1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

Les derniers dossiers:

Problème de fusion word excel 2004

Discussion dans 'Bureautique, utilitaires, éducation' créé par cécile33, 5 Janvier 2008.

Modérateurs: Aliboron
  1. cécile33

    cécile33 Membre Junior

    Messages:
    10
    J'aime reçus:
    0
    Score des trophées:
    0
    Meilleures réponses:
    0
    Bonjour,

    Je rencontre un problème lors de la fusion entre ma source de données Excel (adresse, nom, etc...) et Word. Lorsque je suis dans Word dans le Menu Gestionnaire de Fusion de données. Je choisi le type Lettre, puis la source (fichier Excel sous format Texte séparateur Tabulation pour éviter des pbs d'affichage des dates et monnaie), à ce moment dans Insérer un champ de fusion Word met des Champs de fusion automatique au lieu de ceux de Excel et la fusion devient impossible puisqu'il ne reconnait pas le nom de mes champs de fusion Excel...
    Auparavant je n'avais aucun problème, cela avait toujours fonctionné, je ne comprends pas d'où vient le souci, séparateur de champs ? séparateur d'enregistrement ?
    J'ai besoin d'un gros coup de pouce car je m'en sert pour mon boulot et je me retrouve coincée...
    J'utilise Mac OSX et Word et Excel 2004 for Mac

    Merci beaucoup...
    Cécile​
     
  2. Aliboron

    Aliboron Chercheur de son Modérateur Club MacG

    Messages:
    11 324
    J'aime reçus:
    438
    Score des trophées:
    285
    Meilleures réponses:
    12
    Appareil(s) Apple:
    iMac, Mac mini, iPhone
    Bonjour, et bienvenue sur les forums de MacGénération !!!

    Je pense qu'il faudrait que tu nous donnes quelques précisions. Pour ma part, je ne rencontre pas ce problème et n'arrive pas à le reproduire. Ni avec une source en texte tabulé ni avec un classeur Excel directement d'ailleurs.

    Je ne vois pas ce que peuvent être les "champs de fusion automatique" auxquels tu fais allusion (chez moi, c'est bien la première ligne du tableau qui donne les intitulés et ensuite, je visualise les données - texte, date ou nombres - en cliquant sur le bouton "ABC" de la partie "Aperçu" du "Gestionnaire de fusion de données").

    Est-ce que ta version d'Office est bien à jour (en version 11.3.9 actuellement) ? Quelle est ta version de Mac OS X ?
     
  3. cécile33

    cécile33 Membre Junior

    Messages:
    10
    J'aime reçus:
    0
    Score des trophées:
    0
    Meilleures réponses:
    0
    Bonsoir,

    J'avoue que je ne suis pas super calée, il faudra que je vérifie ma version de Mac OSX, c'est l'ordinateur de mon boulot ( à la maison c'est PC :rolleyes: ) Je pourrais en dire plus lundi, par contre il n'y a que Word et Excel sur le mac, nous n'avons pas tout le pack office...

    Les champs de fusion automatique c'est quand on est dans le gestionnaie de fusion de données après avoir choisi le fichier source, on peut ajouter les champs de fusion dans le fichier cible (Word, le courrier), d'habitude il indique les noms donnés dans le fichier Excel: 1ère ligne du tableau avec Nom, adresse, tél etc... Maintenant Word me met ChampFusion Automatique 1 2 3.... au lieu de ceux du fichier Excel, donc quand je veux faire la fusion il ne trouve plus les champs et m'affiche une boite de dialogue qui m'indique que les champs sont introuvables. Je suis un peu désespérée... Cela avait toujours fonctionné et j'ai juste les salaires à faire la semaines prochaine... arghhh
    Help!
    merci encore
    Cécile​
     
  4. Aliboron

    Aliboron Chercheur de son Modérateur Club MacG

    Messages:
    11 324
    J'aime reçus:
    438
    Score des trophées:
    285
    Meilleures réponses:
    12
    Appareil(s) Apple:
    iMac, Mac mini, iPhone
    Ah, probablement un lien rompu, alors. Le mieux est probablement de le recréer. C'est à dire de reprendre le document Word et, dans la partie "Source de données" > "Lire les données", revenir à "Ouvrir la source de données..." pour refaire la sélection du fichier Excel.

    A tout hasard, tu peux tout de même faire quelques unes des manips de base, si le problème persiste : Réparer les autorisations, renommer le document "Normal"... Mais je ne pense pas que ce soit nécessaire dans ce cas-là, je crois que ça va se résoudre assez facilement (ça me fait penser à un cas similaire que j'ai eu à résoudre cette semaine sur une fusion Word... sur PC) ;)
     
  5. cécile33

    cécile33 Membre Junior

    Messages:
    10
    J'aime reçus:
    0
    Score des trophées:
    0
    Meilleures réponses:
    0
    Bonsoir,

    Hélas le problème est plus compliqué car cela dysfonctionne pour tous mes courriers ! Je crois que le problème est général... peut être dans les Préférences de Word ? mais je ne vois pas quoi... Quelque soit le fichier Excel et le fichier Word ça ne marche pas...
    J'ai un big problème :$

    Merci en tout cas de t'intéresser à mon cas (désespéré) !

    Cécile​
     
  6. Aliboron

    Aliboron Chercheur de son Modérateur Club MacG

    Messages:
    11 324
    J'aime reçus:
    438
    Score des trophées:
    285
    Meilleures réponses:
    12
    Appareil(s) Apple:
    iMac, Mac mini, iPhone
    Essaye de renommer les préférences de Word (c'est équivalent à les supprimer, mais plus facilement réversible si nécessaire) ainsi que le document "Normal"... En gros, cela revient à avoir un Word tout neuf, comme s'il venait de sortir de sa boîte.
     
  7. cécile33

    cécile33 Membre Junior

    Messages:
    10
    J'aime reçus:
    0
    Score des trophées:
    0
    Meilleures réponses:
    0
    Bonjour,

    Que faut-il faire concrétement, suis vraiment nulle en Mac...
    Et est-ce qu'il n'y a pas un risque de "tout faire sauter" ??? Est-ce que la manip' est innoffensive car C l'ordi du boulot et si je le plante je crois C mon patron qui va me planter... :$

    Merci​
     
  8. Aliboron

    Aliboron Chercheur de son Modérateur Club MacG

    Messages:
    11 324
    J'aime reçus:
    438
    Score des trophées:
    285
    Meilleures réponses:
    12
    Appareil(s) Apple:
    iMac, Mac mini, iPhone
    Il faut quitter Word puis aller dans ~/Bibliothèque/Preferences" (~ symbolise le dossier utilisateur, la "petite maison"). Là, renommer les fichiers de préférences dont le nom commence par com.microsoft...., par exemple en rajoutant -ex à la fin. Même chose pour le dossier Microsoft qui se trouve là aussi, et même chose encore pour le document Normal qui se trouve dans ~/Documents/Données utilisateurs Microsoft.

    Le fait de modifier le nom fait que, au prochain lancement de Word, ces documents ne seront pas reconnus, donc il s'en recréera de tous nouveaux. On peut aussi déplacer les documents (par exemple sur le bureau), cela aura le même effet. En cas de problème, on peut facilement faire machine arrière en rétablissant le nom d'origine (ou en remettant en place les documents déplacés).

    Tu peux aussi faire une réparation des autorisations de ton disque de démarrage : dans l'outil /Applications/Utilitaires/Utilitaire de disque, onglet SOS, il y a un bouton "Réparer les autorisations". Tu sélectionnes dans la partie gauche le disque dur et tu cliques sur le bouton. L'opération prend quelques minutes et est totalement inoffensive. Mais ça résout parfois bien des problèmes.

    Pour bien comprendre les manips de base sur Mac OS X, voir le site Rhinos, très bien fait pour aider les néophytes.


    Non. La suppression des préférences est, avec la réparation des autorisations, la manip de base en cas de souci. En effet, ce sont des fichiers qui sont très régulièrement ré-enregistrés et donc sujet à corruption. En remettant les choses à blanc, on rétablit bien des soucis. Dans le cas particulier de Word, un bon nombre de paramétrages sont mémorisés dans le document Normal, c'est pour ça qu'il est lui aussi sujet à corruption et qu'il faut donc lui aussi le supprimer (ou le renommer, etc.)​
     
  9. cécile33

    cécile33 Membre Junior

    Messages:
    10
    J'aime reçus:
    0
    Score des trophées:
    0
    Meilleures réponses:
    0
    Bonsoir,
    Bon je n'ai pas osé faire toutes ces manip' mais cela m'a permis de me familiariser avec la navigation dans Mac.
    Par contre j'ai bidouillé un peu sur mon problème et je crois avoir compris le problème sans pouvoir le résoudre pour autant...
    Cela doit venir de Word, j'ai l'impression qu'il ignore la ligne d'en-tête du fichier Excel, celle qui contient le nom des champs (Nom, tél) du coup il met ChampFusionAuto à la place... Mais je n'ai pas la solution...

    Une idée ?

    Merci

    Cécile​
     
  10. boddy

    boddy Accro à MacG Club MacG

    Messages:
    3 676
    J'aime reçus:
    347
    Score des trophées:
    270
    Meilleures réponses:
    5
    Bonjour,
    C'est vraiment dommage, tu devrais quand même essayer de supprimer les préférences et le document Normal...
    Ici, tu trouveras une explication pour ton problème de ChampFusionAuto, mais c'est pour PC... Peut-être que ça donnera une idée à des macgéens plus calés que moi !
    Comme Aliboron j'ai essayé de reproduire ton problème, mais je n'y arrive pas... tout marche nickel pour moi...
    Je ne comprends pas ce que tu dis dans ton message : "fichier Excel sous format Texte séparateur Tabulation". Tu trouves ça où ?
     
  11. Aliboron

    Aliboron Chercheur de son Modérateur Club MacG

    Messages:
    11 324
    J'aime reçus:
    438
    Score des trophées:
    285
    Meilleures réponses:
    12
    Appareil(s) Apple:
    iMac, Mac mini, iPhone
    Excel, "Fichier"> "Enregistrer sous...", dans les "Formats" proposés ;)

    Reste que je ne vois pas trop l'intérêt dans le cas présent. Mais j'ai fait les tests avec les deux formats sans voir de différences...
     
  12. Aliboron

    Aliboron Chercheur de son Modérateur Club MacG

    Messages:
    11 324
    J'aime reçus:
    438
    Score des trophées:
    285
    Meilleures réponses:
    12
    Appareil(s) Apple:
    iMac, Mac mini, iPhone
    Une piste, trouvée sur le forum microsoft.public.fr.word :

    Si vous avez décoché " La première ligne contient les en-têtes de
    colonnes" Word donnera des noms automatiques numérotés à vos champs.
    Cochez Outils / Options / Général / Confirmer les conversions lors de
    l'ouverture , puis reconnectez votre base de données en cochant
    cette option selon la voie d'accès choisie


    Bon, dans les versions Mac, c'est dans les "Préférences..." que ça se passe, mais ça mérite certainement d'y jeter un coup d'oeil. Pour ma part, je regarderai ça ce soir.
     
  13. boddy

    boddy Accro à MacG Club MacG

    Messages:
    3 676
    J'aime reçus:
    347
    Score des trophées:
    270
    Meilleures réponses:
    5
    [​IMG]
    J'ai beau cocher et décocher la Mise à jour des liaisons à l'ouverture et/ou la Confirmation des conversions... je n'arrive toujours pas à reproduire le problème !
    Ca m'a permis aussi de voir l'utilité d'enregistrer en Format texte séparateur : tabulation. C'est très limité ! Certes, on fait un tableau facilement, mais il faut recommencer à chaque fois une nouvelle base de donnée dans Word, puisque les changements dans Excel ne sont pas pris en compte.
    Le plus simple, c'est ce que je conseillerais à Cécile33 (toujours pas virée j'espère :rateau:) c'est tout simplement de faire un copier-coller : dans Excel, copier toutes les cellules et les coller dans Word. Tu auras ton tableau tout fait et il n'y aura plus qu'un peu de présentation (?) à faire.

    Aliboron si tu arrives à reproduire le problème, on attend ta procédure... de mise en panne... pour comprendre le pourquoi du comment :D:D:D
     
  14. Aliboron

    Aliboron Chercheur de son Modérateur Club MacG

    Messages:
    11 324
    J'aime reçus:
    438
    Score des trophées:
    285
    Meilleures réponses:
    12
    Appareil(s) Apple:
    iMac, Mac mini, iPhone
    Cette manip ne sert qu'à avoir la main sur l'option "La première ligne contient les en-têtes de colonnes" au moment de l'import des données, d'après le fil (c'est ça qu'il faudrait donc contrôler).

    Le problème, si j'ai bien compris, n'est pas d'importer les données dans un document Word en tant que telles. C'est de faire une fusion (un puiblipostage, si tu préfères). Il faut avoir un fichier Excel enregistré quelque part qui sert comme "Source de données" lors de la création d'une fusion. "Pour ne pas être embêtée avec les formats de date et de monnaie", Cécile33 (toujours pas virée, j'espère aussi ;)) préfère enregistrer sous le format texte tabulé, mais un bête classeur Excel convient bien (du moins pour les tests que j'ai fait, mais il est vrai que les montants importés comme ça posent parfois problème, le séparateur décimal US prenant le dessus dans les documents fusionnés - ceci dit il me semble que ce n'est plus le cas, il va falloir que je vérifie ça aussi...)
     
  15. Aliboron

    Aliboron Chercheur de son Modérateur Club MacG

    Messages:
    11 324
    J'aime reçus:
    438
    Score des trophées:
    285
    Meilleures réponses:
    12
    Appareil(s) Apple:
    iMac, Mac mini, iPhone
    Bon, j'ai réussi à reproduire le problème des "ChampFusionAuto" !

    En fait, c'est une erreur de manip qui est (probablement) à l'origine de tout ça.
    Quand on crée une fusion, lorsqu'on choisit un classeur il demande de choisir la feuille à partir de laquelle on veut prendre les données. Il se trouve que, sur la version Mac, cette fonction marche (contrairement à la version Windows où on est obligé de prendre les données sur la première feuille du classeur). Mettons qu'on choisit de prendre les données sur la troisième feuille.

    La prochaine fois qu'on ouvre le document de fusion, on a le dialogue "Ouvrir un classeur" qui s'ouvre et propose la première feuille du classeur. Si on accepte, il ne trouve évidemment pas les champs Et c'est là qu'il remplace les champs par des "ChampFusionAuto". Si on clique sur le bouton "ABC" de la partie "Aperçu", un dialogue s'ouvre et propose de remplacer les champs qu'il ne trouve pas par ce qu'il a sous la main. Si la feuille contient des en-têtes de colonnes cohérentes, il les propose, sinon, ce sont les fameux "ChampFusionAuto".

    Moralité : pour reconstituer le document, il faut bien ouvrir le bon document source de données, choisir le cas échéant la bonne feuille (!!!) et, si nécessaire grâce au bouton "ABC" de la partie "Aperçu", remettre les bons champs de fusion aux bons endroits. Bref, ça marche !

    Et voilà pourquoi votre fille est muette :D
     
  16. cécile33

    cécile33 Membre Junior

    Messages:
    10
    J'aime reçus:
    0
    Score des trophées:
    0
    Meilleures réponses:
    0
    bonsoir,​

    whaou ! Je suis impressionnée ! Merci, vous vous donnez du mal pour résoudre mon problème C vraiment sympa.​

    Bon je n'ai plus qu'à imprimer tout ça et à m'y coller demain au taf ! A la maison je ne peut rien faire je suis sous PC ! (houuuu !)​

    Je vais aller aussi voir le lien chez Microsoft. On est près du but...

    Il me semble que ça doit peut avoir un lien avec les conversions à l'ouverture, les Préférences C celles de Word ?
    et euh C quoi le bouton ABC de la partie Aperçu ?

    Merci Aliboron et Boddy...
    Je vous tiens bien sûr au courant... Virée ou pas...?!! ;)
     
  17. Aliboron

    Aliboron Chercheur de son Modérateur Club MacG

    Messages:
    11 324
    J'aime reçus:
    438
    Score des trophées:
    285
    Meilleures réponses:
    12
    Appareil(s) Apple:
    iMac, Mac mini, iPhone
    Oui. Mais honnêtement, ce n'est pas utile. Il suffit de remettre les "bons" champs de fusion en place (attention à ce qu'il y ait bien les en-têtes sur la première ligne) pour que les choses rentrent dans l'ordre.

    Dans le "Gestionnaire de Fusion de données", tu as plusieurs parties : "Document principal", "Source de données", etc. C'est là que tu trouves "Champs de fusion" avec la liste des champs disponibles dans le document source. Tu les fais glisser vers l'emplacement voulu.

    Eh bien justement, dans le "Gestionnaire de Fusion de données", l'avant-dernière partie, c'est "Aperçu". Si tu la déploies (en cliquant sur le petit triangle) tu vois les commandes permettant de voir les champs en cliquant sur le premier bouton "ABC" (ensuite, tu peux naviguer avec les flèches).
     
  18. cécile33

    cécile33 Membre Junior

    Messages:
    10
    J'aime reçus:
    0
    Score des trophées:
    0
    Meilleures réponses:
    0
    Bonjour,

    Bon ça marche toujours pas !
    J'ai essayé les conversions à l'ouverture... fonctionne pas...

    C justement cet endroit que je me retrouve avec ChampFusionAuto au lieu de mes champs de fusion ! Dans le document Word, ils sont nickels, ma ligne d'en-tête dans Excel aussi et au moment où je suis dans le gestionnaire de fusion nada !
    Et quand j'ai plusieurs feuilles dans mon classeur Excel, Word me demande laquelle je veux pour effectuer la fusion... Donc pas de souci de ce coté là

    J'y comprend rien !
    J'ai également essayé d'enregistrer uniquement ma ligne d'en tête dans Excel effaçant le reste du doc, comme ça une fois dans Word je choisi et ma source de données pour le doc et ma source d'en-tête... marche pas non plus...

    Je ne sais pas quoi faire...

    Est-ce que si je désinstalle Word il y a un moyen d récupérer tous mes Styles et mes Corrections automatiques? Car j'en ai une tonne dont j'ai besoin pour bosser... :(

    Merci encore
    Cécile​
     
  19. Aliboron

    Aliboron Chercheur de son Modérateur Club MacG

    Messages:
    11 324
    J'aime reçus:
    438
    Score des trophées:
    285
    Meilleures réponses:
    12
    Appareil(s) Apple:
    iMac, Mac mini, iPhone
    Et si tu cliques alors sur "ABC" que se passe-t-il ?

    Et dans la liste des champs proposés (partie "Champs de Fusion") ? Normalement, si les choses sont en ordre dans le fichier source cela devrait correspondre. Pas dans le document lui-même dans un premier temps. Mais dans le choix des champs de fusion, tu devrais retrouver ce qui te manque et pouvoir reconstituer ton document.

    Mais pourquoi désinstaller Word ? On n'est pas sous Windows, il n'y a pas de comportement "magique" et la désinstallation n'apporte pour ainsi dire jamais de solution à un problème, dans la mesure où le problème est généralement dans les paramétrages et réglages divers.

    Il te faut plutôt chercher à localiser précisément le souci. Dans une certaine mesure, même, c'est souvent dans les fichiers qu'on conserve (en particulier le document "Normal") que se cachent les corruptions. Mais dans le cas présent, vu les tests que j'ai fait je suis à peut près sûr qu'il n'y a pas de souci de ce côté-là, il te faut reconstituer les champs (comme indiqué plus haut) dans ton document initial de fusion. Si tu repars de zéro et refais une fusion quelconque dans un document vierge, ça marche ?
     
  20. cécile33

    cécile33 Membre Junior

    Messages:
    10
    J'aime reçus:
    0
    Score des trophées:
    0
    Meilleures réponses:
    0
    Bonsoir,

    des nouvelles fraiches... :)

    J'ai suivi votre conseil de repartir de zéro. J'ai retenté la fusion à partir de fichiers que j'ai complétement recréé. Nouveau doc principal sous Word et nouvelle source de donnée sous Excel.

    La bonne nouvelle c'est que cela a fonctionné, Word a retrouvé les bons champs de fusion après avoir ouvert la boite de dialogue "Ouvrir un classeur" et j'ai choisi la première feuille du classeur (de toute façon je n'en avait créé qu'une).

    La mauvaise nouvelle C que j'ai retenté l'opération en enregistrant mon ficher Excel sous format Texte: séparateur Tabulation (nous l'appellons trash, car C un fichier que l'on met à la "poubelle" ensuite, il n'a pas vocation à être conservé) toujours pour les problèmes d'affichage de date et monnaie.
    Et bien là Word ne reconnait plus les champs de fusion d'Excel et me met à nouveau ChampFusionAuto dans la partie "Champs de fusion" du Gestionnaire de fusion de données.

    voilà les nouvelles du front...

    Cécile​
     
Modérateurs: Aliboron

Partager cette page

iOccasion - Achetez un produit Apple d'occasion

Les derniers deals sur Ebay