Mac Pro 4,1 -> 5,1 - Install Catalina KO

emmanuelvbv

Membre junior
6 Mars 2009
24
0
ché le Nord :)
Bonjour à tous,

tout d'abord désolé je présume qu'il dois y avoir d'autre sujet la dessus mais j'ai l'impression que la recherche sur ces forums est ko en ce moment ? ou alors personne en a parlé mais j'en doute.

J'ai un Mac Pro de 2009 (mono-CPU w3520) que j'ai flashé il y a longtemps en 5.1 vu que j'était sur Mojave il y 1 heures lol (quelle idée de formater :))
J'ai un peu upgradé ce mac pro, en ajoutant :
- une carte pci express 1x sata3 pour mettre mon SSD en sata 3 plutot que sata d'origine.
- une carte pci express 1x usb3 4 ports
- et mon ancienne Nvidia GeForce GTX770 2 Go que j'avais dans mon PC compatible metal 2, mais sans le bios efi (j'ai encore la GT120 d'origine au cas où) :)

J'ai télécharger le fameux dosdude1 catalina partcher http://dosdude1.com/catalina/ et j'ai suivi les instructions.
et là c'est le drame :

j'ai formaté mon disque (pas grave au pire je remettrai Mojave) et j'ai cliqué sur réinstall mac os et là j'ai ce beau message d'erreur :

this mac is configured in a way that is incompatible with macos catalina

Du coup je suis bloqué, dommage je voulais booster ce mac en mettant un ssd mvne avec une carte pci express plus rapide et je pensais aussi a changer le cpu par un x5690 qui se trouve dans les 50-60 €.

Vous auriez des idées ou je dois repasser sur Mojave ?? en vous remerciant d'avance :)
 

Lil Montréal

Membre confirmé
14 Juin 2019
258
89
67
Bon Matin :coucou: ,

Mais quelle idée de vouloir installer le dernier OS non finalisé sur une machine qui ne le supporte doublement pas :
- MP 4.1 2009 même passé en 5.1
- Même sur le 5.1 2012 je ne m'y risquerai pas à l'heure actuelle.

Il a fallu attendre Mojave en 10.14.6 (2 versions en 10.14.6) pour que tout soit stable !!!

Avec 10.14.6 il faut obligatoirement passer les Nehalem en Westmere

Amitiés
 
  • J’aime
Réactions: mariol66 et Y_E_S

mariol66

Membre émérite
15 Août 2015
786
132
40
Gironde
Perso, je suis resté sur Mojave et ne compte passer à Catalina. Comme le dit @Lil Montréal, Catalina n’est pas compatible nativement avec nos MacPro sans parler du fait qu’il est jeune et donc plus à même d’être buggé.
A passer à Catalina, j’aurais utiliser uniquement la combine qui consiste à l’installer à partir d’un Mac compatible et de faire le transfert de disques entre les Mac. Les solutions autres sont trop sujets à problème, du moins pour le moment de ce que j’en ai lu.
Trop d’incertitudes en plus il ne me semble pas que l’on ai vraiment à gagner à passer sur Catalina par rapport à Mojave.
 
  • J’aime
Réactions: Lil Montréal

Lil Montréal

Membre confirmé
14 Juin 2019
258
89
67
Bon Matin :coucou:

Je pense que Catalina est parfaitement adapté au MP 7.1 et au MBP 16" ainsi qu'aux nouvelles machines qui sortiront.

Apple, dans sa grande sagesse, et en dépit de ce que disent les mauvaises langues, nous a fait un grand cadeau avec Mojave qui tourne parfaitement sur nos MP 4.1 et 5.1.
Ces machines de 10 ans déjà, vont être encore très performantes (*) par rapport à des machines récentes et pendant au moins cinq ans encore.

Amitiés

(*) Bien upgradées aussi, avec CPU(s), GPU, RAM, RAID SSD en PCIe, carte BT et WiFi récentes, etc ...
 
  • J’aime
Réactions: VLuc et Y_E_S

emmanuelvbv

Membre junior
6 Mars 2009
24
0
ché le Nord :)
Bonjour

Merci pour vos réponses, j'ai réinstallé Mojave.

Je vais voir si j'upgrade cpu et disque en mvne, ou si je revends mon mac pro, j'ai mon macbook air qui commence a être limite car j'ai changer de boitier reflex, mais les macbook du moment avec le clavier a problèmes je ne me vois pas changer tout de suite.
 

Y_E_S

Membre confirmé
20 Juillet 2008
276
27
Paris
Bonjour

Merci pour vos réponses, j'ai réinstallé Mojave.

Je vais voir si j'upgrade cpu et disque en mvne, ou si je revends mon mac pro, j'ai mon macbook air qui commence a être limite car j'ai changer de boitier reflex, mais les macbook du moment avec le clavier a problèmes je ne me vois pas changer tout de suite.

Je ne sais pas combien de ram ton Mac Pro a, mais c'est le premier upgrade à faire, avec beaucoup de ram le gain est très significatif...
La Ram actuellement pour ces machines ne vaut plus rien...
Ensuite pour le disque NMVe, j'ai mis celui-ci avec cette carte sur le PCIe 4, j'ai des débits lecture/écriture à 1500Mbs, ça aussi ça met une jolie claque à la machine...


(Je l'ai payé 110 euros avant la fin d'année, à 130 euros je pense qu'il vaut mieux prendre un Samsung EVO pour la faible différence de prix.)

Sur cette carte, et ça marche nickel...

 

Leonardi Lino

Nouveau membre
27 Février 2020
6
1
30
Bon Matin :coucou: ,

Mais quelle idée de vouloir installer le dernier OS non finalisé sur une machine qui ne le supporte doublement pas :
  • MP 4.1 2009 même passé en 5.1
  • Même sur le 5.1 2012 je ne m'y risquerai pas à l'heure actuelle.

Il a fallu attendre Mojave en 10.14.6 (2 versions en 10.14.6) pour que tout soit stable !!!

Avec 10.14.6 il faut obligatoirement passer les Nehalem en Westmere

Amitiés
Bonjour. Pourquoi dire cela des mac pro 2009 flashé en 5.1? Car je lis ici et là que la procédure est assez risquée mais une fois effectuee aucune différence materielle entre le 2009 et un mi 2010.
Est ce faux?
Cordialement
 

Lil Montréal

Membre confirmé
14 Juin 2019
258
89
67
Hello :coucou: ,

Parce que les 2009, 2010 et 2012 sont 3 machines différentes, même si l’architecture et les schémas sont les mêmes, et même si sur Mactracker les caractéristiques fondamentales sont les mêmes :

- Différentes par le hard : carte wifi et bluetooth différentes, CPU différentes avec et sans IHS, différentes quant à la gestion des RAM entre les Nehalem et les Westmere, différentes par les slots PCIe 1 et 2 sur un 2009 et différentes sur les slots 3 & 4 entre un 2010 et un 2012. On trouve même une différence entre un 2012 de juin 2012 et un 2012 de février 2013.
Tu ne peux pas échanger un tiroir CPU-RAM entre un 2009 et un 2010, ni même entre un 2010 et un 2012.
La RAM d’un 2009 ne fonctionne pas parfaitement en 1333 MHz et tu ne peux pas gérer 64 Go de RAM avec un 2009 même avec un X5690 (sans IHS bien sûr). Pourquoi ? Je n’en sais rien.
Tu peux parfaitement faire fonctionner une carte RAID 0 (7101A) en Slot 1 (à environ 5000 MB/s en R/W) avec la GPU en slot 2 ou même en slot 4 (en bricolant l’équerre) sur un 2012, mais pas sur un 2009 (je ne me rappelle plus sur un 2010).

- Différentes par le firmware : wifi et bluetooth différents, Airplay ne fonctionne pas sur un 2010 même avec la dernière MàJ en 10.14.6. Seuls les derniers 2012 (qui sont de 2013) fonctionnent avec Airplay, je ne parle pas d’Airdrop.
Les ID des tiroirs CPU(s) et RAM sont différents sur les 3 machines.
Impossible d’échanger un tiroir de 2010 avec un tiroir de 2012 avec les mêmes composants (CPU(s) et RAM) ???
Si tu veux changer un mono CPU en bi-pro, il faut le tiroir de la même année sinon cela ne marche pas, etc …
Je soupçonnerais même Apple d’avoir été perméable entre les Early 2009 et les Mid 2010 et entre les Mid 2010 et les Mid 2012 dont certains ont été fabriqués en 2013.

C’est lorsque tu utilises toutes les ressources que tu t’aperçois des différences entre un OS qui était stable et un nouvel OS qui fonctionne à peu près sur une machine et pas certaines Apps sur le même modèle de machine, séparé par quelques mois de fabrication.

Je tire mon chapeau aux Ingénieurs Apple pour nous avoir donné un OS hyper stable, Mojave en 10.14.6, sur des machines de plus de 10 ans avec toutes les variantes matériels de ces machines :merci:.
Mais pour l’heure je ne me risquerai pas à Catalina sur un MP 5.1 même sur un 2012.

La dernière version de FCPX (10.4.8) est une véritable réussite sur le MP 5.1 sous Mojave.
ProRender d’AMD est une réussite avec Metal2 même si nous voudrions que Blender 2.81 soit encore plus rapide dans les très gros rendus.
La suite Affinity est une réussite avec Metal.
Les 12 coeurs et la GPU fonctionnent parfaitement de concert dans ces Apps modernes.

Catalina a été développé pour le MBP 16" et pour le MP 7.1.
Il nous faudra bien un jour abandonner nos « camions » pour des 7.1, mais de tous les Macs que nous avons eu (depuis 34 ans), ceux-ci ont vraiment été des machines fantastiques :up:.

Pour le moment, les essais de Catalina sur nos MBP, en usage professionnel, ne sont pas convaincants par rapport à Mojave :sorry:.

Amitiés
 

Leonardi Lino

Nouveau membre
27 Février 2020
6
1
30
Ah effectivement! Autant pour moi. Le nombre de differences ont mm perdu l'utilisateur lambda que je suis.

Je reagissais à ce post car j'essaie de mettre un peu au goût du jour un Mac pro 2009 reconditionné et acquis en 2018.
Un double hexacore 2.66 intel xeon flashé en 5.1 par le vendeur. Jusqu'ici je n'avais pas de problème le jour et la nuit par rapport à mon ancien imac 2014 quadicoeur i5. Jusqu'a récemment en ayant acheté une toute récente surface de control par ethernet avid (eucon,protools..) qui n'est pas reconnue.

J'ai donc pensé qu'il y avait un problème d'incompatibilité. Depuis je cherche à upgrade vers un os qui reconnaîtraI la machine . Mais peut être que je me trompe.

Pour l'instant j'ai monté la ram de 24 à 32,mm barrettes mm num de serie

J'ai commandé une sapphire amd radeon pulse 580 et la connectique correspondante dont j'attends la livraison.

J'ai tout récemment installé High sierra via l'Apple store sans aucun problème j'ai suivi les instructions redemarrage un peu long mais tout s'est bien passé.

Par contre je l'ai acheté sans carte wifi/réseau et je fais passer la connection par un pauvre dongle usb et j'ai lu que certains périphérique àvient besoin de reconnaître une carte réseau.
Je compte en acheter une mais je ne sais pas laquelle,
puisqu il semble aussi que le placement d'une carte aux normes recentes aille dans le sens d'une installation propre.


Est ce que je fais fause route?
Si quelqu'un a une idée en espérant que ma question ne soit pas trop hors thème. Merci
 

Shadownet

Membre junior
13 Juillet 2018
90
8
45
La première chose à faire avant d'installer catalina sur un macpro 5,1 est de désactiver le SIP.

Je l'ai fait sur mon 5,1 et il fonctionne aussi bien que mojave (mais j'ai attendu 10.15.3 avant de le faire).

Pour ma part je l'ai fait car mes autres machines tournent sous catalina aussi et le transfert de librairie photo est plus simple s'ils sont tous dans la même version de l'OS.