Accès à un partage Samba Windows depuis OS X 10.4.11

ThibaudC

Membre confirmé
12 Décembre 2011
91
2
Région parisienne
Bonjour,

Il y a là un gros pavé, mais c'est parce que je détaille tout, ne vous inquiétez pas, ça se lit tout seul :rateau: !

J'explique :

- Un serveur W2K8R2 contrôleur de Domaine (mon_domaine.local)
- Un iBook G4 (PowerPC, donc) sous Mac OS X 10.4.11, intégré à mon_domaine.local

Un partage samba est en place sur le serveur, et il fonctionne très bien car d'autres ordinateurs y accèdent sans problèmes [Windows XP/7 comme Mac OS X 10.5 et supérieur, tournant sur différents Macs (MacBook Blanc, MacBook Pro, MacBook Air) plus ou moins vieux].

Mon petit iBook, robuste comme il est, tourne bien, est bien connecté au réseau, ping le serveur, et tutti-conti ! Je dois donc monter le Partage Windows sur l'iBook, via l'outil "Se connecter au serveur" :

cmd-K > "Adresse du serveur" : smb://ip_serveur > "Se connecter"

Mac OS se connecte au serveur, et m'affiche la petite fenêtre "Authentification du système de fichiers SMB/CIFS" avec 3 champs renseignés comme suit:
- Groupe de travail ou Domaine : "MON_DOMAINE" (sans le .local et en majuscules)
- Nom : "MON_USER" (en majuscules, existant et fonctionnel)
- Mot de passe : le mot de passe lié au compte, existant et fonctionnel, car testé avec succès sur une machine plus récente.

Et lorsque je valide, message d'erreur indiquant : "Impossible de se connecter au serveur en raison d'une erreur dans le nom ou dans le mot de passe."


Lorsque je me rends dans "Format de répertoire", option "Active Directory", les 3 champs "Forêt AD", "Domaine AD" et "ID de l'ordinateur" sont correctement renseignés, et l'ont me propose de "Rompre la liaison..." si je le souhaite.
Les autres options cochées sont :
- Apple Talk
- Bonjour (coché et grisé)
- LDAPv3
- SLP
- SMB/CIFS => et dans cette option le champ "Groupe de travail" contient "MON_DOMAINE.LOCAL", tandis que "Serveur WINS" est laissé vide.

Je sais que les partages samba avec ces vieilles bébêtes sont assez casse-tête...

Avis donc à vos expériences et vos connaissances pouvant me sortir de là !

Mercii !
 
Dernière édition:

ThibaudC

Membre confirmé
12 Décembre 2011
91
2
Région parisienne
Pour les plus curieux d'entre nous, je vous présente la solution :

Lorsqu'un ordinateur se connecte à un partage SMB sous W2K8 il y a, par défaut, une transmission de paquets signés et sécurisés.
Or, les anciennes versions d'OS Windows, ou les vieilles versions d'OS non-Windows (Linux, Mac OS, pour ne citer qu'elles), ne prennent point en charge ladite transmission signée et sécurisée.

Il faut donc aller jouer avec les GPO (gpmc.msc) du 2008 Server pour désactiver ce zèle de sécurité !

Dans "Default Domain Policy > Modifier > Conf ordinateur > Stratégies > Paramètres Windows > Paramètres de Sécurité > Stratégies locales > Options de sécurité"

Il faut ensuite passer en "Désactivé" les deux points suivants (mais les paramètres doivent être Défini !!) :
- Membre de domaine : chiffrer ou signer numériquement les données des canaux sécurisés (toujours)
ET
- Serveur réseau Microsoft : communications signées numériquement (toujours)

Puis appliquer ladite GPO sur l'Unité d'Organisation de l'AD qui va bien, faire un gpupdate /force, et hop, le tour est joué !

Un jeu d'enfant n'est-ce pas ?! Et il ne m'aura fallu que 2 semaines pour m'en sortir !!! :)