macOS Big Sur Accès impossible à "Sécurité & confidentialité" sur macOS Big Sur 11.2.3

iSomeday

Membre junior
30 Novembre 2013
45
6
Bonjour,

Je fais face actuellement à un problème que je n'arrive pas à résoudre.

Il m'est impossible d'accéder aux préférences "Sécurité & confidentialité" depuis une mise à jour des pilotes USB (Eltima LLC) de l'application Shadow PC.

Au moment d'approuver l'installation, j'ai été conduis vers ce panneau qui ne se charge plus (le comble c'est que 5min avant j'ai approuvé l'accès au micro pour une application via ce panneau...)

J'ai depuis réussi à supprimer ses pilotes pensant être le coupable mais rien, le problème persiste.

Le mode sans échec n'a quand à lui rien arranger, une nouvelle session non plus ainsi que la suppression du fichier com.apple.systempreferences.plist.

J'ai même supprimé l'application Shadow dans le doute mais rien n'y fait.

Je suis complètement au bout des solutions que j'ai trouvées sur internet et c'est donc pour cela que j'en viens à demander votre aide.

Merci beaucoup.

OS : macOS Big Sur 11.2.3
MacBook Pro 15' 2016
Shadow Bêta (dernière version en date)

Prefs panel error.png
 
Dernière édition:

mokuchley

Membre d’élite
Club MacG
27 Août 2010
4 438
306
il faut réinitialiser macOS en passant par CMD+R au demarrage

Penser a faire une sauvegarde avec time machine et/ou CCC
 

iSomeday

Membre junior
30 Novembre 2013
45
6
As-tu essayé de réinstaller BS par-dessus lui-même ?
Donc démarrage avec cmd R, puis installer…
Ah d'accord dans ce sens-là.

Non, je n'ai pas essayé. Mais ce n'est pas un peu "trop facile" pour régler ça ?

En tout cas merci à tous pour votre aide :)

D'où l'intérêt des sauvegardes préalables… ;)
On va prévoir une Time Machine dans tous les cas :)
 
Dernière édition par un modérateur:

mokuchley

Membre d’élite
Club MacG
27 Août 2010
4 438
306
...et une clé USB avec Big Sur dessus... et vous serez paré pour le grand saut
 
Dernière édition par un modérateur:

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
37 346
4 990
Je suppose que je ne pourrai pas restaurer via Time Machine au risque de remettre le problème sur la table ?
SI ta dernière sauvegarde Time Machine contient cette version de Shadow en version bêta, tu vas réinjecter le même problème !

Tu as exécuté les commandes du Terminal du lien en réponse #12 ?
 

iSomeday

Membre junior
30 Novembre 2013
45
6
C’est possible de sélectionner une sauvegarde plus ancienne, par hasard ?
 
Dernière édition par un modérateur:

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
37 346
4 990
C’est possible de sélectionner une sauvegarde plus ancienne, par hasard ?
Bien sûr que oui, mais il te faut être sûr qu'elle ne contient pas Shadow. Sinon, relis ma réponse #14 car je l'ai éditée au moment ou tu répondais. ;)
 
Dernière édition par un modérateur:

iSomeday

Membre junior
30 Novembre 2013
45
6
Je pourrais courir le risque d’une sauvegarde début de semaine, tout fonctionnait, et ensuite désinstaller Shadow (ça a planté quand j’ai mis à jours les pilotes USB depuis le launcher) ?

Pour les commandes, j’ai effectué la deuxième mais pas la première car après renseignements cela désactive les extensions et comment je les réactive si le problème est toujours là du coup ? :/
 
Dernière édition par un modérateur:

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
37 346
4 990
Pour les commandes, j’ai effectué la deuxième mais pas la première car après renseignements cela désactive les extensions et comment je les réactive si le problème est toujours là du coup ? :/
Il faut exécuter cette première commande...
Bloc de code:
rm "/Volumes/{HD name}/Library/LaunchDaemons/us.electronic.eveusb.daemon.plist"
...en n'oubliant pas de donner le vrai nom du disque dur et non pas en laissant {nom du DH}, puis enchainer avec celle-ci...
Bloc de code:
reboot
...c'est impératif pour que la première commande soit pleinement exécutée.
 

iSomeday

Membre junior
30 Novembre 2013
45
6
Ces deux là ont été faites, je parlais de celle plus haut disponible dans le lien :)
 
Dernière édition par un modérateur:

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
37 346
4 990
Ces deux là ont été faites, je parlais de celle plus haut disponible dans le lien :)
Pas de précipitation, relis ma réponse précédente. Sinon, est-ce que tu as bien donné le vrai nom, comme par exemple...
Bloc de code:
rm "/Volumes/Macintosh HD/Library/LaunchDaemons/us.electronic.eveusb.daemon.plist"
...après Volumes il faut taper le vrai nom du disque dur.