Accès vpn derrière un NAT, à l'aide !!

MrStone

Membre expert
Club MacG
30 Janvier 2003
2 845
673
46
Gone west
Salut,
je me prends le chou depuis hier poru réussir à faire entrer en communication deux mac avec un serveur distant via un vpn.

Les faits :
réseau d'entreprise hybride, 2 mac et plein de pc, le tout derrière un NAT correctement configuré pour laisser lasser les paquets qu'il faut.

Sur pc, client Checkpoint VPN-1 Securemote déjà paramétré : je donnne mon ID, mon mdp et ça roule, il accède au serveur sans soucis.

Sur macOS9.1 (héééé oui !), client Checkpoint mac, interface imbuvable... après moults essais-erreurs, j'ai réussi à créer une gateway, donné une IP, ID, mdp, (corrigez-moi si je me gourre) a priori rien d'autre n'est nécessaire. Je tente la connexion, qui échoue à l'étape n°1 (négociation avec le firewall distant, si j'ai bien tout compris).

Là je me dis, pas de panique OSX a un client vpn en standard, allons l'essayer : 10.3.5, j'ouvre connexion internet, crée une nouvelle connexion vpn via ipsec, je renseigne ip, login, mot de passe, de toutes façons il n'y a pas beaucoup d'options supplémentaires... J'ai essayé avec et sans secret partagé (si j'ai bon il s'agit du mot de passe qu'on m'a attribué).
Je tente une connexion, qui n'aboutit pas après une mminute de tentative. Le log reste plutôt évasif : Fri Sep 17 10:38:57 2004 : L2TP connecting to server 'xxx.xxx.xxx.xx' (xxx.xxx.xxx.xx)...
Fri Sep 17 10:39:58 2004 : L2TP cannot connect to the server

Ma question : y a-t-il quelque chose que je fais de travers ? Pourquoi ça marche sur un pc lambda et pas sur un mac ? (j'ajouterais même "pourquoi est-ce d'une simplicité incroyable sur pc, alors que moi, le macuser, je suis en train de m'arracher les cheveux depuis hier ???")

Toute aide sera vraiment-vraiment la bienvenue, merci d'avance :zen: :zen: