Airplay fonctionne via iTunes mais n'apparaît plus comme sortie audio globale

A l'aise Breizh

Membre confirmé
1 Juillet 2008
415
11
Marne-la-Vallée
Bonjour,
J'ai cherché en vain une solution à mon problème, aussi je me permets de lancer une nouvelle discussion en espérant poster dans la bonne section du forum.
J'utilise depuis longtemps une borne Airport Express afin de diffuser le son global de mon mac ou de mon iPhone sur des enceintes via Airplay.
Seulement voilà, depuis un mois environ, ma borne Airport Express (et Airplay) n'apparaît plus comme sortie audio dans les préférences système. Pourtant, elle s'affiche et fonctionne parfaitement directement depuis iTunes ou mon iPhone.
Ma borne Airport Express est donc bien reconnue par mon mac (cf. utilitaire Airport) et Airplay fonctionne (via l'icône dans iTunes) mais rien à faire, je n'arrive plus à la sélectionner comme sortie audio globale...
Quelqu'un aurait-il eu la même mésaventure et serait en mesure de m'aider ?
Pour info je tourne sous OS X Yosemite 10.10.2.
Merci par avance.
 
A

Anonyme

Invité
Bonsoir,

as-tu testé : désactiver/réactiver wifi sur le Mac, rebooter Express, rebooter Mac ?

Je suppose que oui, mais c'est pour vérification avant de passer à plus "sérieux".
 

A l'aise Breizh

Membre confirmé
1 Juillet 2008
415
11
Marne-la-Vallée
Effectivement j'ai déjà effectué à plusieurs reprises ces procédures de base, sans résultat !
 
A

Anonyme

Invité
Airplay n'est pas non plus visible en faisant touche Alt + clic sur l'icône son de la barre de menus ?

Une des manips "connues" pour ce problème est la commande suivante dans le terminal :

sudo kill `ps -ax | grep 'coreaudiod' | grep 'sbin' |awk '{print $1}'`

Il faut être dans une session avec droits admin, le mot de passe (password) sera demandé, le taper à l'aveugle, il ne s'affiche pas, puis touche Entrée.

Un redémarrage n'est pas nécessaire.

Par principe et par précaution, on ne passe pas de commandes dans le Terminal si on a aucune sauvegarde de son ordi.
Donc : sauvegarde à jour, ensuite Terminal.
 

A l'aise Breizh

Membre confirmé
1 Juillet 2008
415
11
Marne-la-Vallée
Airplay n'est pas non plus visible en faisant touche Alt + clic sur l'icône son de la barre de menus ?

Une des manips "connues" pour ce problème est la commande suivante dans le terminal :

sudo kill `ps -ax | grep 'coreaudiod' | grep 'sbin' |awk '{print $1}'`

Il faut être dans une session avec droits admin, le mot de passe (password) sera demandé, le taper à l'aveugle, il ne s'affiche pas, puis touche Entrée.

Un redémarrage n'est pas nécessaire.

Par principe et par précaution, on ne passe pas de commandes dans le Terminal si on a aucune sauvegarde de son ordi.
Donc : sauvegarde à jour, ensuite Terminal.

J'avais déjà tenté le Alt + Clic mais ça n'a rien changé.

Je viens de tester la commande dans le terminal et ça n'a pas marché...
 
A

Anonyme

Invité
Je tenterais ça :

Macintosh HD / Bibliothèque / Préférences / Audio

Mettre à la corbeille, sans vider la corbeille :

com.apple.audio.DeviceSettings.plist
com.apple.audio.SystemSettings.plist

Redémarrer.
 

A l'aise Breizh

Membre confirmé
1 Juillet 2008
415
11
Marne-la-Vallée
Je tenterais ça :

Macintosh HD / Bibliothèque / Préférences / Audio

Mettre à la corbeille, sans vider la corbeille :

com.apple.audio.DeviceSettings.plist
com.apple.audio.SystemSettings.plist

Redémarrer.

Cela n'a pas eu d'effet non plus...
 
A

Anonyme

Invité
Gasp.

Reste en attendant mieux :

- réparation des permissions dans Utilitaire de disque
- démarrage en mode sans extension (touche maj au boot)
- reset SMC
- reset PRAM

Et si ça ne donne rien, réinstallation de l'OS "par dessus" (sans effacer le disque).

Tu peux replacer les fichiers supprimés : dans la corbeille, clic droit / remettre, puis "Remplacer".
 

A l'aise Breizh

Membre confirmé
1 Juillet 2008
415
11
Marne-la-Vallée
Gasp.

Reste en attendant mieux :

- réparation des permissions dans Utilitaire de disque
- démarrage en mode sans extension (touche maj au boot)
- reset SMC
- reset PRAM

J'ai fait tout cela... sans résultats !!!
Il me reste donc la réinstall de l'OS "par dessus". Cela va t il affecter les programmes installés et les fichiers ou juste l'OS ?
 
A

Anonyme

Invité
Bonsoir,

la réinstallation de l'OS "par dessus" ne modifie rien dans les applications installées, les données et les réglages des utilisateurs.

Seuls les fichiers système sont ré-écrits.

Avant de faire ça, as-tu vérifié que le problème est le même dans une autre session ?