Airport avec MacOS X

romanh1

Membre junior
7 Janvier 2001
84
0
J'ai un G4 400 sous MacOS X (10.1.1) et un ibook 300 sous MacOS 9.1

Les deux machines ont chacune une carte airport ce qui me permetait de partager la connexion ADSL.

Il y a qq jours : G4 sous 9.2 airport reglé en borne logiciel partage de connexion actif -> surf avec l'ibbok sans problemes.

Aujourd'hui : G4 sous X impossible de regler le mac en borne d'acces logiciel.
Le logiciel airport n'apparait que sur la bare du haut de l'ecran mais pas sous forne de lociciel comme sous mac os 9.2
L'assitant ne me propose pas de configurer mon ordi en borne d'acces logiciel.

Voila je suis tres embeter je me demande ce que je vais bien pouvoir faire de mes cartes airport si je ne trouve pas de solution.

AIDEZ MOI JE VOUS EN SUPPLIE !!!!

Merci d'avance

Roman.

[20 novembre 2001 : message édité par romanh1]
 

Titanium31

Membre confirmé
8 Avril 2001
109
0
Si je ne me trompe pas, OS X ne gere pas la borne logiciel, pour le moment la seule solution est de rester en 9.2.1.


Daniel
 

WebOliver

Propre en Horde
Club MacG
31 Janvier 2000
31 518
4 207
Plus là
<BLOCKQUOTE><font size="1" face="Verdana, Geneva">quote:</font><HR>Posté à l'origine par Titanium31:
Si je ne me trompe pas, OS X ne gere pas la borne logiciel, pour le moment la seule solution est de rester en 9.2.1.

Daniel
<HR></BLOCKQUOTE>

Pas du tout, j'ai Airport sous OS X depuis deux semaines et sans problème.
 

simon

Membre d’élite
Club MacG
18 Juin 2000
3 669
16
Singapore
www.simonganiere.ch
Est-ce que tu as fait la mise-à-jour Airport de la semaine passée, et si oui est-ce que tu l'as fait sur les deux machines ???
 

-anonyme-

Légende
26 Février 2001
66 286
2 667
ca fait un peu plus de 20 minutes ;-)

bon, avant il y avait gNAT.

NAT ca veut dire Network Address Translation.

si tu fais un ifconfig -a dans un terminal,
tu as une interface ethernet qui devrait s'appeler en1 qui est en fait ta carte AirPort, et une interface ppp0 qui est ton interface PPPoE.

l'idee c'est de faire passer les paquets d'une interface sur l'autre, d'ou NAT.

pour ce faire, il te faut un StartupItem.

tu dois creer un dossier /Library/StartupItems/NAT

dedans tu met un script qui s'appelle NAT aussi

#!/bin/sh

. /etc/rc.common

ConsoleMessage "Starting NAT Services"
ConsoleMessage "Configuring NAT Parameters"
/usr/sbin/sysctl -w net.inet.ip.forwarding=1
/sbin/ifconfig en1 10.0.1.1 netmask 255.255.255.0
/sbin/ifconfig en1 mtu 1492
/usr/sbin/natd -f /etc/natd.conf
/sbin/ipfw -f flush
/sbin/ipfw add divert natd all from any to any via ppp0
/sbin/ipfw add pass all from any to any


puis un fichier qui s'appelle StartupParameters.plist
et qui contient
{
Description = "Network Address Translation";
Provides = ("NAT");
Requires = ("Network");
OrderPreference = "Late";
Messages = {
start = "Starting Network Address Translation Services";
stop = "Stopping Network Address Translation Services";
};
}


et enfin un fichier more natd.conf dans /etc
qui contient:

dynamic yes
interface ppp0

enfin tu rends executable
chmod a+x /Library/StartupItems/NAT
et
chmod a+x /Library/StartupItems/StartupParameters.plist

enfin, tes parametres reseaux pour les deux cartes airport devront etre:

10.0.1.1 pour le server avec un masque de 255.255.255.0 et routeur laisse vide.

pour le portable:

10.0.1.2 pour le server avec un masque de 255.255.255.0 et routeur 10.0.1.1.

je me suis permis de suppose que ton modem etait ethernet et pas configure en routeur...

Bonne chance, si tu as des questions, je suis la
 

-anonyme-

Légende
26 Février 2001
66 286
2 667
j'oubliais un detail,
je change le mtu* parce que pour certains sites et pour la mise a jour logicielle, le mtu doit etre homogene sur tout le trajet.

donc, tu dois penser a le modifier aussi sur ton powerbook.

sudo ifconfig en1 mtu 1492.

tu auras alors
en1 mtu de 1492 sur ton AirPort powerbook
en1 mtu de 1492 sur ton AirPort G4
ppp0 mtu de 1492 pour sortir vers ton provider.

notes aussi que le firewall que je propose et une passoire... tu peux le modifier comme tu voudra ;-)

*mtu c'est la taille maximale des paquets. si tu passe de 1500 vers 1492, le paquet est coupe en 2, d'ou les problemes de transmission pour certains sites et services.


Merci a l'auteur de gNAT
 

alèm

Cas clinique
10 Juin 2001
31 576
2 790
Belgrade
www.64asa.net
<BLOCKQUOTE><font size="1" face="Verdana, Geneva">quote:</font><HR>Posté à l'origine par William:
ce genre de truc, c'est ma specialite ;-)
dans 20 minutes tu as ta solution
<HR></BLOCKQUOTE>

et bien, tu aurais pu poster seulement dans 20 minutes alors…
 

-anonyme-

Légende
26 Février 2001
66 286
2 667
oui, c'est vrai

le message au dessus du tien est une erreur.
les messages de reponse sont les 3 au dessus