• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

Animate.css : les animations ne fonctionnent pas

Frédéric de Lavenne

Nouveau membre
28 Mai 2017
18
0
60
Bonjour,

Je suis WebDesigner et dans le cadre d'une campagne de teasing, je dois créer une page HTML animée. Pour ça en règle générale, j'utilise la librairie animate.css dispo à l'adresse suivante : https://daneden.github.io/animate.css/

Le hic, c'est que sur ma machine (MacBook Pro 15 pouces, mi-2012 - High Sierra), ça ne marche pas, mes animations ne fonctionnent pas. Même les exemples d'animations du site animate.css ne fonctionnent pas, que ce soit sur Safari, Chrome ou Firefox.

Par contre quand je l'essaie à partir d'une autre bécane (mac ou pc) ou quanf je teste les exemples d'animation du site animate.css, ça fonctionne !!!

En résumé :
  • ça ne vient pas de ma page puisque que les animations fonctionnent normalement quand je la fais tourner sur un autre ordi,
  • ça ne ne vient pas de tel ou tel navigateur
Une idée ?
 

pouppinou

Une vie de Chien et de Pommé, et je suis heureux !
17 Juin 2017
1 958
1 660
48
Niche.
Tes navigateurs sur ton MBP 2012 sont à jour ?
Vu que le CSS ne cesse d'évoluer il faut essayer de suivre le mouvement en mettant à jour tes navigateur sinon certaines nouveautés (webkit ...) ne seront pas "traduit" sur un ancien navigateur.

Pour le site que tu dis les animations passent pas du javascript, attention de bien avoir coché et activé le contenu web Javascript dans les préférences.

As-tu installé des protections (restrictions) dans ton environnement sur ton MBP 2012.

Sinon il faudrait que tu nous montres tes codes html et css éventuellement. Tu peux le mettre dans le forum en utilisant l'icône "+" dans la barre de menu de la fenêtre de ton message.
 
Dernière édition:

Frédéric de Lavenne

Nouveau membre
28 Mai 2017
18
0
60
Tes navigateurs sur ton MBP 2012 sont à jour ?
Vu que le CSS ne cesse d'évoluer il faut essayer de suivre le mouvement en mettant à jour tes navigateur sinon certaines nouveautés (webkit ...) ne seront "traduit" sur un ancien navigateur.
Mes anims sont "full css", pas la moindre ligne en js. Côté navigateurs, tout est ok, dernières versions installées. Je n'ai rien installé qui soit "bloquant", mais je suspecte quand même quelque chose de ce côté, 3 navigateurs à jours pas capables de mouliner des anims basées sur animate.css, y a une piste...
 

pouppinou

Une vie de Chien et de Pommé, et je suis heureux !
17 Juin 2017
1 958
1 660
48
Niche.
Tu as essayé sur une autre session ?
 

Frédéric de Lavenne

Nouveau membre
28 Mai 2017
18
0
60
Bien vu, tout est ok sur une autre session. Donc ça doit venir de ma bibliothèque... J'ai viré toutes les préfs, mais ça n'est pas ça...