Apercu/Mail ne prend pas le navigateur par défaut

acerso

Membre junior
12 Octobre 2008
17
0
Bonjour,
Dans Apercu, lorsque je sélectionne du texte dans un document, par exemple PDF, et que je clique avec le bouton droit de la souris et que je choisis "Recherche avec Google", le navigateur Safari est automatiquement démarré. Pourtant, j'ai défini dans Safari que le navigateur par défaut est Firefox et j'ai aussi vérifié dans Firefox que l'option "Toujours vérifier au démarrage que Firefox est le navigateur par défaut" est sélectionnée. J'ai également appuyer sur le bouton "Vérifier maintenant" dans ces mêmes options, et le message affiché est que Firefox est vraiment défini comme navigateur par défaut ("Firefox est déjà votre navigateur par défaut"). D'ailleurs, ce problème se rencontre également avec Mail si je recherche le texte sélectionné avec Google... Par contre, si je clique sur un lien Web dans Mail ou Apercu (exemple : www.lien.com), le navigateur par défaut (Firefox dans mon cas) est correctement chargé... Quelqu'un a une petite idée (et surtout une solution ;-))

PS : Mon Imac est sur Snow Leopard (10.6.8) avec toutes applications à jour...

Merci d'avance !
 

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
14 095
1 000
Toulouse.cong
faq.office.macintosh.free.fr
Dans Apercu, lorsque je sélectionne du texte dans un document, par exemple PDF, et que je clique avec le bouton droit de la souris et que je choisis "Recherche avec Google", le navigateur Safari est automatiquement démarré.
Normal, sauf erreur, dans la mesure où cette option fait appel aux "Services" de Mac OS X (que tu peux aussi activer via le menu "Aperçu" > "Services…" Et les services ne permettent pas de passer par Firefox (c'est en fait un process Automator, dans le cas de la recherche Google, qui lance une commande Shell - voir dans /Système/Bibliothèque/Services).

Si tu as l'âme d'un bidouilleur, tu peux peut-être essayer d'écrire un processus différent...