Automatiser (ou profil) le changement de paramètres réseau

MilesTEG

Membre confirmé
29 Octobre 2007
275
15
39
Salut,
J'aurais besoin d'un coup de main pour automatiser le paramétrage de la carte réseau.
Je m'explique, je suis dans deux lycées qui ont chacun un mode de fonctionnement différent niveau config réseau.
J'ai la chance que le DHCP fonctionne pour les deux.
Par contre, pour le 1er établissement il faut paramétrer un proxy pour HTTP, HTTPS et SOCKS, sinon ça ne fonctionne pas.
Et pour le 2ème pas besoin de paramétrer le proxy.
Chaque réseau a un nom différent et des IP différentes.

Je souhaite donc faire un script (ou autre chose genre profil) pour que lorsque je connecte mon MBA via l'adaptateur USB<->Eth la connexion soit paramétrée comme il faut sans que j'ai besoin d'aller dans la config réseau pour cocher les cases des proxy.

J'ai essayé un script automator, mais il n'a enregistré que les mouvements de la souris. Donc le clic sur l'icône des paramètres systèmes ne fonctionne pas tout le temps quand j'ai pas le même nombre d'icônes de logiciels ouverts dans le dock...

Quelqu'un pourrait-il me conseiller sur la manière de procéder ?

Merci d'avance,
++
Miles
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 492
4 321
59
St Germain en Laye - FRANCE
Et dans Preferences Sytème / réseau, si tu enregistres une configuration correspondant à l'un des lycées, puis tu crées une nouvelle configuration du nom de l'autre lycée sur laquelle tu fais les modifs de réglages pour cet autre lycée.

Il devrait suffire ensuite de passer d'une configuration à l'autre pour passer d'un réglage à l'autre
 

MilesTEG

Membre confirmé
29 Octobre 2007
275
15
39
Et dans Preferences Sytème / réseau, si tu enregistres une configuration correspondant à l'un des lycées, puis tu crées une nouvelle configuration du nom de l'autre lycée sur laquelle tu fais les modifs de réglages pour cet autre lycée.

Il devrait suffire ensuite de passer d'une configuration à l'autre pour passer d'un réglage à l'autre
:siffle: Rhooo, mais j'avais pas vu les "configurations" !! J'avais pourtant cherché :rolleyes:
Je pense que c'est ce qu'il va me falloir ^^
Merci ^^

Il n'y aurait pas moyen que la configuration se charge toute seule en fonction du réseau détecté ?