Automator: problème de doublon lors de conversion

crifan

Nouveau membre
24 Juin 2007
5
0
Bonjour,

J'ai créé un service avec Automator pour exporter des fichiers vidéo .avi en .m4v pour pouvoir les mettre dans mon iPhone.

Ça marche, mais malheureusement chaque vidéo est exportée 2 fois (c'est déjà très long, alors c'est très frustrant d'obtenir cette copie inutile)

J'ai vérifié, recréé et revérifié plusieurs fois le script sans succès.

Auriez-vous une piste ? Je joins le script à toutes fins utiles.
Cordialement,

Christian

Mac OS X 10.6.2
 

Jetsurfer

Membre confirmé
1 Février 2001
383
4
J'ai eu cela l'autre jour en zipant d'abord les fichiers et en les transférant dans un dossier avant de les envoyer avec FileZilla sur le serveur.
Comme je suis victime de la loi des séries pour le moment, mon MacBook Pro alu a eu sa carte graphique qui a lachée, problème reconnu par Apple, je devrais le récupérer dans une semaine.
Etant pour le moment avec le "vieux" £PowerBook G4, pas mal d'actions ne sont pas installées, donc même pour lire to processus c'était pas la joie.
Regardes si tu n'as pas fait un : Copier les éléments du Finder indiqués, moi c'est de ce côté là que j'avais un problème. Une fois supprimé je n'avais plus que la version zippée et non les versions originale et zipée en même temps dans le dossier.

@+,
Thierry
 

crifan

Nouveau membre
24 Juin 2007
5
0
J'ai eu cela l'autre jour en zipant d'abord les fichiers et en les transférant dans un dossier avant de les envoyer avec FileZilla sur le serveur.
Comme je suis victime de la loi des séries pour le moment, mon MacBook Pro alu a eu sa carte graphique qui a lachée, problème reconnu par Apple, je devrais le récupérer dans une semaine.
Etant pour le moment avec le "vieux" £PowerBook G4, pas mal d'actions ne sont pas installées, donc même pour lire to processus c'était pas la joie.
Regardes si tu n'as pas fait un : Copier les éléments du Finder indiqués, moi c'est de ce côté là que j'avais un problème. Une fois supprimé je n'avais plus que la version zippée et non les versions originale et zipée en même temps dans le dossier.

@+,
Thierry
Merci pour cette piste, Thierry. J'ai vérifié : j'ai bien utilisé l'action "obtenir les éléments sélectionnés du finder" et non "Copier les éléments du finder"... J'enchaîne ensuite avec l'action "Exporter les séquences". Et j'obtiens le format voulu, mais en double exemplaire. Vraiment bizarre...

Cordialement,

Christian
 

Jetsurfer

Membre confirmé
1 Février 2001
383
4
Merci pour cette piste, Thierry. J'ai vérifié : j'ai bien utilisé l'action "obtenir les éléments sélectionnés du finder" et non "Copier les éléments du finder"... J'enchaîne ensuite avec l'action "Exporter les séquences". Et j'obtiens le format voulu, mais en double exemplaire. Vraiment bizarre...

Cordialement,

Christian
Dès que je récupère mon MacBook Pro, je te tiens au courant.
Pas de panique ;-)

@+,
Thierry