Autorisation dans le Finder pour destruction

Aperron

Nouveau membre
J'ai un MacBookPro et j'ai installé Mac OSX Lion en le mettant à jour régulièrement. Je viens de terminer le nettoyage et classement de toutes mes images, photos.
J'avais vidé mon dossier images dans mon disque dur principal et j'ai recopié mes photos nettoyées et classées dans le dossier images de mon disque principal. Jusque là tout va bien.
En voulant nettoyer mes photos récentes installées dans le dossier images, je constate qu'à chaque fois que je veux détruire une image, le finder me demande mon mot de passe avec le message: Finder souhaite effectuer des modifications. Saisissez votre mot de passe pour donner l'autorisation.
J'ai essayé beaucoup de choses incluant réinitialiser les permissions, utiliser Tinker Tool System pour nettoyer etc.. Redémarrage de session. Tentative de modification avec PathFinder. Rien n'y fait, j'ai toujours le même "?%$#@ :mad: :confused:maudit message.
Oui je suis bien administrateur du système et je peux administrer l'ordinateur au complet. J'ai vérifié plusieurs fois. Le bouton dans mon compte principal est grisé mais il est coché. Je comprends que s'il est grisé c'est que je suis bien un administrateur root.
Donc j'ai besoin d'aide, je ne trouve pas à quel endroit je peux faire disparaître cet inconvénient majeur puisque j'ai plusieurs photos à gérer et s'il faut qu'à chaque fois je donne mon mot de passe c'est impossible.
De plus, j'utilise Picasa donc lorsque je veux supprimer une photo dans Picasa, impossible et je crois que c'est relié à ce problème d'autorisation.
Désolé d'un si long message mais je suis un peu désespéré de trouver une solution à cet irritant majeur dans ma gestion d'images. Mon autre solution serait de mettre ma banque d'images dans un de mes disques durs externes mais ça ne fait pas mon affaire, j'ai un portable... donc transporter un disque supplémentaire ce n'est pas vraiment une solution.
J'ai cherché dans le forum et ailleurs sur le net, les seules réponses en lien avec ce que je demande me renvoient à l'autorisation d'administrateur alors que je suis vraiment administrateur du système. À moins qu'il y ait quelque chose de caché en quelque part.
Y a-t-il un logiciel qui pourrait m'aider?
Merci d'avance, surtout si vous avez eu la patience de lire au complet ce message.
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
44 092
6 843
Nancy___
Le bouton dans mon compte principal est grisé mais il est coché. Je comprends que s'il est grisé c'est que je suis bien un administrateur root.
Je ne comprends pas de quel bouton tu parles :j'espère juste que tu ne travailles pas dans une session root, mais juste dans une session admin.


Regarde si tu as les autorisations du dossier dans lequel sont rangées tes photos : cmd-i sur le dossier, est-ce que tu as bien les autorisations en lecture et écriture ?


 

marctiger

Membre d’élite
Club MacG
25 Janvier 2006
3 343
156
Bruxelles
marctiger.be
Je dirais d'abord et SURTOUT... espacer tes paragraphes, car c'est pénible à lire et à comprendre, et perso (et penses à tout le monde, autant le dire maintenant pour que "à l'avenir" ;)) si Sly n'y avait pas répondu j'aurais carrément sauter le post, et d'ailleurs je ne lis pas tout, désolé mais avec ma vue qui baisse... ! :D

Maintenant, dans un premier temps je dirais que commencer par réparer les permissions et vérifier le disque ne serait pas de trop, cela ne mange pas de pain et résout déjà certains problèmes.

Et vérifies aussi les fichiers éventuellement corrompus.

Et bienvenue ! :)
 

Aperron

Nouveau membre
Je dirais d'abord et SURTOUT... espacer tes paragraphes, car c'est pénible à lire et à comprendre, et perso (et penses à tout le monde, autant le dire maintenant pour que "à l'avenir" ;)) si Sly n'y avait pas répondu j'aurais carrément sauter le post, et d'ailleurs je ne lis pas tout, désolé mais avec ma vue qui baisse... ! :D

Maintenant, dans un premier temps je dirais que commencer par réparer les permissions et vérifier le disque ......

Et vérifies aussi les fichiers éventuellement corrompus.
Désolé pour les espaces...Je tenterai de faire mieux.

J'ai toutes les autorisations nécessaires. J'ai même mis 777 pour être sûr que j'avais bien toutes les permissions requises.


J'ai réparé le disque, j'ai aussi réparer les permissions, rien n'y fait et j'avais déjà fait cela avant d'écrire dans le forum.

Lecture, écriture, exécuter, tout est là.

Bizarre que l'on me renvoie toujours à ces trucs alors qu'évidemment c'est la première chose que j'ai faite. J'ai essayé bien des trucs, mais ça ne marche pas. Fichiers corrompus, je vais voir, peut-être mais tous mes fichiers corrompus, je ne crois pas. ..

Merci

---------- Nouveau message ajouté à 18h07 ---------- Le message précédent a été envoyé à 18h06 ----------

Je parle du bouton dans la fenêtre d'information sur les comptes comme dans l'image jointe. Que je sois en root ou comme admin, ça ne marche pas.
 
Dernière édition par un modérateur:

-anonyme-

Légende
26 Février 2001
66 286
2 673
Lecture, écriture, exécuter, tout est là.
Non. Sélectionner le dossier Images, puis faire cmd I, aller à Partage et permissions, sélectionner l’utilisateur, Lecture et écriture, puis Appliquer aux éléments inclus.



Le problème provient de la copie initiale qui n’a pas respecté les droits de Max OS X. Il fallait utiliser l’application Assistant migration.



L’application PropEdit peut aider pour rétablir les droits.

Mac OS LION va encore plus loin que ses prédécesseurs dans le côté chiant des autorisations.
 

Aperron

Nouveau membre
Merci j'avais déjà fait cela aussi i.e. : Appliquer aux éléments inclus.

Je crois que tu viens de mettre le doigt sur le bobo, je n'ai pas utilisé Assistant migration et j'ai tout recopié dans le dossier images que j'avais vidé auparavant.

Je vais essayer le logiciel dont tu parles et j'en redonne des nouvelles. Sinon, je me disais que je pourrais essayer de réinstaller le système Lion mais je trouve ça "ben platte".

---------- Nouveau message ajouté à 19h51 ---------- Le message précédent a été envoyé à 19h12 ----------

Je viens d'essayer PropEdit mais je n'ai pas réussi à corriger la situation. Remarque que je l'ai utilisé à l'aveuglette en souhaitant qu'en cochant les permissions adéquates, ça marcherait mais ça n'a pas fonctionné.

Je vais continuer à chercher à comprendre les termes utilisés parce que je ne sais pas ce qu'ils signifient. Au départ, je suis propriétaire du répertoire images (Pictures) et je fais partie du groupe Wheel selon ce que je vois.

En demandant d'appliquer les changements i.e. lecture, écriture, exécucter ça ne change rien, il me demande toujours de valider par le mot de passe.

Un peu découragé de voir les complications que j'ai créé.

J'ai testé dans les autres répertoires par exemples documents et je peux détruire sans avoir une demande de mot de passe.

Dans le répertoire images, impossible. J'ai tenté de créer un autre répertoire images2 et j'ai recopié des images dedans et j'ai tenté d'en détruire une, même problème. De plus, je constate qu'après avoir donné mon mot de passe, l'ordi me demande encore une fois de m'authentifier pour vider la corbeille. La galère....

Bon je vais continuer à chercher et je souhaite une piste de travail bien sûr. Merci de vos efforts, bizarre comme problème ou bien ça arrive à d'autres?

---------- Nouveau message ajouté à 20h00 ---------- Le message précédent a été envoyé à 19h51 ----------

Dans musique, dans documents, aucun problème....
Uniquement dans Images que j'ai ce problème.

---------- Nouveau message ajouté à 20h27 ---------- Le message précédent a été envoyé à 20h00 ----------

J'ai utilisé un logiciel que j'ai acheté: Tinker Tools System et j'ai glisser/déposer le répertoire images dans la gestion des autorisations.

Ensuite j'ai cliqué sur le groupe admin et j'ai demandé au logiciel de diffuser les autorisations accordées à tous les répertoires et sous-répertoires dans le dossier images.

Présentement je suis en mesure de détruire les images sélectionnées sans que j'aie à m'authentifier. J'ai aussi redémarré le système pour m'assurer que les changements étaient permanents.

Je crois avoir réglé mon problème. Merci de m'avoir accompagné dans cette recherche de solutions. À l'avenir j'utiliserai assistant migration mais je trouve cette façon de faire "chiante". Pourquoi avoir compliqué le déplacement de fichiers, je ne comprends pas la logique.

Je suppose avoir identifié le problème et l'avoir réglé avec ce que je viens de décrire mais j'ai tellement fait de manipulations (même si j'ai essayé après chaque manipulation) que je ne suis pas sûr.
 
Dernière édition:

-anonyme-

Légende
26 Février 2001
66 286
2 673
Il est possible de se choisir l’emplacement des dossiers de l’utilisateur :

Préférences Système > Comptes > Cadenas ouvert > sélectionner le compte à modifier, puis ctrl + clic sur le compte > Options avancées… > et choisir un autre répertoire de départ…
 

ziarn

Membre confirmé
19 Juillet 2001
369
2
Visiter le site
Pour info,
Je te rassure, j'ai utilisé l'assistant migration et j'ai le même p%$*/= de pb que toi :mad:
C'est la première fois en x années de mac que je me prends la tête à ce point sur une copie de fichiers...
Je refuse d'acheter un soft pour régler des pbs d'OS, faut tout de même pas déconner :mouais:
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 126
625
À côté (de ma plaque)
Depuis 10.5, l'utilitaire de réinitialisation des mots de passe comprend une fonction de réinitialisation des permissions et ACL des Comptes d'utilisateur. Parfait pour les migrations ratées !

Utilitaire made in Apple, :)
contenu dans le DVD d'install de 10.5 et 6,
et dans la partition Recovery HD de Lion (voir là : http://forums.macg.co/10812432-post4.html )
 

proubaud

Membre junior
10 Octobre 2007
10
0
Val de Marne, La Queue en Brie
J'ai un MacBookPro et j'ai installé Mac OSX Lion en le mettant à jour régulièrement. Je viens de terminer le nettoyage et classement de toutes mes images, photos.
J'avais vidé mon dossier images dans mon disque dur principal et j'ai recopié mes photos nettoyées et classées dans le dossier images de mon disque principal. Jusque là tout va bien.
En voulant nettoyer mes photos récentes installées dans le dossier images, je constate qu'à chaque fois que je veux détruire une image, le finder me demande mon mot de passe avec le message: Finder souhaite effectuer des modifications. Saisissez votre mot de passe pour donner l'autorisation.
J'ai essayé beaucoup de choses incluant réinitialiser les permissions, utiliser Tinker Tool System pour nettoyer etc.. Redémarrage de session. Tentative de modification avec PathFinder. Rien n'y fait, j'ai toujours le même "?%$#@ :mad: :confused:maudit message.
Oui je suis bien administrateur du système et je peux administrer l'ordinateur au complet. J'ai vérifié plusieurs fois. Le bouton dans mon compte principal est grisé mais il est coché. Je comprends que s'il est grisé c'est que je suis bien un administrateur root.
Donc j'ai besoin d'aide, je ne trouve pas à quel endroit je peux faire disparaître cet inconvénient majeur puisque j'ai plusieurs photos à gérer et s'il faut qu'à chaque fois je donne mon mot de passe c'est impossible.
De plus, j'utilise Picasa donc lorsque je veux supprimer une photo dans Picasa, impossible et je crois que c'est relié à ce problème d'autorisation.
Désolé d'un si long message mais je suis un peu désespéré de trouver une solution à cet irritant majeur dans ma gestion d'images. Mon autre solution serait de mettre ma banque d'images dans un de mes disques durs externes mais ça ne fait pas mon affaire, j'ai un portable... donc transporter un disque supplémentaire ce n'est pas vraiment une solution.
J'ai cherché dans le forum et ailleurs sur le net, les seules réponses en lien avec ce que je demande me renvoient à l'autorisation d'administrateur alors que je suis vraiment administrateur du système. À moins qu'il y ait quelque chose de caché en quelque part.
Y a-t-il un logiciel qui pourrait m'aider?
Merci d'avance, surtout si vous avez eu la patience de lire au complet ce message.
Bonjour à tous
j'ai le même problème et pour tout type de fichier. Quand je rentre le mot de passe pour effectuer la suppression, je ne retrouve pas le fichier dans la corbeille ! comme si j'étais dans une configuration de type "suppression directe, sans mise à la corbeille"
J'ai beau chercher je ne vis pas de telle option
Merci
 

ntx

Vénérable sage
Club MacG
15 Octobre 2004
12 052
370
92
Ceci arrive quand les droits d'accès à la corbeille du compte utilisateur courant ne sont pas bons. Ils n'autorisent pas le compte qui effectue la suppression (administrateur) à mettre le fichier supprimé dans la corbeille de l'utilisateur actuellement connecté.