10.12 Sierra Autoriser l'ouverture d'un logiciel de source inconnue

Bart Simpson

Membre actif
7 Avril 2016
204
10
44
Bonjour,
je suis sur mac mini avec OS Sierra 10.12.6 et j' n'arrive pas à installer un logiciel: "FileZilla".
Ce logiciel demande une version minimum demande OS 10.13 aussi j'ai trouvé des versions plus anciennes qui devraient être théoriquement acceptées.
Mais le mac refuse de les ouvrir parce que "elles proviennent d'un développeur non identifié" (voir capture d'écran FilleZilla 3).
Pourtant j'ai été dans :
Préférence système -> Sécurité et confidentialité -> Confidentialité -> ouvrir le cadenas -> sélécioner "FilleZilla"
comme sur la capture d'écran "FilleZila 2".
Comment puis-je forcer le mac à ouvrir un logiciel qu'l refuse?
J'ai essayé plein de version de FilleZilla, elles sont systématiquement refusées.
Merci pour vos conseils :)
Bart
 

Fichiers joints

  • FilleZilla 2.png
    FilleZilla 2.png
    89,9 KB · Affichages: 36
  • FilleZilla 3.png
    FilleZilla 3.png
    38,5 KB · Affichages: 35

Berthold

Bricoleur du dimanche
Club MacG
5 Novembre 2004
4 863
4 719
par là-bas, environ.
Bonjour
Astuce dont je ne suis pas sûr qu'elle fonctionne sur tous les systèmes :
  • dans le dossier Applications,
  • clic droit sur Filezilla, Ouvrir
  • Normalement après un moment de vérification, MacOS te demande quoi faire : ouvrir quand même (autoriser ou en substance) ou fermer.
Tout ça de mémoire…
 
  • J’aime
Réactions: Sly54

Bart Simpson

Membre actif
7 Avril 2016
204
10
44
Berthold:
merci pour l'astuce.
J'ai tenté, mais rien à faire, l'ordi lance effectivement l'ouverture du logiciel mais j'ai des message d'erreure sur les 17 version de FilleZilla que j'ai téléchargé.
Je ne sais si ce sont les versions de FilleZilla qui sont corrompues ou si le problème viens de mon mac.

Sly54:
Je crois qu'il faut que je change d'ordi. Il fonctionne mais il est vétuste, super lent et pose problème dans de nombreux cas comme celui-ci.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
39 544
6 009
Par curiosité, tu lances le Terminal et tu fais un Copier/Coller de cette commande...
Bloc de code:
sudo spctl --master-disable
...il faudra taper ton mot de passe en aveugle et valider avec la touche Entrée. Vois ce qu'il se passe en réinstallant FileZilla 16.
 

Bart Simpson

Membre actif
7 Avril 2016
204
10
44
Quel modèle ? Et quelle configuration hardware ?

Sly54:
C'est un mac mini de 2014 avec macOS sierra 10.12.
  • processeur 1,4 GHz Intel Core i5
  • mémoire 4 Go 1600 MHZ DDR3
  • Graphisme Intel HD Graphics 5000 1536 Mo
  • système d'exploitation: macOS Sierra 10.12.6

On n'en avais déja parler sur une autre discussion ou tu me proposais d'y remédier avec une opération chirugicale: ajouter un SSD à l'intérieur. Mais je ne sais pas faire cela, et je crois vraimenet que ma machine est un ancêtre qui n'en vaut plus la peine, vu sa lenteur et tout le soucis d'incompatibilité et de désuétude qu'elle me procurre...
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
39 544
6 009
On n'en avais déja parler sur une autre discussion ou tu me proposais d'y remédier avec une opération chirugicale: ajouter un SSD à l'intérieur. Mais je ne sais pas faire cela, et je crois vraimenet que ma machine est un ancêtre qui n'en vaut plus la peine, vu sa lenteur et tout le soucis d'incompatibilité et de désuétude qu'elle me procurre...
C'est bien, mais là tu cherches à faire quoi, tu parles de logiciel et maintenant de matériel !

Au fait, tu as fait ce que j'ai mentionné en réponse #6 ?
 

Bart Simpson

Membre actif
7 Avril 2016
204
10
44
Par curiosité, tu lances le Terminal et tu fais un Copier/Coller de cette commande...
Bloc de code:
sudo spctl --master-disable
...il faudra taper ton mot de passe en aveugle et valider avec la touche Entrée. Vois ce qu'il se passe en réinstallant FileZilla 16.
Je ne sais plus comment on lance le "Terminal".
Il me semble qu'il y a une manipe spéciale pour faire cela, mais je ne la retrouve pas.

En fait je ne suis pas vraiment certain d'avoir besoin de "FilleZilla".
Mon objectif est celui ci:
  • je suis administrateur général d'un forum phpbb (pour une association).
  • le forum phpbb est installé sur un "serveur" (le serveur est YunoHost) par le webmaster de l'association.
  • j'aimerais changer le "thème" (= décore et style graphique du forum), et cela n'est possible qu'en installant sur le serveur "YunoHost" un "thème" téléchargé de par ailleurs. Le webmaster m'a donné les droit d'accès sur l'endroit conerné de "YunoHost"
  • le webmaster m'explique que pour installer le thème sur "YunoHost", je dois utiliser le logiciel "FilleZilla".
  • mais après réflexion cela me semble assez superflu: pourquoi aurais-je besoin d'un logiciel pour installer un thème de forum sur "YunoHost" (quand bien même j'ai les droit d'accès ouverts)?
Ne puis-je pas installer un "style de forum phpbb" sur "younoHost" sans "FilleZilla", mais simplement avec les fonctionnalitées de mon mac?
Alors qu'habituellement je télécharge des information depuis la source de mon mac jusqu'à d'autres destinations en ligne, sans logiciel comme FilleZilla?

Pardon, je ne suis pas sur d'être bien clair, mais je n'ai jamais tripatouiller un "serveur" et pour moi cela n'est effectivement pas bien claire :)
J'apprend, je découvre, et je traverse une zone de brouillard :D
 

Bart Simpson

Membre actif
7 Avril 2016
204
10
44
Sly54:
C'est un mac mini de 2014 avec macOS sierra 10.12.
  • processeur 1,4 GHz Intel Core i5
  • mémoire 4 Go 1600 MHZ DDR3
  • Graphisme Intel HD Graphics 5000 1536 Mo
  • système d'exploitation: macOS Sierra 10.12.6

On n'en avais déja parler sur une autre discussion ou tu me proposais d'y remédier avec une opération chirugicale: ajouter un SSD à l'intérieur. Mais je ne sais pas faire cela, et je crois vraimenet que ma machine est un ancêtre qui n'en vaut plus la peine, vu sa lenteur et tout le soucis d'incompatibilité et de désuétude qu'elle me procurre...
Locke:
c'était une réponse à Sly54 qui me demandais des précision sur mon materiel :).
Nos message se sont croisés, je viens de répondre à ton message :)
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
53 239
10 172
Nancy___
C'est un mac mini de 2014 avec macOS sierra 10.12.
  • processeur 1,4 GHz Intel Core i5
  • mémoire 4 Go 1600 MHZ DDR3
  • Graphisme Intel HD Graphics 5000 1536 Mo
  • système d'exploitation: macOS Sierra 10.12.6

On n'en avais déja parler sur une autre discussion ou tu me proposais d'y remédier avec une opération chirugicale: ajouter un SSD à l'intérieur. Mais je ne sais pas faire cela, et je crois vraimenet que ma machine est un ancêtre qui n'en vaut plus la peine, vu sa lenteur et tout le soucis d'incompatibilité et de désuétude qu'elle me procurre...
Ta machine n'est pas jeune mais pas si vieille que ça.
Mais elle n'a que 4 Go de RAM, c'est un gros inconvénient.

Néanmoins tu peux mettre un SSD externe, donc rien à démonter, juste mettre un SSD de qualité (Crucial X6 ou X8) en USB3, mettre l'OS et tes applications dessus et travailler en permanence sur le SSD. Pour pouvoir mettre un OS plus récent que ce vieux Sierra.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
39 544
6 009
Je ne sais plus comment on lance le "Terminal".
Il me semble qu'il y a une manipe spéciale pour faire cela, mais je ne la retrouve pas.
Le terminal est toujours au même endroit, dans Macintosh HD/Applications/Utilitaires une fois lancé tu fais un Copier/Coller de la commande citée plus haut. ;)
 

love_leeloo

In Tartiflette We Trust
Club MacG
25 Décembre 2004
1 302
440
pour ne faire la manip que pour une seule application, je lance le terminal, et je tape :
"xattr -rd com.apple.quarantine "
ensuite je fais un glisser/déposer de l'appli à la suite de la commande
puis je valide
je tape mon mot de passe et voilà
 

Bart Simpson

Membre actif
7 Avril 2016
204
10
44
Salut à tous et merci pour vos réponses :)
Il y a mainteneand 2 problème distincts traités dans cette discussion que je décrit ainsi:

1/ Je n'arrive pas à installer FilleZilla sur mon mac.
2/ Mon mac n'a que 4 Go de ram, et c'est un incovénient important.

Alors pour le 1/ Je n'arrive pas à installer FilleZilla sur mon mac:

LOCKE:
Ok, j'ai retouvé le terminale :), j'ai copié-collé la commande, donné mon mot de pass et réinstallé une vielle version de FilleZilla. Mais j'ai toujours le même message d’erreurs (voir capture d'écran en fichier joint)

BEWARE PICKPOCKET:
J'ai essayé ton lien de téléchargement, mais celui-ci me donne un logiciel FilleZila qui n'est possible sur un mac OS X 10.13.2 au minimum.
Or je suis sur macOS Sierra 10.12.6. Cette version de macOS est est la version maximum que peux suporter mon amc avec 4 Go de Ram. Ce qui me rediriger vers la question 1/

PATLEK: J'aurais préféré "FilleZilla" à "Cyberdick", car c'est le logiciel que m'a conseillé le webmaster-général qui héberge mon forum. Ainsi il aurait pu répondre à mes question et m'assister un peu sur FilleZilla. Malheureusement il travail sur PC-windows, donc il ne peus pas tester les liens de téléchargement de FilleZilla qu'il m'a envoyé. Et je pense que ces liens sont corrompus.
Pourquoi pas tenter selon ton conseil "Cyberduck", pour remplacer FilleZialla?
Tu as un lien de téléchargement compatible Mac OS 10.12.6?

LOVE_LEELOO:
j'ai tenté de copier tacoande sur le terminal, mais ça ne fait rien.
Je ne suis pas du tout à l'aise sur le Terminal.
Enfin, j'aurais essayé :)

Et pour le 2/ Mon mac n'a que 4 Go de ram, et c'est un inconvénient important:

SLY54:
Ce problème de version OSX plafoné à 10.12.6 est récurent chez moi.
J'envisageais acheter un nouvel ordi. Mais tu me précise:
"Néanmoins tu peux mettre un SSD externe, donc rien à démonter, juste mettre un SSD de qualité (Crucial X6 ou X8) en USB3, mettre l'OS et tes applications dessus et travailler en permanence sur le SSD. Pour pouvoir mettre un OS plus récent que ce vieux Sierra."[/I]
Oui!
Je veux bien essayer de brancher un SSD sur mon mac pour lui donner une nouvelle jeunesse et installer la versio OSX la plus récente.
Seulement c'est quoi l'acronyme "SSD"?
"Super-Super-Disquedur"?
ça se branche en USB sur mon mac?
Je commande ça sur Amazone en cherchant "SSD compatible mac"?
 

Fichiers joints

  • FilleZilla Bug.png
    FilleZilla Bug.png
    31,9 KB · Affichages: 31
Dernière édition par un modérateur:

patlek

Membre expert
Club MacG
10 Août 2003
3 478
1 956
Tu as un lien de téléchargement compatible Mac OS 10.12.6?

Le lien que j' ai donné.

macOS 10.12 or later on Intel (64bit) or Apple M1 required.



C' est pour du FTP, c' est le meme principe que Hilezilla.

Excepté que c' est bien mieux fichu. (J' ai jamais aimé filezilla)
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
53 239
10 172
Nancy___
SLY54:
Ce problème de version OSX plafoné à 10.12.6 est récurent chez moi.
J'envisageais acheter un nouvel ordi. Mais tu me précise:

"Néanmoins tu peux mettre un SSD externe, donc rien à démonter, juste mettre un SSD de qualité (Crucial X6 ou X8) en USB3, mettre l'OS et tes applications dessus et travailler en permanence sur le SSD. Pour pouvoir mettre un OS plus récent que ce vieux Sierra."
Oui!
Je veux bien essayer de brancher un SSD sur mon mac pour lui donner une nouvelle jeunesse et installer la versio OSX la plus récente.
Seulement c'est quoi l'acronyme "SSD"?
"Super-Super-Disquedur"?
ça se branche en USB sur mon mac?
Je commande ça sur Amazone en cherchant "SSD compatible mac"?
SSD = solid state drive. C'est un stockage à base de mémoire flash (un peu comme les barrettes de RAM, sauf que lorsqu'il n'y a plus de courant, les données restent inscrites sur le SSD).

Regarde chez Crucial.fr les X6 ou X8 : https://www.crucial.fr/products/ssd/portable-ssds

Ca se branche en USB, oui.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
39 544
6 009
@Bart Simpson
Evite de coloriser ta réponse, ça pique les yeux, j'ai corrigé.

Sinon, officiellement on peut trouver les anciennes de FileZilla ici... https://download.filezilla-project.org ...dans ton cas, il faut aller dans Client et... https://download.filezilla-project.org/client/ ...tu as toutes les anciennes versions. Je n'ai pas de certitude, mais en bas de page, commence par la version 3.50.0... FileZilla_3.50.0-rc1_macosx-x86.app.tar.bz2 ...et vois ce qu'il se passe.

Historique des versions... https://filezilla-project.org/versions.php ...la version 3.56.2 est adaptée pour macOS Monterey d'ou ton problème d'installation.