Besoin d'avis - Macbook Air 2011

The Witness

Membre enregistré
24 Octobre 2022
4
3
29
Bonjour à tous,

Petit nouveau sur le forum et petit nouveau également sur Mac, je découvre les joies (et les défauts) de ces machines haha !

En effet, je suis principalement un gros utilisateur Windows mais il y a peu, un collègue de travail m'a donner son vieux Macbook Air de 2011.
Celui ci avait diagnostiqué la carte mère HS (les billes de soudures de la RAM avec les 3 bips typhique de ce genre de problème).

Moi, bille en tête, voulant à tout pris redonner une 2nd jeunesse à ce Mac plutôt que de le jeter, j'ai acheté une CM d’occasion en Angleterre.

La carte mère est bien fonctionnelle et marche à merveille, cela fait plaisir de voir ce petit Mac Air tourner !

Mais voilà, je me retrouve face à un soucis de clavier, Trackpad et langage.

Pour récapituler les différents problèmes : Une fois la nouvelle carte mère installée, je fais la commande (CMD +R) afin de réinstaller l'OS de base au fonctionnement du Mac.
Avant l'installation, le clavier ainsi que le Trackpad fonctionnait totalement normalement et suite à l'installation de Mac Os X, impossible de faire fonctionner ces derniers !
Le rétroéclairage du clavier fonctionne parfaitement mais le Mac recherche un clavier en Bluetooth qui n'existe pas !
Idem pour le Track, celui ne fonctionne plus également alors qu'avant l'installation de l'OS, tout fonctionnait parfaitement.

Je ne comprend vraiment pas ce qui a pu capoter entre le temps où j'ai rentré ma clé wifi et l'installation de l'OS pour que cela donne ce résultat.

Concernant mon problème de langage : Vu que la CM est anglaise, l’intégralité de l'OS l’était également. J'ai donc changé la langue via les menus dédié, avec succès sauf pour la page d'ouverture de session qui elle, reste toujours en anglais.


Doit on changer la langue dans le BIOS, si cela est possible?

Je vous remercie d'avoir pris le temps de me lire,

Cordialement,

The Witness
 
Bonsoir

Pour les périphériques non reconnus, tu peux tenté une ré-initialisation de la PRAM et de la SMC :
Ça ne mange pas de pain, au pire ça ne change rien...


Pour la langue, tu peux tenter de lancer le Terminal, y copier-coller la commande sudo languagesetup, valider avec Entrée, taper ton mot de passe à l'aveugle, puis choisir la bonne langue (chez moi le Français est le 11) donc taper 11 et Entrée, puis redémarrer normalement le Mac.
 
Bonsoir

Pour les périphériques non reconnus, tu peux tenté une ré-initialisation de la PRAM et de la SMC :
Ça ne mange pas de pain, au pire ça ne change rien...


Pour la langue, tu peux tenter de lancer le Terminal, y copier-coller la commande sudo languagesetup, valider avec Entrée, taper ton mot de passe à l'aveugle, puis choisir la bonne langue (chez moi le Français est le 11) donc taper 11 et Entrée, puis redémarrer normalement le Mac.
Merci pour ta réponse rapide !
J'avais déjà essayé le reset SMC sans résultat mais je n'avais pas fait le reset PRAM.

Voilà qui est chose faite, malheureusement sans résultat également.

Est il possible que lors du remontage, la nappe qui gère le clavier + trackpad soit défaillante?
Ce qui m’étonne, c'est que si la nappe était défaillante, le rétroéclairage du clavier ne fonctionnerai pas? (Où alors, le rétroéclairage est dissocié du clavier + track?)

J'apporte une petite précision à ceci : le témoin LED vert de la touche MAJ ne fonctionne pas également, uniquement le rétroéclairage.

En ce qui concerne la langue, j'essaye ça demain et je reviens vers vous ! Merci :up:
 
Est il possible que lors du remontage, la nappe qui gère le clavier + trackpad soit défaillante?
Ce qui m’étonne, c'est que si la nappe était défaillante, le rétroéclairage du clavier ne fonctionnerai pas? (Où alors, le rétroéclairage est dissocié du clavier + track?)

J'apporte une petite précision à ceci : le témoin LED vert de la touche MAJ ne fonctionne pas également, uniquement le rétroéclairage.
D'après les merveilleux guides de démontage de iFixit en effet :
  • la nappe du rétro-éclairage n'est pas la même que celle du clavier (étape 20 / étapes 39 et 40)
  • la nappe du clavier passe par le trackpad, puis une autre nappe connecte le trackpad à la carte-mère, c'est donc probablement celle-ci qui est mal fixée ou abîmée (ou un de ses connecteurs)


Par contre ce qui est étrange dans ton histoire, c'est que tout fonctionnait bien pendant la phase d'installation de macOS, quand le Mac était déjà réparé et bien refermé, ça n'aurait donc pas dû bouger dans les entrailles...
 
D'après les merveilleux guides de démontage de iFixit en effet :
  • la nappe du rétro-éclairage n'est pas la même que celle du clavier (étape 20 / étapes 39 et 40)
  • la nappe du clavier passe par le trackpad, puis une autre nappe connecte le trackpad à la carte-mère, c'est donc probablement celle-ci qui est mal fixée ou abîmée (ou un de ses connecteurs)


Par contre ce qui est étrange dans ton histoire, c'est que tout fonctionnait bien pendant la phase d'installation de macOS, quand le Mac était déjà réparé et bien refermé, ça n'aurait donc pas dû bouger dans les entrailles...
Bonjour,
Je reviens vers vous après ces quelques jours, en effet j'ai du commander une nouvelle nappe pour le trackpad/clavier car la mienne était bel et bien HS.

Après la pose de la nouvelle nappe, le clavier + trackpad sont de retour pour mon plus grand plaisir !

Pour la langue, tu peux tenter de lancer le Terminal, y copier-coller la commande sudo languagesetup, valider avec Entrée, taper ton mot de passe à l'aveugle, puis choisir la bonne langue (chez moi le Français est le 11) donc taper 11 et Entrée, puis redémarrer normalement le Mac.

En ce qui concerne la langue, la commande à bien fonctionné, le loggin est en français maintenant :)

Je vous remercie beaucoup pour votre aide et je pense que nous pouvons fermer ce topic.

Cordialement,

The Witness
 
  • J’adore
Réactions: Bicus