Blem compilation libmcrypt-2.5.8

Daft33Punk

Membre confirmé
20 Juin 2011
12
0
Bordeaux
Bonjour j'ai essayé de compiler libmcrypt-2.5.8 en console, ca démarre mais il veut pas crée l'executable. :mouais:

local-server:libmcrypt-2.5.8 flo$ sudo MACOSX_DEPLOYMENT_TARGET=10.6 CFLAGS='-O3 -fno-common -arch i386 -arch x86_64' LDFLAGS='-O3 -arch i386 -arch x86_64' CXXFLAGS='-O3 -fno-common -arch i386 -arch x86_64' ./configure --disable-dependency-tracking
checking build system type... i686-apple-darwin10.8.0
checking host system type... i686-apple-darwin10.8.0
checking target system type... i686-apple-darwin10.8.0
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... no
checking whether to enable maintainer-specific portions of Makefiles... no
checking whether make sets $(MAKE)... (cached) no
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking for C++ compiler default output file name... configure: error: C++ compiler cannot create executables
See `config.log' for more details.

aparament faut que j'instale quelque chose mais quoi.

Mercis d'avance
 

ntx

Membre vénérable
Club MacG
15 Octobre 2004
12 128
376
92
Tu as récupéré les sources sur leur site ?

A priori le makefile n'est pas tout à fait un jour pour ta configuration. D'ailleurs quelle version d'OS : 10.6 ou 10.7 ?

En général pour installer des librairies ou applications issues du monde Unix, il est recommandé de passer par MacPorts ou Fink qui propose justement des makefile et des sources adaptés pour Mac OSX.

Ensuite tu peux te douter que tu n'es pas le premier à essayé la manip, et donc le premier réflexe est de coller le message d'erreur dans Google. :zen: Et tu trouveras une solution au problème qui requiert la mise à jour de Xcode de la 3.1.2 à la 3.2. Est-ce ton cas ? :confused:
 

Daft33Punk

Membre confirmé
20 Juin 2011
12
0
Bordeaux
salut, oui le fichier vient de leur site. Je suis sur Mac os x 10.6.8 et Xcode 3.2.6 (1761)
Il faut aussi 'mhash' mais meme blem il manque le compilateur 'gcc' et 'cc'
 

tatouille

Membre expert
1 Juin 2004
5 174
493
Stanford CA
ouvrir le log et regarde le probleme tes flags a part pour l'arch sont corrects (si tu utilises gcc) mais pour le linker WTF? you do :p, a part ca, juste une simple idée as tu gcc-xcode installé? bah non :rateau::p:cool:
 
Dernière édition: