Bug ouverture maquette QuarkXPress 4 avec version 7 ou 8

bjsc

Membre junior
6 Mai 2006
69
0
Bonjour à tous !

J'ai un gros bouquin réalisé en XPress 4 dont je dois faire la mise à jour. L'ouvrage de près 1300 pages est composé de 32 chapitres (des documents XPress séparés) réunis en un "LIVRE". Il comporte un index conséquent (16 700 entrées).
J'ai les versions complètes 7.5 et 8.12 d'XP.

Je rencontre des problèmes différents avec chacune de ces versions :

  • Avec XP 7.5 :
:mad: Point négatif : le texte met beaucoup de temps à s'afficher, les mots indexés ont de mauvaises césures (genre "MacGén-ération" ou "MacGénér-ation"), à cause de ces mauvaises césures le texte occupe plus de place ce qui rajoute des pages. Certains gros chapitres plantent même le logiciel.

:) Point positif : la génération de l'index de plusieurs chapitres ne pose pas de problème.

  • Avec XP 8.12 :
:) Point positif : aucun décalage dans le texte. Il s'affiche tel que dans la version d'origine.

:mad: Point négatif : la génération de l'index chapitre par chapitre ne pose pas de problème, mais lorsque je lance la génération de l'index de plusieurs chapitres, le logiciel plante après ce message "Certaines feuilles de style nécessaires au formatage des références sont absentes de cette mise en page". Pourtant tous les chapitres ont bien été synchronisés.
J'ai tenté ceci : enregistrer les maquettes en XP 8.12 puis les exporter vers XP 7.5 mais l'exportation plante systématiquement.
J'ai essayé aussi ceci : enregistrer les maquettes en XP 7.5 puis les ouvrir en 8.12 et générer alors l'index, mais ça plante pendant la génération de l'index avec le même message sur les feuilles de style manquantes.

Quelqu'un aurait une piste ?
Merci.
 

bjsc

Membre junior
6 Mai 2006
69
0
Je viens de passer 2 heures à dialoguer avec quelqu'un de chez Quark via le "Dialogue en ligne (chat) gratuit".
Cette personne s'exprimant dans un français traduit de l'étranger très approximatif, certaines réponses étaient incompréhensibles et j'ai eu l'impression d'un dialogue de sourd.
Ça n'a rien donné d'autre que de l'agacement et deux heures de perdues :mad:
J'ai envoyé un e-mail au support technique. Peut-être que ça aboutira à quelque chose.
 

claude72

Membre d’élite
Club MacG
13 Février 2005
3 636
261
60
Tu avais déjà lancé une discussion début 2009 sur un problème de césure des mots indexés avec XPress 6.52... à l'époque la discussion s'était arrêtée apparemment sans qu'une solution ait été trouvée...

... as-tu réglé ce problème, ou est-ce le même livre qui aujourd'hui te repose plus ou moins les mêmes problèmes ?


Quark a modifié son moteur typographique pour la version 6, ce qui a créé beaucoup de problème de compatibilité entre XPress 6 et les documents issus de versions antérieures...
... et à l'époque il était pour cette raison fortement recommandé d'ouvrir les documents XPress avec la même version que celle qui les avait créés...
(ou au moins d'utiliser une version 5 maxi pour ouvrir les docs créés sous 3, 4 et 5 et de réserver la version 6 pour les docs créés sur 6).
Et XPress 7 et 8 utilisant le même moteur que XPress 6, il est normal de retrouver les mêmes problèmes qu'avec la 6 à l'ouverture des docs 5 et antérieurs.

As-tu essayé de rouvrir ton document sur un XPress 4 ou 5 sous Classic ?
 

bjsc

Membre junior
6 Mai 2006
69
0
Tu avais déjà lancé une discussion début 2009 sur un problème de césure des mots indexés avec XPress 6.52... à l'époque la discussion s'était arrêtée apparemment sans qu'une solution ait été trouvée...

... as-tu réglé ce problème, ou est-ce le même livre qui aujourd'hui te repose plus ou moins les mêmes problèmes ?
Oui, il s'agit du même livre. (Bravo pour ta mémoire !) À l'époque, l'éditeur envisageait de simplement le faire réimprimer quand il viendrait à être épuisé, et je n'avais pas creusé plus pour résoudre le problème. Aujourd'hui, il est question de l'actualiser.


As-tu essayé de rouvrir ton document sur un XPress 4 ou 5 sous Classic ?
Classic ne fonctionne plus avec mon ordinateur actuel. Mais je suppose que si j'allume un vieil ordinateur mes documents s'ouvriront sous XPress 4. Ça apporterait quelque chose que j'essaie ?


Avec XPress 6.5 et 7.5, mes maquettes étaient mal lues (problème de césure des mots indexés).

Avec XPress 8.12, elles sont bien lues, les maquettes de chaque chapitres s'ouvrent et s'affichent telles qu'elles furent créées en XPress 4 et il est possible de générer un index pour chaque chapitre séparément, mais pas moyen de générer l'index du livre dans sa totalité, le logiciel plante. C'est comme si, au fil des versions d'XPress, un bug avait été résolu (les césures), mais qu'un nouveau (la génération de l'index) soit apparu.
 

claude72

Membre d’élite
Club MacG
13 Février 2005
3 636
261
60
Mais je suppose que si j'allume un vieil ordinateur mes documents s'ouvriront sous XPress 4. Ça apporterait quelque chose que j'essaie ?
Je pense que oui : d'abord ça permettrait de lever le doute sur le bon état de ton document et sur l'existence eventuelle d'un bug dans les versions 6.x et 7.x...

... et ensuite au pire ça te permettrait de faire le travail sur cet ordinateur !!!



C'est comme si, au fil des versions d'XPress, un bug avait été résolu (les césures), mais qu'un nouveau (la génération de l'index) soit apparu.
C'est dans le domaine des choses possibles !
 

bjsc

Membre junior
6 Mai 2006
69
0
Je pense que oui : d'abord ça permettrait de lever le doute sur le bon état de ton document et sur l'existence eventuelle d'un bug dans les versions 6.x et 7.x...
Je viens de faire le test : les maquettes ne sont pas corrompues, elles s'ouvrent sans problème en XPress 4, comme en 8.12

... et ensuite au pire ça te permettrait de faire le travail sur cet ordinateur !!!
L'auteur et l'éditeur préfèrent pour la pérennité de l'ouvrage (un dictionnaire doit pouvoir être réactualisé régulièrement) que la maquette soit faite dans des versions du logiciel compatibles avec les systèmes actuels. Déjà qu'on ne peut plus utiliser Classic avec les dernières machines, alors faire tourner un Os9 dans 5, 10 ou 15 ans, il faudra aller dans un musée !

Le problème est l'important index. L'éditeur ne voudra jamais payer pour sa recréation : 16700 clés à rentrer et ce sur 32 chapitres, quel boulot ! — même si les occurrences uniques sont majoritaires.
 

claude72

Membre d’élite
Club MacG
13 Février 2005
3 636
261
60
L'auteur et l'éditeur préfèrent pour la pérennité de l'ouvrage (un dictionnaire doit pouvoir être réactualisé régulièrement) que la maquette soit faite dans des versions du logiciel compatibles avec les systèmes actuels.
(...)
L'éditeur ne voudra jamais payer pour sa recréation : 16700 clés à rentrer et ce sur 32 chapitres, quel boulot !
Il va falloir que les deux comprennent que l'informatique et les logiciels évoluent !!! et que la compatibilité entre un doc créé sous XPress 4 et l'actuel XPress 8 n'est pas parfaite, et que donc ça va impliquer du travail supplémentaire !!!

... et que dans les années à venir, avec XPress 11 ou 15, le problème risque de recommencer !!! :siffle:
 

CMYK

Membre d’élite
Club MacG
25 Novembre 2004
1 551
39
Ici, pourquoi ?
J'ai un gros bouquin réalisé en XPress 4 dont je dois faire la mise à jour.
Quand tu ouvres d'anciens fichiers, est-ce que tu passes par le menu Ouvrir, puis Option-Commande-clic sur le bouton Ouvrir ? Dans la négative, fais-le parce que cela met à jour tout ton fichier dans la version actuelle (celle que tu utilises effectivement - du coup, je te conseille d'utiliser la 8). Enregistre le fichier. Tu pars alors sur des bases saines. Si par contre c'est déjà ce que tu fais, alors je ne peux pas t'aider davantage parce que je ne travaille jamais avec les fonctions Livre et Index (parce que je n'en ai pas besoin).
 

animoo

Membre confirmé
13 Novembre 2007
129
3
www.nimo.ch
Hello voilà un vieux post : télécharge ça :

http://www.nimo.ch/xpress.zip

C'est une petite applic développée en AppleScript, elle corrige certaines erreurs sur les fichier. J'ai récupéré pas mal d'anciens jobs avec ça !
Tu dézippe puis tu glisse simplement ton fichier .qxd sur l'icône XPress.app ...

Sans garantie mais ça coûte rien d'essayer :)
 

bjsc

Membre junior
6 Mai 2006
69
0
Quand tu ouvres d'anciens fichiers, est-ce que tu passes par le menu Ouvrir, puis Option-Commande-clic sur le bouton Ouvrir ? Dans la négative, fais-le parce que cela met à jour tout ton fichier dans la version actuelle (celle que tu utilises effectivement - du coup, je te conseille d'utiliser la 8). Enregistre le fichier. Tu pars alors sur des bases saines.

Non, je faisais un simple glisser/déposer puis "enregistrer sous"

J'ai procédé suivant ta technique, que je ne connaissais pas, avec la version 8.12.
Le logiciel plante toujours pour la génération de l'index complet mais sans le message "Certaines feuilles de style nécessaires au formatage des références sont absentes de cette mise en page". Il y a du progrès donc !

Il y a une autre technique pour partir sur de bonnes bases, c'est de passer par la commande "Ajouter" du menu "Fichier". Le problème, pour moi, c'est que ça supprime les clés d'index.

Pour voir si XP 8 gère bien la génération de l'index d'un LIVRE, je vais indexer le texte de deux maquettes créées directement avec cette version du logiciel.

---------- Nouveau message ajouté à 11h32 ---------- Le message précédent a été envoyé à 11h23 ----------

Hello voilà un vieux post : télécharge ça :

http://www.nimo.ch/xpress.zip

C'est une petite applic développée en AppleScript, elle corrige certaines erreurs sur les fichier. J'ai récupéré pas mal d'anciens jobs avec ça !
Tu dézippe puis tu glisse simplement ton fichier .qxd sur l'icône XPress.app ...

Sans garantie mais ça coûte rien d'essayer :)

Chez moi ça indique juste quelle version d'XPress a créé le document.
 

CMYK

Membre d’élite
Club MacG
25 Novembre 2004
1 551
39
Ici, pourquoi ?
Tu peux aussi exporter le texte en XPress Tags et voir ce que ça raconte. Idem avec un faux fichier nouvellement créé dans XPress 8. Tu compares et tu vois s'il n'y a pas une astuce… Il faut parfois bidouiller (surtout avec un tel saut de versions et la gestion de gros fichiers + index).
Et il n'y avait aucune extension particulière ?

Attention : la dernière version en date est la 8.1.6. Autant travailler avec celle-là :up:
 

fau6il

Membre d’élite
Club MacG
9 Décembre 2005
1 625
454
Ardent Citadin
Je viens de passer 2 heures à dialoguer avec quelqu'un de chez Quark via le "Dialogue en ligne (chat) gratuit".
Cette personne s'exprimant dans un français traduit de l'étranger très approximatif, certaines réponses étaient incompréhensibles et j'ai eu l'impression d'un dialogue de sourd.
Ça n'a rien donné d'autre que de l'agacement et deux heures de perdues :mad:
J'ai envoyé un e-mail au support technique. Peut-être que ça aboutira à quelque chose.
Ici, on te répondra clairement en français

=> "Custservice (FR)" <custservice.fr@quark.com> :zen:
 

bjsc

Membre junior
6 Mai 2006
69
0
Tu peux aussi exporter le texte en XPress Tags et voir ce que ça raconte. Idem avec un faux fichier nouvellement créé dans XPress 8. Tu compares et tu vois s'il n'y a pas une astuce… Il faut parfois bidouiller (surtout avec un tel saut de versions et la gestion de gros fichiers + index).
Ça va occuper mon après-midi ;)
T
Et il n'y avait aucune extension particulière ?
Aucune.


Attention : la dernière version en date est la 8.1.6. Autant travailler avec celle-là :up:
Les maquettes créées avec cette version sont données comme des "Fichier exécutable Unix", dans les infos :



---------- Nouveau message ajouté à 12h13 ---------- Le message précédent a été envoyé à 12h06 ----------

Ici, on te répondra clairement en français

=> "Custservice (FR)" <custservice.fr@quark.com> :zen:
J'ai utilisé cette adresse pour un problème avec le code de validation de la version 8.
La personne qui m'avait répondu est la même avec laquelle j'ai dialogué hier, à moins que chez Quark toutes les personnes qui répondent en français portent ce même prénom très particulier !
 

TibomonG4

Vénérable sage
Club MacG
26 Novembre 2003
18 290
3 938
tibomonG4.free.fr
Et en enregistrant une copie de la version 7.5 en prenant soin de supprimer les césures puis créer un nouveau fichier avec les paramètres césure de l'ancien fichier ?
 

bjsc

Membre junior
6 Mai 2006
69
0
Et en enregistrant une copie de la version 7.5 en prenant soin de supprimer les césures
Jusque là je comprends :p


puis créer un nouveau fichier avec les paramètres césure de l'ancien fichier ?
Là je ne saisis pas la manœuvre.
Je crée un nouveau fichier avec les paramètres de césure de mes maquettes qui posent problèmes. Et après je fais quoi ?

---------- Nouveau message ajouté à 14h04 ---------- Le message précédent a été envoyé à 13h56 ----------

Je pense que c'est certainement un problème d'extension manquante sur le nom du fichier :
Ça ne change pas le type :

 

bjsc

Membre junior
6 Mai 2006
69
0
As-tu redémarré ?
Sinon essaye avec Onyx : reconstruire la base LaunchServices

:zen:
Redémarrer c'était fait. Reconstruire la base LaunchServices je viens de le faire mais ça ne change rien.

En faisant différents tests je découvre que les fichiers créés avec XPress 7.5 prennent l'icône de la version 8 et ouvrent cette version du logiciel lorsque je double clique dessus.
Maintenant si dans le fenêtre Infos je choisis à "Ouvrir avec" la version 7.5, l'icône devient celle de cette version (rond orangé) mais le type de fichier passe de "QuarkXPress Project File" à "Fichier exécutable Unix". Si je double clique dessus XPress 7.5 s'ouvre.

J'en perds mon latin :confused: