Carbon pas si compatible MacOS 9

-anonyme-

Légende
26 Février 2001
66 286
2 673
Si j'en crois ce que nous avait promis Apple, une application carbonisée devait rester compatible avec MacOS 9...

Alors bien entendu, j'ai voulu essayer :)

CarbonLib 1.2.5 installé sur mon OS 9.1 (US donc), j'ai téléchargé iMovie2 version OS X... Entretemps je me posais la question pourquoi Apple continuait à le vendre à $49 si la version Carbon (sensée être 9 & X) devenait gratuite ;-)

Et bien ça ne marche pas, une fois le contenu du package entrouvert, l'iMovie contenu dans MacOSClassic refuse de se lancer en indiquant clairement: "This version of iMovie can only be run on OS X."

Donc, pas si descendante que ça la carbonisation...

Et c'est plutôt mesquin de la part d'Apple de commencer à pas tenir sa parole. Le message affiché indique clairement qu'il s'agit d'une volonté d'Apple de restreindre iMovie2 à MacOS X, et non à une version de CarbonLib pas au même niveau que le Carbon d'X (un message d'erreur d'appel aurait été émis)


[Ce message a été modifié par pierrelyon (edited 27 Mars 2001).]
 

-anonyme-

Légende
26 Février 2001
66 286
2 673
Hé non, iMovie et iTunes sont bien malheureusement simplement carbonisé.

Je dis "malheureusement" même si certains me diront qu'il n'y a pas de différences notables entre une appli carbon et une appli cocoa puisque ce ne sont que des APIs, mais je doute que pour iMovie qui consomme énormément de ressources lors des calculs d'effets ou transitions, l'appli ne gagne pas en performance en étant redéveloppée sous frameworks X. Permettez-moi de considérer que pour l'instant, Apple a mis une rustine pour respecter ses délais, espérons que la version 3 parte de zéro, ou du moins pour son grand frère ainé: Final Cut Pro... 3
 

Gwenhiver

Membre d’élite
Club MacG
8 Décembre 2000
3 351
2
Visiter le site
Ben oui...
Disons qu'Apple a peut-être un peu exagéré en déclarant que les applications Carbon tournaient sous Mac OS 9 et Mac OS X.

Mais bon, la raison n'est quand même pas purement commerciale, puisque les développeurs font de même. (Par exemple, iCab existe en deux versions, bien que carbonisé -- et même si c'est possible, il n'est pas recommandé de faire tourner la version OS X sur OS 9 -- et Audion se comporte de la même façon qu'iMovie -- avec donc aussi deux versions qui cohabitent.)

------------------
iMac DV+ (Summer 2000) 20Go/320Mo Mac OS 9.1 et X