Ce forum est en partie financé par l’affichage de publicités. Merci de désactiver votre bloqueur de publicités pour nous permettre de continuer à fournir ce service.

Changement de format des cellules sur Neooffice-Spreadsheet

Discussion dans 'Bureautique et productivité' créé par Goufou, 23 Novembre 2007.

Modérateurs: Aliboron
  1. Goufou

    Goufou Nouveau membre

    Inscrit:
    24 Juillet 2007
    Messages:
    7
    J'aime reçus:
    0
    Bonjour,

    J'ai un petit problème avec Neooffice, qui pour le coup aurait été réglé en deux coups de cuillère à pot sur Microsoft Office, mais visiblement plus complexe sur Neo. Ca parait totalement absurde comme problème, mais je ne trouve la solution nulle part.

    Je m'explique :

    J'ai installé Neooffice, en version plus ou moins française (le texte est par défaut en français, mais tout est écrit en anglais dans les menus, déjà là, je comprends pas bien le concept, mais peu importe), et il considère qu'entre la partie entière entière d'un nombre et la partie décimale, il faut mettre une virgule — le format standard est en 0,00. C'est son droit, mais franchement, rien de plus pénible que d'avoir partout ces satanés virgules, au lieu de point, pour la simple raison, que rien n'est compatible avec le format 0,00. J'ouvre un document csv, il ne reconnait aucune valeur par exemple, parce que le document a été écrit par un programme en C++ avec l'écriture standard 0.00. Je fais un copier coller de valeurs provenant d'un terminal ou d'un document texte avec des résultats de calcul, il ne reconnait pas.

    Or j'arrive sans problème à changer le format pour un document, en sélectionnant tout et avec format -> Cells... mais dès que j'ouvre un autre document il faut recommencer. Ce qui signifie que si j'ouvre un document .csv, le format de cellule redevient standard avec les virgules et non les points, il ne reconnait pas les nombres. De plus si je change de format, après ouverture du document, il modifie les cellules 0.00000 en '0.00000 pour ne pas à avoir les considérer comme des nombres. Du coup, impossible d'utiliser les données de mon programme en C. (et yen a des milliers, je ne vais pas les recopier :) )

    Comment faire pour que le format standard soit en 0.00 et non en 0,00, dès l'ouverture d'un document ? (Et ceci de façon définitive, puisque je n'ai jamais utilisé, et je n'utiliserai jamais le format 0,00)

    J'espère que quelqu'un pourra m'aider :)

    Merci.

    EDIT : J'ai trouvé ! C'est dans Préférences (ou Tools, option) language settings -> languages -> Decimal separator key.
    Voilà problème résolu :)
     
Modérateurs: Aliboron
Chargement...