MacBook Pro Changement nappe sata A1278 problème

dodo02

Membre junior
25 Juillet 2017
17
0
28
Bonjour à tous,

voilà je rencontrais des soucis avec mon cable interne de mon macbook pro 13' mid 2012 (Modèle A1278)

Pour verifié qu'il s'agissais bien du cable qui ne fonctionnais pas j'ai utiliser mon SSD samsung 500Go que j'avais installer en interne, en externe. Et la par magie, le SSD fonctionne parfaitement et je peux utiliser mon macbook pro sans problème... (Même si des fois j'ai la roue qui apparait indéfiniment, du coup ça plante et je dois redemarré mais je remet ça sur la faute au fait que je sois connecté en externe, même si c'est pas très fréquent comme bug)

Du coup je me suis empressé d'aller commander un cable sur IFIXIT

(Je n'arrive pas à poster un lien: il s'agit du modèle lorsque je tape macbook pro mid 2012 nappe sata A1278)

Je le reçoit et l'installe (Juste le fait de devoir plier le cable SATA c'est l'opération la plus délicate) mais sinon aucun soucis pour l'installer en suivant correctement le tuto.

Et là lors du démarrage plus de HDD reconnu par mon mac. Je démarre donc avec ALT enfoncé, j'ai la récup par internet, j'arrive à accèder à l'utilitaire, effectivement rien n'est reconnu. Du coup je revérifie ma connectique, et relance : même soucis.

De peur d'avoir abimé un composant je décide de réinstaller l'ancien, et là paf ça me reconnait mon HDD (Ca démarre même dessus, j'ai cru un instant que je pouvais le réutiliser mais après 30 min dessus j'ai eu un plantage avec la roue qui tourne indéfiniment )

Je recontacte IFIXIT pour le faire part du soucis il m'en renvoie un direct sans renvoyer l'ancien

Enfin ayant reçu le nouveau : même soucis ... ( Malgré qu'un cours instant il à été reconnu brièvement mais j'avais au lieu d'un dossier avec point d'interrogation ce symbole-ci (Je n'arrive pas à poster un lien: il s'agit d'un rond avec une barre diagonale, comme un panneau d'interdit de stationner)
Après vérification de l'installation j'ai le même soucis finalement qu'avec l'ancien cable, il ne reconnais pas le disque dur.

Bon je réinstaller l'ancien cable, pareil ça refonctionne mais je fais plus trop confiance à l'ancien cable...

Je suis vraiment perdu, je sais pas ou est le soucis du coup, pourtant l'ancien fonctionne mais il est très lent et j'ai des bug, je suis persuadé que c'est le cable qui ne fonctionne car là actuellement j'écris le poste avec mon disque dur dans un boitier externe...

Pourtant le modèle de mon mac correspond au cable ...

Voici une série de photo pour y voir plus clair
(Je n'arrive pas à poster un lien)

Quelqu'un sait pourquoi je n'y arrive pas? J'ai vu que certain parlais de problème au niveau du contrôleur SATA? Mais dans ce cas je ne devrais absolument pas reconnaître mon disque dur?

PS: J'ai pensé à remplacer mon lecteur optique par un emplacement pour mon SSD, je sais pas si ça peut régler le soucis mais en tout cas là je m'écoute un disque audio et je n'ai aucun soucis de lecture donc je pense que si j'opte pour cette solution ça devrais fonctionner...

Merci de vos réponses :)
 

okeeb

Membre d’élite
20 Janvier 2015
1 740
567
43
Cher (18)
www.flickr.com
Si nous remettons les choses dans l'ordre, nous avons cela :

1/ ssd en interne avec nappe d'origine : KO
2/ ssd interne monté en externe : OK mais pas vraiment puisque ralentissements et crashes
3/ ssd monté en interne avec nappe neuve : KO

Je demanderais donc :

1/ êtes-vous certain de votre montage ?
2/ pourquoi ne douter que de la nappe et pas du ssd ?

Et je répondrais donc :

1/ tentez d'installer un autre disque en interne
2/ sortez-le et branchez-le en externe

Ca donne quoi ?

Un ssd est plus exigeant qu'un hdd au niveau de la qualité du débit de données, ce qui explique que certains ne s'aperçoivent de leur nappe faiblarde que lorsqu'ils installent un ssd. Maintenant je trouve surprenant qu'avec une nappe neuve le souci perdure. La probabilité de tomber sur une nappe défectueuse est tout de même doutable.
Par contre, connaissant Samsung et certains de leurs ssd, cela pourrait valoir le coup de suspecter votre ssd...
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
34 793
4 045
Et la par magie, le SSD fonctionne parfaitement et je peux utiliser mon macbook pro sans problème... (Même si des fois j'ai la roue qui apparait indéfiniment, du coup ça plante et je dois redemarré mais je remet ça sur la faute au fait que je sois connecté en externe, même si c'est pas très fréquent comme bug)
Au lu de tout ce que tu décris, je mettrais en cause le SSD Samsung vu que tu as changé par deux fois la nappe SATA.

Comme en réponse #2, si en interne tu installes un autre disque dur avec les nappes neuves et que tout se passe bien, alors ce serait ton SSD qui pose problème. Tu n'en as pas un autre pour tester ?
 
  • J’aime
Réactions: okeeb

dodo02

Membre junior
25 Juillet 2017
17
0
28
Quand je suis en externe c'est juste quand je bouge mon disque dur principalement que ça plante, sinon pas de ralentissement mais juste comme je dit des plantages... il n'est pas possible de vérifier mon disque dur avec un logiciel? La par exemple 5h que j'utilise mon pc sans soucis...
 

dodo02

Membre junior
25 Juillet 2017
17
0
28
Bon j'ai remis un anciens HDD (WD 500 go) et visiblement il le reconnait... J'aimerais maintenant faire des tests dessus pour être sûr que ça fonctionne bien à l'interieur (la nouvelle nappe sata) qu'est ce que je pourrais faire pour être sûr ? Avant tous je vais le formater en quelle format ?

Ensuite j'ai penser à réinstaller l'os dessus et utiliser pendant 1 ou 2 jours mon disque dur 5400 rpm (Celui dans le mac) je risque juste d'un peu rager niveau vitesse mais au moins ça confirmerais vos supçons... Cependant je vois pas pourquoi mon SSD fonctionne bien en externe (à part comme je vous ai dit 1 crash lorsque je manipule le boitier externe, et encore c'est assez rare)
 

Fichiers joints

dodo02

Membre junior
25 Juillet 2017
17
0
28
Bon j'ai bien mon HDD qui est reconnu mais impossible de le formater, j'arrive juste à le formater en MS DOS

J'ai tenter en GUID et partition apple dans les schéma mais j'ai ces erreurs-ci

Capture d’écran 2017-07-25 à 22.36.07.png
Capture d’écran 2017-07-25 à 22.36.36.png


Je suis toujours sur l'OS qui est installer sur SDD dans un boitier externe, il vois bien le disque dur interne mais impossible à le formater...
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
44 339
6 922
Nancy___
Erreur d'entrée / sortie, c'est un problème hardware : SSD ou bien nappe HS.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
34 793
4 045
Moi je dirais, encore un problème avec la nappe SATA et oui ça peut arriver, car tu n'es pas le seul membre à qui c'est arrivé.
 

dodo02

Membre junior
25 Juillet 2017
17
0
28
je viens de récupérer un macbook pro 2009 (défectueux CM hs) j'ai recupérer la nappe dessus et installer dans mon mac, de nouveau le même soucis, surtout que j'ai récup le SSD dans ce mac pour l'installer dans le miens, de nouveau impossible de le formater... Vous allez pas me dire que mes 3 nappes sont HS? ( 2 reçu d'IFIXIT et 1 d'un ancien mac) Ou que le soucis viens du disque dur ? ( 2 SSD tester + 1 HDD)
 

dodo02

Membre junior
25 Juillet 2017
17
0
28
Bon je fais un petit up pour trouver une solution que j'ai trouver de remplacement, j'ai tous simplement remplacé mon lecteur optique par une baie pour disque dur, et là comme par magie ça fonctionne niquel, du coup j'ai pu réutiliser mon mac comme avant, voilà si quelqu'un passe par ce topic et qu'il aurait une idée quand même pour éventuellement pouvoir profiter de mes 2 emplacements pour disque dur ça serait cool!
 

Yuls

Membre d’élite
1 Juin 2003
1 034
165
41
Lyon
Une question au passage, as-tu installé tes 3 nappes en prenant soin de bien les disposer dans les baies Superdrive et disque dur, sans les plier et les rentrer de force ?
 

dodo02

Membre junior
25 Juillet 2017
17
0
28
Je suis obliger de les pliers au niveau des vis, c'est d'ailleurs l'opération la plus délicate lors de l'installation que j'ai rencontré. Le premier je l'ai plié à l'exterieur du pc avec un spatule en plastique, le second j'ai suivi un tuto sur youtube ou le mec le plie directement dans le mac, et le 3e il s'agissait d'un connecteur d'un macbook pro 2009 déjà plier (D'ailleurs le cable était un peu plus long au niveau du connecteur et il ne collais pas parfaitement au mac mais je doute que ça change quelque chose, il étais juste un peu arrondi...)