Cherche formule de calcul d'intervalle d'heures pour Numbers

Tricassien

Membre enregistré
22 Octobre 2019
3
0
50
Bonjour,

Ça fait 2 jours que je tente désespérément de trouver une formule pour calculer le résultat du nombre d'heure comprise entre 35h et 43.

Mes souhaits :

que dans L9 soit calculée le nombre d'heures comprises entre 35 et 43 du résultat K8

Que L10 soit le nombre d'heures à partir de la 43ème.

Merci pour votre aide ! o_O
Compteur d'heures.png
 

zeltron54

Membre expert
Club MacG
29 Mars 2008
2 348
369
Lorraine
Bonjour,

Pour pouvoir t'aider, il faudrait savoir ce qu'il y a dans ta cellule k8, comment est obtenu le 48, le 31, et comment tu les as mis en forme l'affichage, afin de savoir comment récupérer ces valeur ...
 

Tricassien

Membre enregistré
22 Octobre 2019
3
0
50
Bonjour,

K8 est la somme de K2=>K7, l'affichage est en heure et en durée.
En fait je souhaiterai faire un compteur d'heure suplémentaire, mais en détaillant le nombre d'heure.

CAD :

dans L9 (de la 36ème à la 43 ème heure) et L10 dès la 44ème

exemple :

- si K8 est inférieur à 44h le compteur de L10 doit indiquer 0h 0min,
- si K8 est 38h 45min L9 doit indiquer 3h 45 min...

Merci.
 

zeltron54

Membre expert
Club MacG
29 Mars 2008
2 348
369
Lorraine
Ok! bien compris, mais cela ne répond pas à ma question, comment sont saisie, les heures, minutes, sous quelles formes. quelles formules exacte y a t'il dans les cellules K2,K.... k8, et aussi dans C2 etc...
Il faut pouvoir récupérer juste les heures de k8 et les minutes de K8 ...
 

zeltron54

Membre expert
Club MacG
29 Mars 2008
2 348
369
Lorraine
Je suppose que tu entres tes valeur en h:mn:sec.
Donc dans la cellule L9 la formule doit être: =SI(ENT(DURHEURES(K8))<35;0;SI(ENT(DURHEURES(K8))−35≥8;DUREE(0;0;8;0);DUREE(0;0;(ENT(DURHEURES(K8)−35));DURMINUTES(K8)−ENT(DURHEURES(K8))×60)))
dans la cellule L10 la formule: =SI(ENT(DURHEURES(K8))<43;0;DUREE(0;0;(ENT(DURHEURES(K8))−43);DURMINUTES(K8)−ENT(DURHEURES(K8))×60))
 
  • J’aime
Réactions: baron

Tricassien

Membre enregistré
22 Octobre 2019
3
0
50
Je suppose que tu entres tes valeur en h:mn:sec.
Donc dans la cellule L9 la formule doit être: =SI(ENT(DURHEURES(K8))<35;0;SI(ENT(DURHEURES(K8))−35≥8;DUREE(0;0;8;0);DUREE(0;0;(ENT(DURHEURES(K8)−35));DURMINUTES(K8)−ENT(DURHEURES(K8))×60)))
dans la cellule L10 la formule: =SI(ENT(DURHEURES(K8))<43;0;DUREE(0;0;(ENT(DURHEURES(K8))−43);DURMINUTES(K8)−ENT(DURHEURES(K8))×60))

Je ne sais quoi dire ! Je reste bouche bée... vous êtes un génie
Merci+++
 

zeltron54

Membre expert
Club MacG
29 Mars 2008
2 348
369
Lorraine
content pour toi !