Clavier MIDI M-Audio Axiom : sa config' est "volatile"

Leon-Naej

Nouveau membre
30 Septembre 2011
2
0
Bonjour à tous !

Je viens vers vous car j'ai un gros problème que je n'arrive pas à résoudre depuis...un an. ^^'
Voilà le topo : je possède un clavier MIDI M-Audio Axiom 49 (ancienne génération, les bleus) que j'utilise avec Logic Pro 9.
Ce clavier est très bien reconnu par mon macbook blanc de 2009, tous les contrôles fonctionnent, mais le gros problème est le suivant : quand je le configure dans Logic (telle touche actionne telle fonctionnalité du logiciel) la configuration est prise en compte pour cette session d'utilisation, mais la fois d'après ça ne marchera plus !
Le plus étrange est que la configuration est toujours présente dans Logic, mais c'est comme ci ce dernier ne reconnaissait pas le clavier comme étant le périphérique auquel elle s'applique.

Ça arrive à tous les coups quand je le débranche (alors que le mcbook est éteint pourtant) et le rebranche (mcbook éteint toujours mais ayant été rallumé une fois sans le clavier). Je suis obligé de le débrancher souvent car je bouge pas mal...

J'ai hanté pas mal de forum, sites (en anglais aussi) etc sans trouver de solution à ce problème et je désespère un peu car ça enlève presque tout intérêt au clavier. J'ai l'impression que ça viendrait d'un identifiant de périphérique qui change à chaque fois mais j'y connais pas grand chose sur le sujet...

Merci de m'avoir lu :zen:

Leon-Naej


Ben en fait, là, je ne suis pas convaincu qu'il s'agisse d'un problème de périphérique, je pense plutôt à un souci logiciel. Dans tous les cas, ceux qui sont le plus à même de te répondre squattent dans le forum "Musique", donc, on va s'y rendre !
 
Dernière édition par un modérateur:

Leon-Naej

Nouveau membre
30 Septembre 2011
2
0
Bon apparemment ça viendrait de Logic qui a tendance à pourrir le fichier des préférences quand il en a envie. Là ça apparait quand il se lance sans l'Axiom connecté, au moins je sais quand ça arrive.

Donc la parade pour ceux que ça intéresserait consiste à faire un back-up du fichier de préférences qui se trouve dans ~/Library/Preferences/ et qui s'apple apple.logic.pro.cs. Donc une fois que vous avez fait tous vos réglages, quittez Logic et faites un back-up (sauvegarde) de ce fichier (normalement à ce moment là il fonctionne toujours sauf vraiment pas de bol).
La prochaine fois que vous perdez vos réglages, supprimez le fichier de preférences courant (corrompu) et remplacez-le par le back-up.
Bien sûr ça veut dire qu'à chaque fois que vous faites de nouvelles assignations MIDI vous avez intérêt à faire un nouveau back-up...

Bref pas top de la part de Logic sur ce coup, ça fait pas très sérieux.

P.S : J'explique la manip' un peu plus en détail ici. S'il existe une meilleure méthode je suis preneur !