Comment résoudre ce problème de police ?

kriscus

Membre actif
Bonjour à tous,

Je viens de switcher sur Mac et je crois que j'ai fait ma première bourde :(

J'ai pris toutes les polices que j'avais sous Windows que j'ai collé dans le "Livre des polices". Le système m'a gentillement installé les polices. J'ai ensuite supprimé les doublons via l'option "Résoudre les confllits de doublons".

Seulement voilà, maintenant j'ai parfois ce genre de problème d'affichage :

police.jpg


Je suppose qu'une police cause des soucis mais je n'arrive pas à savoir laquelle. Le livre de police ne me signale aucune erreur.

Savez-vous comment résoudre ce problème ? J'aimerai aussi, si possible, remettre le système avec ses polices de bases afin de repartir sur quelque chose de propre car là je me retrouve avec des tas de doublons (désactivés quand même).

Merci d'avance !
 

vleroy

Membre expert
Club MacG
6 Novembre 2004
6 761
1 918
hop hop hop
essaye ce qui est proposé ci-dessus. cela ne mange pas de pain, mais cela ne changera pas grand chose à mon avis.

Pour répondre à ta question (repartir sur du propre); tu rebootes ta machine en insérant le CD d'installation et tu tapes (bref regarde les posts sur le sujet) pour booster dessus (déoslé il est tard)
Et là tu reprends ta machine en réimportant tout sauf les polices
Au moins celles de base y seront remises

C'est simple, et cela prend que 45 minutes (enfin sur ma machine:D :D :D )
 

kriscus

Membre actif
J'ai suivi les recommandations de Tucpasquic et visiblement c'est partiellement corrigé. Merci ! Dans l'OS ça semble OK (Safari inclus) mais sous Firefox et Thunderbird ça coince toujours...

Quand à tout réinstaller le système non merci ! J'ai passé 3 jours à tout installer (applications, documents, comptes mails, windows via Parallels Desktop). Je parlais de réinstaller seulement les polices de base, pas tout l'OS.

Visiblement c'est la police Arial qui pose soucis. Je vais voir ce que je peux faire. Si vous avez d'autres pistes je suis preneur ;)
 

vleroy

Membre expert
Club MacG
6 Novembre 2004
6 761
1 918
Mais réinstaller ne te fera perdre aucune donnée, relis mon post! Et les post dédiés!
Tu ne perdras que 45 minutes car il te demandera si tu veux importer tes données, et tu va slui dire oui, avec tout dedans. T'y verras que du feu.
Mais tes polices seront toutes propres. Et tes noyaux aussi.
Allez zou
 

kriscus

Membre actif
J'ai trouvé la solution à mon problème en fait !

Mes polices provenant de Windows sont dans user/bibliothèque/fonts et celles du système sont directement dans /bibliothèque/fonts

Via le livre des polices j'ai comparé la provenance des polices Arial et j'ai désactivé toutes celles de user/bibliothèque/fonts et activé les autres. En fait je n'avais pas désactivé forcément les bonnes à chaque fois. (je ne sais pas si j'ai été bien clair)

Je pense que je vais tenter de supprimer carrément les fichiers de user/bibliothèque/fonts pour tester. A mon avis je vais me retrouver qu'avec les polices systèmes et de là je referai une installation propre de mes polices.
 

apenspel

Membre expert
Club MacG
23 Juin 2002
7 056
329
.be - BXL
Tu as intérêt à comparer les versions et ne garder que les plus récentes.
 

kriscus

Membre actif
Donc je confirme, j'ai supprimé tous les fichiers de mon dossier user/bibliothèque/fonts et après un redémarrage je me retrouve dans mon livre des polices, après réactivation de toutes, avec une liste bien propre de polices. J'ai comparé cette liste à celle d'un autre Mac sur lequel aucune police n'a été modifiée et tout est identique.
 

vleroy

Membre expert
Club MacG
6 Novembre 2004
6 761
1 918
ta manip prouve que les deux solutions n'auraient rien donné (surtout la mienne) car tu n'aurais pas effacé la biblio dont tu parles (mais tu nous avais pas dit que tout était sous deux bilbio)
Bien joué!
On apprend tous les jours;)
 

apenspel

Membre expert
Club MacG
23 Juin 2002
7 056
329
.be - BXL
Oui, il s'agissait d'un conflit de versions, sans doute. Ça donne exactement la même chose quand on remplace une version par une autre, le cache n'étant pas vidé.
J'expérimente assez souvent ce genre de choses car je bosse de temps à autre sur des fontes perso et à chaque nouvelle version, j'ai ce type de problème que le vidage des caches résout bien.
 

Stiff

Membre enregistré
24 Avril 2010
6
2
Bonsoir à tous,

Je sais que le post date un peu mais après une courte nuit, j'ai fait une grossière erreur. Afin de me calmer j'aurai voulu savoir si quelqu'un pouvait m'aider.

J'ai supprimé toutes les polices systèmes de mon MacBook Pro... :mad: Résultats des courses, le démarrage est fort lent, je suppose qu'il cherche les polices et qu'il ne les trouve pas. Je suis bloqué sur le bureau et plus rien ne se passe. Plus aucunes fenêtres ne veux s'ouvrir, le dock n'apparait plus et le menu n'apparait plus non plus.

En fait, je suis assez prudent en général, donc je sauvegarde souvent mes données via timemachine. J'ai pensé reprendre la configuration du mac à la date d'hier mais le problème, c'est qu'il ne détecte pas mon disque dur. Alors j'ai penser à reformater le mac mais pareil, il ne détecte pas le DVD en fait il le lit mais je n'ai aucune visibilité du DVD ou des périphériques sur le bureau.

Si quelqu'un pouvait m'aider se serait vraiment gentil, merci d'avance

Stiff