Comportement de CCC : blocages intempestifs pendant la copie

chafpa

Membre d’élite
Club MacG
12 Décembre 2009
2 586
141
Aux pieds des Vosges côté Alsace
J'utilise Carbon Copy Cloner, maintenant la version payante, et je lui trouve un comportement capricieux.

Lorsque je fais un clone, en plus de ma Time Capsule, je suis presque systématiquement obligé de m'y reprendre à plusieurs reprises car il reste bloqué sur un fichier lambda. Quand cela se produit, j'arrête l'opération et la relance. Elle reprend là où elle s'était bloquée et continue son bonhomme de chemin ... jusqu'au blocage suivant car cela m'arrive la plupart du temps 2 fois lors d'un clonage.

Là où c'est pas triste c'est pour arrêter l'opération qui ne veut pas s'arrêter.

J'ai exposé mon problème à Bombich, l'éditeur, et j'ai reçu une fin de non-recevoir m'expliquant que c'est ma machine, ou moi, ou ma configuration comme vous voulez, qui était en cause.

Quelqu'un a-t-il été confronté à ce problème ?

Toute aide serait la bienvenue. ;)
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 126
625
À côté (de ma plaque)
As-tu essayé de désactiver Time Machine le temps de faire tes clones ?

Le blocage se produit-il toujours sur les mêmes fichiers ?

Utilises-tu une autre application pendant que CCC fait son travail ?

As-tu fouillé la Console ?


Bombich m'avait cordialement accueilli quand je lui avais exposé mon problème (en fait lié au chaînage de mes disques externes).
 

chafpa

Membre d’élite
Club MacG
12 Décembre 2009
2 586
141
Aux pieds des Vosges côté Alsace
Time Machine est toujours désactivé quand je fais le clone tout comme Sophos .... Rien d'autre ne tourne.

Il ne bloque jamais sur le même fichier. Dés fois c'est sur une photo, d'autre fois c'est sur le machine virtuelle de Parallels, jamais rien d'identique.

La console, c'est hélas de l'hébreu pour moi et je n'ai jamais pensé à aller voir ce qui se passe quand cela se produit. De tout façon à ce moment-là, le Mac est bloqué. C'est pour cela que j'écrivais " Là où c'est pas triste c'est pour arrêter l'opération qui ne veut pas s'arrêter." Je n'ai plus la main sur rien et cela finit par un débranchement de la prise électrique du Mac. :confused:

Merci de te pencher sur mon problème.

PS : J'ai écrit une bêtise en ce qui concerne la console. Quand je clone, j'afiche toujours la fenêtre du log de CCC pour suivre le bon déroulement des opérations. Rien ne s'inscrit à ce moment là sauf que l'utilisateur a arrêté l'opération.

Par ailleurs, j'ai souvenir qu'une fois, le moteur de synchronidation n'a jamais voulu s'arrêter de démarrer. J'ai dû arrêter le Mac à la hussarde .... une foic de plus.
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 126
625
À côté (de ma plaque)
S'il ne bloque jamais sur le même fichier, on peut penser à un gag matériel : câble de connexion au disque externe, auto-extinction du disque externe, disque externe défectueux, …

Ou peut-être télécharger et installer un nouvel exemplaire de CCC ?
Il y a un com.bombich.ccc.plist dans les Préférences de ton Compte,
et un com.bombich.ccc dans les PrivilegedHelperTools de la Bibliothèque de Macintosh HD.


Tu peux aussi noter l'heure du plantage, et aller voir les messages de la Console après que tu aies redémarré le Mac,
ou en remontant le temps dans Tous les messages jusqu'à l'heure précise du plantage, ou en cherchant un rapport de crash de CCC.
 

chafpa

Membre d’élite
Club MacG
12 Décembre 2009
2 586
141
Aux pieds des Vosges côté Alsace
Hier soir j'ai lancé un clonage et ce matin j'avais un message me demandant de supprimer un fichier de la destination et de réessayer, ce que je suis en train de faire. Ce fichier était la Machine Virtuelle de Parallels.

Voici ce que raconte le log, du moins l'un des 2 logs car j'en ai 2 dans la console mais l'autre ne raconte pratiquement rien.

-----------------------------------------
01/14 21:27:01 Clonage en cours...
01/14 23:04:32 rsync: receive_data: write failed on "/Volumes/Clone Mavericks/Users/Paul/Parallels/Windows 8.pvm/Windows 7-0.hdd/Windows 7-0.hdd.0.{5fbaabe3-6958-40ff-92a7-860e329aab41}.hds": Invalid argument (22)
01/14 23:04:32 rsync: connection unexpectedly closed (13169493 bytes received so far) [sender] (10001)
01/14 23:04:32 Bénédiction du volume destination...
01/14 23:32:05 An error occurred while blessing the destination volume /Volumes/Clone Mavericks: Error Domain=com.bombich.ccc.ErrorDomain Code=451 "Mac OS X ne répond pas à la requète de CCC pour effectuer une tâche privilégiée." UserInfo=0x6080000f6700 {NSLocalizedRecoverySuggestion=Lisez le log de CCC pour plus de détails. Si le problème persiste, soumettez un rapport de bogue via le menu Aide., NSFilePath=No command!, alertStyle=2, showLogOption=false, NSLocalizedDescription=Mac OS X ne répond pas à la requète de CCC pour effectuer une tâche privilégiée.} (451)
01/14 23:51:38 Nettoyage...
01/15 00:19:41 Mise à jour du "Dynamic Linker Shared Cache" sur le disque de destination...
01/15 00:53:45 139,12 Go [Veuillez consulter Carbon Copy Cloner Documentation pour obtenir des explications sur ce comportement]
----------------------------------------------------
J'ai mis en gras le fichier incriminé qui est le hdd virtuel contenant Windows 7 et 8.

---------- Nouveau message ajouté à 11h41 ---------- Le message précédent a été envoyé à 09h51 ----------

J'ai donc supprimé le fichier et relancé le clonage qui vient de se terminer avec succès.

Le problème, c'est qu'il en est toujours ainsi alors que sous Snow Leopard je n'avais aucun souci !
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 126
625
À côté (de ma plaque)
L'écriture d'un fichier qui foire et la bénédiction du disque externe qui renâcle, ça m'évoque plus un problème au niveau du disque externe que de CCC lui-même.

J'en reviens donc au câble et au disque externe.
Mais je ne suis pas le développeur habitué à déchiffrer les rapports de bogue de son logiciel…
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 926
3 160
+1
Il faudrait vérifier (si c'est possible) le disque de destination ; il peut y avoir un problème avec le disque ou son contrôleur. Ou le câble (faux contact ?).
 

chafpa

Membre d’élite
Club MacG
12 Décembre 2009
2 586
141
Aux pieds des Vosges côté Alsace
Alors petite précision que j'aurais dû déjà écrire : j'ai 2 HDD externes dont l'un contient le dernier clone de Mountain Lion, et tous les 2 me font cette blague que je les connecte en firewire 800 ou en USB.

J'ai contacté Bombich qui me demande le log complet. Malheureusement, j'ai suivi le coseil de François et j'ai fais le ménage de l'ancienne version et effacer le contenu de la console avant d'en réinstaller une nouvelle pour voire si la précédente installation n'était pas corrompu.

Je vais changer mon câble firewire, ce n'est pas ce qui me manque et vérifier, et réparer si nécessaire, le HDD que j'utilise actuellement.

Wait and see et merci de vos conseils. ;)
 

pascalformac

Légende
Club MacG
23 Novembre 2003
58 699
1 814
ceci dit dans le passé j'ai eu , parfois, des blocages assez proches
et je constatais que c'était uniquement avec certains types de fichiers ( dans mon cas des dmg cryptés verrouillés)

très possible que CCC soit "un peu susceptible" avec tes fichiers " parrallels windows"
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 126
625
À côté (de ma plaque)
Le souci que j'avais eu avec CCC lors d'une mise à niveau de mon OS X ne tenait qu'au chaînage de mon disque externe FW : il a disparu au branchement direct de mon disque externe au Mac.
 

chafpa

Membre d’élite
Club MacG
12 Décembre 2009
2 586
141
Aux pieds des Vosges côté Alsace
Et bien ce matin j'ai fais une nouvelle tentative après une réinstallation la plus clean possible de CCC et en me connectant en USB car mon iMac n'a que le firewire 800 en plus, pas de 400 ... logique.

Tout s'est bien lancé sauf que 3 heures après, je suis allez voir où cela en était. Clonage interrompu car le HDD externe s'était éjecté :eek:

Va comprendre Charles !

Je viens juste de le relancer, comme préconisé, et je vais voir si cette fois le clonage va à son terme avec succès. Il a repris là où il avait stoppé vu que le volume déjà cloné était pris en compte lors de la relance. :rose:
 

chafpa

Membre d’élite
Club MacG
12 Décembre 2009
2 586
141
Aux pieds des Vosges côté Alsace
Suite (Provisoire ?)

Le second lancement du clonage s'est déroulé normalement jusque sa fin.

A revoir dans 15 jours lorsque je recommencerai. ;)

PS: Près de 5 heures pour 400 Go en USB 2 c'est près du double que le Firewire 800 (2h45).
 

chafpa

Membre d’élite
Club MacG
12 Décembre 2009
2 586
141
Aux pieds des Vosges côté Alsace
Un mois et demi plus tard, je suis toujours dans la même panade.

Cette fois, CCC a refusé de faire une mise à jour de mon clone.Il n'a jamais voulu démarré la mise à jour des fichiers après avoir contrôlé les phases préliminaires normalement.

Rien ne s'est affiché sur la console et j'ai arrêté l'opération après 45 minutes. Obligé d'effacer le HDD externe et de refaire un clone complet, opération qui s'est parfaitement déroulée.

Je ne sais plus à quel saint me vouer car si le HDD était en cause, pourquoi fonctionnerait-il normalement lors d'un clone complet ? :rose: