Comportement erratique des liens dans Mail

calain

Membre confirmé
16 Mars 2007
34
1
Morbihan
Peur être quelqu’un pourra t il me renseigner sur un point qui me parait bien mystérieux dans la rédaction de messages avec Mail.
Depuis longtemps, lorsque je rédige un message avec Mail, il m’arrive de joindre des liens dans le texte par copier coller des url de safari.
Ce lien apparait alors dans mon texte en cours de rédaction souligné et en bleu, ce qui caractérise habituellement un lien, mais ceci n’est pas toujours le cas et le texte du lien reste affiché comme du texte normal !
Ces changements de comportement peuvent durer pendant des périodes plus ou moins longues (plusieurs jours ou semaines) sans que je n’arrive à comprendre la logique de ces changements et les redémarrages semblent ne rien changer ou rétablir !
J’ai beau chercher dans les préférences de Mail, je ne vois aucune option concernant cette gestion d'affichage des liens, de même mes recherches google ne pointent pas ce problème… cela semble ne se produire que sur mes mails … serais je le seul :-?
Actuellement sur Big Sur, mais cela était également vrai avec Catalina , Mojave, High Sierra ...
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
52 617
10 041
Nancy___
Bonjour,

Les liens peuvent être en tant que lien ou de texte.
Il arrive que lorsque tu fais un retour chariot à la fin du lien, celui-ci s'active en tant que lien (donc devient bleu).
Autrement il reste toujours le cmd K pour entrer le texte en tant que lien, ou bien supprimer le lien.
 

calain

Membre confirmé
16 Mars 2007
34
1
Morbihan
Merci pour ta réponse.
Mais le problème est là, à chaque fois que je fais un copié collé de l'URL de safari, je le fais sur une nouvelle ligne de texte que je termine toujours avec un retour chariot pour que ce lien soit bien séparé sur une ligne à part. Mais cela n'active pas toujours la ligne comme lien comme je l'explique dans mon message. Cela semble dépendre d'un contexte que je ne comprends pas !
 

calain

Membre confirmé
16 Mars 2007
34
1
Morbihan
Pour clarifier mes messages, je joins une copie d'écran de la rédaction de mail avec copier/coller d'URL de safari sur des articles de journaux ! Cela fait il la même chose sur vos macs avec mail ? Comme vous pouvez le voir, chaque changement de ligne a fait l'objet d'un retour chariot et la ligne n'a pas été interprétée comme lien actif !
 

Fichiers joints

  • Capture d’écran 2020-12-14 à 19.43.29.png
    Capture d’écran 2020-12-14 à 19.43.29.png
    362,7 KB · Affichages: 93

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
39 107
5 812
Pour clarifier mes messages, je joins une copie d'écran de la rédaction de mail avec copier/coller d'URL de safari sur des articles de journaux ! Cela fait il la même chose sur vos macs avec mail ? Comme vous pouvez le voir, chaque changement de ligne a fait l'objet d'un retour chariot et la ligne n'a pas été interprétée comme lien actif !
Pour moi il n'y a aucun comportement erratique, tant que tu rédiges un email les liens ne pourront pas être actifs ! Pour exemple, rédaction bidon depuis mon compte FAI...

Capture-003.jpg

...je ne quite pas, mais je sélectionne Brouillon...

Capture-004.jpg

...comme par magie les liens sont cliquables, je fais un clic sur Modifier...

Capture-005.jpg

...et je peux continuer la rédaction de mon email. C'est la même chose avec Mail.
 
M

Membre supprimé 1129907

Invité
Pourtant quand je crée un nouveau mail, les url sont bien considérés comme des liens (même si c'est impossible de cliquer dessus)
Capture d’écran 2020-12-14 à 20.34.15.png
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
39 107
5 812
Pourtant quand je crée un nouveau mail, les url sont bien considérés comme des liens (même si c'est impossible de cliquer dessus)
Sous macOS Big Sur et Mail, c'est la même chose pour moi...

Capture-007.jpg

...s'il y a une explication, c'est peut-être simple, mais je ne vois pas où ?
 
M

Membre supprimé 1129907

Invité
Dans les substitutions (menu édition) : liens intelligents à cocher ?
S'il est décoché, je n'ai pas de lien
Capture d’écran 2020-12-14 à 20.52.01.png
 
  • J’aime
Réactions: Sly54

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
39 107
5 812
Dans les substitutions (menu édition) : liens intelligents à cocher ?
S'il est décoché, je n'ai pas de lien
Non, j'ai la même chose...

Capture-008.jpg

...mais je suis sûr que c'est tout bête, j'y arrive bien, mais il faut que je fasse...

Capture-011.jpg Capture-012.jpg

...là je n'ai plus le temps, mais je suis sûr que c'est dans les Préférences (ou pas).
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
52 617
10 041
Nancy___
A chaque lien entré, dès que je valide (retour chariot), le lien se transforme en hyper lien. La substitution "Liens intelligents" est cochée chez moi.
 

calain

Membre confirmé
16 Mars 2007
34
1
Morbihan
Merci d'avoir éclairci ce mystère ! Effectivement, après avoir coché "Edition/Substitution/Liens intelligents" les liens deviennent bleus et soulignés !
Par contre, je ne m'explique pas pourquoi cela change parfois sans que je fasse quoi que ce soit consciemment !
Je vais surveiller !
Encore bravo pour votre réactivité et votre sagacité !
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
39 107
5 812
Je savais bien que c'était une connerie, tellement visible que l'on oublie complètement le B.A.BA. ;)