Configurer une Time Capsule en routeur derrière un modem OVH

APPLEmac34

Membre confirmé
30 Octobre 2009
58
0
Montpellier
Bonjour à tous,

Je configure actuellement une time capsule en mode routeur domestique, branché en ethernet derrière un modem Thompson, obtenu chez mon FAI OVH. Je ne suis pas compétent en réseau, c'est pourquoi j'en appelle à un peu d'aide de la part de la communauté Mac.

J'ai suivi les conseils de quelque sujet ici et sur Internet, mais je n'arrive toujours pas à partager la connexion Internet avec cette installation. Je ne sais pas quel paramètre n'est pas bien configuré. Voici le détail et l'erreur retournée:

- Modem Thompson en mode bridge (adresse obligatoire 192.168.1.254).
- Time Capsule: Internet en mode ethernet avec l'adresse IP de la box comme paramètre
- Time Capsule: DHCP et NAT activé.

La Time Capsule me donne une erreur double nat, et donc pas d'accès à l'extérieur.

Pouvez-vous m’aiguiller un peu svp ?
Merci par avance pour votre aide et vos conseils.
 

Polo35230

Membre expert
Club MacG
4 Janvier 2011
1 687
100
Bonjour,

Bon, je suis un peu dans l'expectative....:siffle:

Si le modem Thomson OVH est en mode bridge (le vrai, où on utilise uniquement la fonction modem), il n'a plus d'interface IP configurée. Il n'aura qu'une adresse IP d'administration.
Donc la TC est configurée:
-Côté Wan en PPPoE (avec le couple logon/mot de passe)
-Côté Lan en 192.168.1.1 (par exemple), Serveur DHCP 192/168.1.10 à .50 (par exemple), NAT validée et UpNP validé (si la TC le fait).
Dans cette configuration, il n'y aura pas de double NAT, mais une simple Nat; C'est la TC qui s'en chargera en faisant le nattage des adresses privées (celles en 192.168.1.xxx) en adresses publiques d'OVH.

Maintenant, si le modem thomson n'est pas en mode bridge, effectivement, il aura une adresse IP d'interface Lan en 192.168.1.254/24, il poura être serveur DHCP sur le réseau 192.168.1.0/24.
La TC sera configurée:
-Côté Wan en DHCP auto. Donc, c'est le serveur DHCP d'OVH qui lui affectera une adresse IP dans le plan 192.168.1.0/8
-Côté Lan, la TC sera configurée dans un autre plan IP (par exemple en 192.168.2.1/24). Elle sera serveur DHCP 192.168.2.10 à .50 (par exemple), NAT validée et UpNP validé (si la TC le fait).

Dans cette configuration, il y aura du double NAT:
La TC fera le premier (nattage des adresses en 192.168.2.xxx en 192.168.1.yyy)
Le modem OVH le deuxième (192.168.1.yyy en adresses publiques OVH.
Mais, ce n'est pas une erreur, c'est le fonctionnement normal du réseau.

Donc, tu as le choix entre les deux confs.
Tout dépendra des services que tu utilises. Si tu utilises les services de téléphonie ou de TV de ton opérateur, je pense qu'il vaut mieux utiliser la deuxième solution.

Perso, je ne passerais pas le modem OVH en mode bridge.
Je désactiverais seulement le wifi du modem OVH. Un seul point d'accès wifi, celui de la TC.
Le seul pb que tu pourrais rencontrer dans la deuxième conf (et là, ça dépend des box), c'est qu'il faille mettre l'adresse IP de la TC (celle en 192.168.1.xxx) en DMZ.

Chais pas si j'ai été clair, et si ça peut t'aider, tout ce baratin...;)
 

APPLEmac34

Membre confirmé
30 Octobre 2009
58
0
Montpellier
Merci pour tous ces détails.
Je vais expérimenter l'une de ses solutions.

La raison derrière tout çà, c'est que le modem/routeur OVH ne permet même pas d'assigner des IP fixe :( J'ai un NAS Synology dont j'aimerais fixé l'IP et ouvrir quelques ports, afin d'y avoir accès à l'externe. D'où le besoin d'un vrai routeur compétent. Je désactive donc le routeur OVH, laissant juste la fonction modem.

Ce que je ne comprend pas c'est que quand j'active la fonction bridge sur ce modem, l'adresse d'accès reste 192.168.1.254 pour y accéder (bridge ou pas finalement).
 

Polo35230

Membre expert
Club MacG
4 Janvier 2011
1 687
100
La raison derrière tout çà, c'est que le modem/routeur OVH ne permet même pas d'assigner des IP fixe :( J'ai un NAS Synology dont j'aimerais fixé l'IP et ouvrir quelques ports, afin d'y avoir accès à l'externe. D'où le besoin d'un vrai routeur compétent. Je désactive donc le routeur OVH, laissant juste la fonction modem.

Tu veux dire affecter une adresse IP en fct de l'adresses mac?
Si elle ne fait pas ça, Il y a moyen de faire autrement.
Tu regardes la conf de ta Box (configurée en mode routeur). Supposons 192.168.1.254/24. Tu regardes sa conf Serveur DHCP (supposons par exemple qu'elle distribue des adresses IP entre 192.168.1.10 et 192.168.1.50.
Tu configures ton NAS en IP fixe, MAIS en dehors de la plage DHCP de la box. Par exemple en 192.168.1.115, masque 255.255.255.0 et passerelle 192.168.1.254

Ce que je ne comprend pas c'est que quand j'active la fonction bridge sur ce modem, l'adresse d'accès reste 192.168.1.254 pour y accéder (bridge ou pas finalement).
Normal, il faut bien une adresse IP d'administration. Par exemple pour te reconnecter sur celui-ci pour revenir en mode routeur.
 

APPLEmac34

Membre confirmé
30 Octobre 2009
58
0
Montpellier
J'ai opté pour les solution 1: modem en mode bridge + TC en routeur.

Donc la TC est configurée:
-Côté Wan en PPPoE (avec le couple logon/mot de passe)
-Côté Lan en 192.168.1.1 (par exemple), Serveur DHCP 192/168.1.10 à .50 (par exemple), NAT validée et UpNP validé (si la TC le fait).
Dans cette configuration, il n'y aura pas de double NAT, mais une simple Nat; C'est la TC qui s'en chargera en faisant le nattage des adresses privées (celles en 192.168.1.xxx) en adresses publiques d'OVH.

Malheureusement, cela n'a pas fonctionné. La Time Capsule est bien configurée, aucun message d'erreur et une diode verte, mais l'utilitaire Airport m'indique le réseau Internet en orange (non connecté). Je ne comprends pas mon erreur (car elle vient forcément de moi ^^).
 

Polo35230

Membre expert
Club MacG
4 Janvier 2011
1 687
100
Dans une fenêtre Terminal, il faudrait faire:
ping 192.168.1.1 (ça devrait marcher)
ping 8.8.8.8 pour voir si tu sors (sans DNS) sur internet.
ping google.fr (pour voir si la résolution DNS marche)

Si le ping 8.8.8.8 et ping google.fr ne marchent pas (ça devrait être ton cas), il faudra regarder la configuration WAN de la TC.
En premier, la TC (côté WAN) essaye de se connecter à un équipement de ton opérateur (en PPPoE en principe, si tu es en ADSL) et envoie un logon/password.
Tu es sûr que la TC est bien configurée à ce niveau?
Ensuite, si c'est bon, l'équipement OVH sur lequel tu t'es connecté doit envoyer une adresse IP publique OVH, un masque, une gateway, et (la plupart du temps) les adresses de ses DNS.
Regarde la conf côté wan ce qu'il y a dedans.
 

APPLEmac34

Membre confirmé
30 Octobre 2009
58
0
Montpellier
C'est un échec. A un tel point que mon modem a du être reconfiguré par OVH :) Impossible de comprendre pourquoi l'accès Internet ne fonctionne pas. Je ne reçois pas d'IP d'OVH quand je paramètre la TC.
J'ai eu confirmation que l'on ne peut pas assigner d'IP fixe avec le modem via l'interface, mais que c'est possible en ligne de commande. Donc direction le terminal, et je laisserais la TC tranquille comme çà.

Merci pour ton aide.