• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

Connection internet X.1

aurel99

Membre confirmé
18 Avril 2001
346
0
Nancy, France
www.NoteTonStage.fr
depuis que j'ai macos X.1 je dois une super manip' pour pouvoir retirer mes mails et surfer sur internet via l'ADSL:
sous le Terminal (et connection etablie), taper: sudo ifconfig ppp0 mtu 1488

eh oui! vive la simplicite mac!


Je ne suis pas le seul dans ce cas, je remercie Jean MONEYRON et le forum www.macadsl.com pour leur aide.

Cependant, si je termine ma session, si je me deconnecte... je perds le benefice de ma formule magique tapee precedemment sous le Terminal.

Quelqu'un pourrait-il me donner une solution afin que la "formule magique" ait des effets permanents?

Merci bcp!
)
 

ibanezmac

Membre confirmé
30 Septembre 2001
367
8
55
DIJON
Je fais la meme manip mais avec 1492 (Christophe Colomb roulaize)...
La question est : quel est ton provider ?
Je suis chez NERIM et je suis obligé de faire la manip, autrement la connexion est figée..et tu remarqueras que le chronometre de Internet Connect ne tourne pas..
 

speedy_jo

Membre junior
16 Mai 2001
69
0
Visiter le site
voila la reponse a ta question

EN FIN on est jamais mieux servis que par soit meme
la sulution est trouvee sur la site MAXFIXLT-US !!!!
est la suivant:
en premier---> intstaller X.1 sur X.04
en 2°----->>> la systeme garde tout vos configuration depuis X.04 , mais la "limiteur" MTU est mal configurer par defaut , donc il le faut corriger a la main
en 3° ------>gardez votre calme et dans 2min vous allez etre heureux.
4°------->>> actevez le comtpte "root" : comme suite::: finder>applications>Utilities>NETINFO MANAGER>>>Domaine>>>Securite>>>Authentifier>>>
votre mot de passe administrateur >>>> Domaine>> >>securite>>>activer l'utilisateur root>>> entrez le mot de passe pour le compte root qui vous plaise!!!!
5°----->>>fermez la session
6°----->>>connectez vous comme user "root"
7°----->>>Finder>>>Applications>>>Terminal>>>entrez tout simplement ce ci--->>>sudo ifconfig ppp0 mtu 1488>>>ENTER<<<>>>exit>>>ENTER<<<>>>
8°----->>>Quitter Terminal
9°----->>>fermez la session
10°---->>>connectez vous comme d'hab
11°---->>>lancez votre navigateur
12°---->>>et admirez la vitesse retrouvee....!
Mais attention vous devez repeter les operations entre
4° ET 9° si vous etegnez votre machine....
vous pouvez suprimer les emmerdes entre 4° ET 9° si vous ecrivez un script Shell comme d'ecrit dans l'univers
Macworld Hors-serie (special MACos X) page 66...
et voila...
ouvous pouvez suprimer les emmerdes entre 4° ET 9° si vous ecrivez un script Shell comme d'ecrit dans l'univers
Macworld Hors-serie (special MACos X) page 66...
 

rchytil

Membre junior
20 Avril 2001
54
0
Visiter le site
Bon, le plus simple, à mon avis, c'est de créer le script de la façon suivante:
- dans un terminal, taper "vi mtu.cammand" (sans guillemets). Ca ouvre l'éditeur vi, et le fichier sauvegardé s'appellera mtu.command.
- taper "a" (pour Ajouter)
- entrer les lignes suivantes:
#!/bin/sh
ifconfig ppp0
sudo -u root ifconfig ppp0 mtu 1492
ifconfig ppp0
- puis taper la touche "esc".
- taper ":wq" (sans guillemets, toujours) .Ca sauve le fichier et ca quitte vi.
- toujours dans le terminal, taper:
chmod a+x mtu.command

Et voilà. Il suffit de cliquer sur le fichier pour qu'un terminal s'ouvre et lance la commande. Le "ifconfig ppp0" avant et après la commande lancée avec sudo retourne la valeur actuelle de mtu pour l'interface ppp0.

....mais j'aimerais comprendre quel changement à faire pour avoir cette valeur correcte par défaut. Personne n'a été capable de me répondre pour l'instant. Un paramètre (p.ex dans /etc/ppp/options) ou même un valeur à changer dans le kernel?

Sinon, je pense que les utilisateur france telecom n'ont pas ce problème, car le modem ou routeur ou leur équipment de l'autre côté ajuste la valeur correctement. Ce n'est pas le cas chez d'autres fournisseurs (comme Nerim, ou Bluewin en Suisse)

Robin
 

aurel99

Membre confirmé
18 Avril 2001
346
0
Nancy, France
www.NoteTonStage.fr
chapeau!

je vais peut-etre ecrire a Nerim plutot pour leur demander a ce que leurs serveurs fassent ca automatiquement. ce serait peut-etre plus simple.

OK. Mais bon, je ne suis pas super doue en informatique, quelqu'un pourrait-il donner les elements techniqes pour que le mec chez Nerim sache quoi faire en lisant le mail?
 

rchytil

Membre junior
20 Avril 2001
54
0
Visiter le site
Quel Startupitem?

En fait, créer un startupitem ne résout rien: chaquefois que la connection PPPoE est établie, il fau ajuster le MTU.

Non, le truc que j'ai trouvé, c'est de créer une entrée crontab pour root qui va remettre le MTU à une valeur inférieure ... toutes les minutes (ou plus si vous voulez).
C'est pas très joli, mais ca marche.

Ca vous intéresse?

Robin