10.11 El Capitan Copier uniquement les répertoires et fichiers inexistants

Deepsie

Nouveau membre
18 Septembre 2020
2
0
54
Bonjour Les Macgiciens,

Je voudrais copier un répertoire (environ 175 000 fichiers et 3 000 répertoires), en ajoutant dans le répertoire de destination uniquement les fichiers et répertoires inexistants, sans remplacer les fichiers ou répertoires si ils existent déjà sur le répertoire de destination.
Exemple :
REP A : répertoire à ajouter, REP D : répertoire de destination
REP A = Rep 1 (F11, F12, F13), Rep 2 (F21, F22), Rep 3 (F31, F32)
RED D = Rep 1 (F11, F13, F14), Rep 3 (F33, F34)
Seul les répertoires et fichiers en gras ont été copiés.

Après la copie on a REP D = Rep 1 (F11, F12, F13, F14), Rep 2 (F21, F22), Rep 3 (F31, F32,F33, F34)
Sachant que sur REP D, les répertoires et les fichiers existants Rep 1 (F11, F13), Rep 3 non pas été remplacés par ceux de REP A

Je ne vois donc pas comment faire cela, puisque Finder propose ou de remplacer, ou de copier en double et d'arrêter la copie.

Merci de votre aide
 

ecatomb

Vétéran
Club MacG
21 Septembre 2016
5 097
2 137
Il me semblait qu’il était possible d’ignorer les fichier déjà présents. Je n’ai pas mon mac sous la main, donc je ne peux pas te donner de solution pour le moment. Désolé
 

ecatomb

Vétéran
Club MacG
21 Septembre 2016
5 097
2 137
Dans ce cas, peut-être le faire en ligne de commande ?
 
  • J’aime
Réactions: Deepsie

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
75 563
23 040
Forêt de Fontainebleau
Bonsoir

Il suffit d'employer la commande rsync avec l'option -u (udapte) qui n'ajoute que les éléments différents de la source sur la destination (sans remplacement des identiques de la destination ni suppression des différents de la destination). Une commande du type :
Bloc de code:
sudo rsync -avu [PATH]REP\ A/* [PATH]REP\ B

  • devrait effectuer la mise-à-jour souhaitée.
 
  • J’aime
Réactions: Deepsie et ecatomb

ecatomb

Vétéran
Club MacG
21 Septembre 2016
5 097
2 137
C'est ce à quoi je pensais, mais dans mon idée, il me manquait les options à utiliser et le sudo. :merci:
 
  • J’aime
Réactions: Deepsie