Coupe-feu de OSX 10.6.3 Serveur: iTunes sur Airport Express

Karamazow

Membre émérite
29 Février 2008
578
56
Vienne (Isère)
Bonjour,

J'ai OSX 10.6 Serveur avec la nouvelle MàJ fraîchement installée, et je suis confronté à un problème avec iTunes que voici:

J'utilise une borne airport express branchée en RJ-45 sur mon réseau local.

Je n'ai qu'un seul compte sur mon OSX Serveur, avec lequel j'envoie de la musique via iTunes sur ma borne Airpot Express.

Lorsque le coupe-feu (firewall) de OSX est désactivé je n'ai aucun problème pour envoyer la musique sur iTunes. Dès que j'active le coupe-feu, le son arrête de se transmettre sur la borne airport express.

Si j'avais activé le coupe feu avant de lancer iTunes, je ne trouve tout simplement pas les haut parleurs distants connectés à la borne airport...

Lorsque je fais lance le moniteur d'activité d'OSX pour observer le comportement de l'application iTunes, je constate le fait suivant avec l'inspecteur sur iTunes :

serveurmacmini.local:49409->airport-express-salon.local:commplex-main
serveurmacmini.local:53061->airport-express-salon.local:6000

Les ports utilisés par le serveur OSX seront différents lorsque je quitterai iTunes et le relancerai.

Dans NETSTAT de Utilitaire réseau, je m'aperçois de la chose suivante :

tcp6 0 0 serveurmacmini.l.49409 airport-express-.commp ESTABLISHED
udp6 0 0 serveurmacmini.l.53061 airport-express-.6000

Donc visiblement, sur cette connexion le port 53061 servirait à lancer l'utilitaire d'administration, et le port 49409 à streamer vers la borne airport le flux pour la musique ?

Qu'en pensez-vous ? Est ce qu'il y aurait une manipulation à faire pour me permettre d'initialiser le coupe-feu de OSX Serveur et conserver la possibilité de jouer de la musique depuis iTunes vers la borne airport ?

Merci d'avance pour vos avis !
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 944
3 181
Lorsqu'on émet, le port d'émission est moins important que le port de destination.
Si ça ne marche pas c'est sans doute que le pare-feu bloque la sortie vers le port 6000.

Une fois le pare-feu activé, tu devrais pouvoir ajouter ce paramétrage : autoriser iTunes et/ou la sortie sur le port 6000. Regarde l'aide.
 

Karamazow

Membre émérite
29 Février 2008
578
56
Vienne (Isère)
Salut Bompi,

Merci pour ta réponse.

Dans les paramètres du Firewall, le port 6000 était bien ouvert (de mémoire) en TCP. Par contre, je ne me souviens pas qu'il y ait la mention Sortant / Entrant....

Quoi qu'il en soit, j'ai débusqué ceci sur le forum de la section "Assistance" du site d'APPLE :

http://discussions.apple.com/thread.jspa?threadID=2184595

Apparemement, le problème viendrait de l'option IPv6 activée dans OSX....

Ce soir quand je rentre à la maison je désactiverai l'IPv6 pour voir.

Bonne journée !
 

Karamazow

Membre émérite
29 Février 2008
578
56
Vienne (Isère)
Bonjour, La désactivation de l'IPv6 sur OSX SERVEUR me permet à nouveau d'utiliser ma borne AirPort Express avec iTunes, tout en ayant le coupe-feu de OSX d'activé. En tout cas, le bug de l'IPv6 est vraiment bizarre...