Créer un favicon

Cyberju

Membre confirmé
5 Août 2003
104
4
46
Nanjing, Chine
fr.groups.yahoo.com
Bonjour à tous,

J'essaye de créer un favicon pour mon site mais sans succès. J'ai bien suivi les indications de allhtml.com en utilisant GraphicConverter :
a) Créer une image de votre choix en l'enregistrant au format ico (format icône de Windows) tout en respectant ces indications :
b) Vous devez appeler l'image favicon.
c) Dimensions de l'image : 16 pixels x 16 pixels.
d) Palette de 16 couleurs (4 bits).
e) Transférez cette image sur le répertoire racine de votre site.

et pourtant ça ne marche pas malgré un transfert binaire sur mon site ftp.

Quelqu'un a une idée pourquoi ?

Voici l'adresse de mon site : http://www.acse.asso.fr/
Mon favicon est là : http://www.acse.asso.fr/favicon.ico

Merci de m'aider !

Julien
 
  • J’aime
Réactions: Adrienhb

Spyro

Vétéran
Club MacG
19 Juillet 2001
5 428
867
40
PNG-sur-Yvette
Ce qui marche pas c'est la visualisation dans ton navigateur à mon avis.
En effet ceux-ci gardent les favicons en cache et ne les re-téléchargent pour ainsi dire jamais. Enfin c'est ptet plus subtile que ça, mais je n'en sais pas beaucoup plus.

Y a moyen de récupérer l'icone en vidant le cache (dans le menu Safari), et si ça marche pas il faut supprimer le cache des favicons ou juste l'enregistrement correspondant à celle de ton site, Avec Safari Icon Manager par exemple.
 

Cyberju

Membre confirmé
5 Août 2003
104
4
46
Nanjing, Chine
fr.groups.yahoo.com
Grape a dit:
Peut-être tu as déjà trouvé la solution car ton favicon marche parfaitement.
Ah bon ? vous le voyez vous mon favicon ? Ca s'est bizarre. Ca doit donc être un problème de cache.

Merci à tous les deux pour vos réponses.

Julien
 

sefie

Membre confirmé
24 Février 2003
155
0
Cyberju a dit:
Bonjour à tous,

J'essaye de créer un favicon pour mon site mais sans succès. J'ai bien suivi les indications de allhtml.com en utilisant GraphicConverter :
a) Créer une image de votre choix en l'enregistrant au format ico (format icône de Windows) tout en respectant ces indications :
b) Vous devez appeler l'image favicon.
c) Dimensions de l'image : 16 pixels x 16 pixels.
d) Palette de 16 couleurs (4 bits).
e) Transférez cette image sur le répertoire racine de votre site.

et pourtant ça ne marche pas malgré un transfert binaire sur mon site ftp.

Quelqu'un a une idée pourquoi ?

Voici l'adresse de mon site : http://www.acse.asso.fr/
Mon favicon est là : http://www.acse.asso.fr/favicon.ico

Merci de m'aider !

Julien
Je le vois aussi sous safari, mais sous IE, il me semble qu'il faut mettre ton site en favori et là ton favicon apparaitra...
 

hrsg

Membre confirmé
29 Mai 2002
260
2
38
Rennes & Paris
J'ai mis des favicons sur mes sites :
http://www.sangan.net/
http://www.club.fft.fr/tc.broons/

Ça ne marche pas, pourtant j'ai vidé la cache avec Safari Icon Manager.
Ce qui est bizarre, c'est que ça marche avec :
http://tcbroons.free.fr/
Alors que j'ai procédé de la même façon et qu'il s'agit du même favicon (du moins pour le deuxème site)

Mes favicons marche-t-il chez vous ?
Qu'est-ce que ça fait de vider la cache de safari (c'est bien bibliothèque/cache/safari) ?

La racine est bien l'endroit où l'on met les pages html ?

Merci d'avance,
Harold
 

la tortue

Membre confirmé
6 Novembre 2003
397
1
<blockquote><font class="small"> hrsg:</font><hr /> Qu'est-ce que ça fait de vider la cache de safari (c'est bien bibliothèque/cache/safari) ?

[/QUOTE]
Vider le cache, supprime les images cachées mais pas les favicons.
Pour cela il faut supprimer le dossier ~/Library/Safari/Icons où se trouve le cache pour les favicons...


<blockquote><font class="small"> hrsg:</font><hr />La racine est bien l'endroit où l'on met les pages html ?

[/QUOTE]
Seulement si tu met tes pages à la racine du site...

Tu peux également mettre un favicon différent sur chaque page:
<font class="small">Code:</font><hr /><pre>&lt;LINK REL="icon" HREF="/favicon.ico" TYPE="image/x-icon"&gt;
&lt;LINK REL="shortcut icon" HREF="/favicon.ico" TYPE="image/x-icon"&gt;</pre><hr />
As-tu ajouté du code comme ci-dessus, ou bien as-tu simplement mis le favicon à la racine '/' de ton site?
 

hrsg

Membre confirmé
29 Mai 2002
260
2
38
Rennes & Paris
Hello,

Merci beaucoup...
J'aimerais juste une précision, ce code :
&lt;LINK REL="icon" HREF="/favicon.ico" TYPE="image/x-icon"&gt;
&lt;LINK REL="shortcut icon" HREF="/favicon.ico" TYPE="image/x-icon"&gt;
Il faut le mettre où exactement ? (entre les head ? Et par rapport aux meta ?)
Faut-il le remettre à chaque page du coup, ou sur la première et après il le garde?
On met le favicon à côté des pages quand on utilise le code? (même si pages pas dans la racine?) Car pour le site hébergé par la fft je n'ai pas l'autorisation pour mettre qqch dans la racine...

@+
Harold
 

-anonyme-

Légende
26 Février 2001
66 286
2 670
hrsg a dit:
Il faut le mettre où exactement ? (entre les head ? Et par rapport aux meta ?)
Après les meta, juste avant &lt;/head&gt;

hrsg a dit:
Faut-il le remettre à chaque page du coup, ou sur la première et après il le garde?
sur chaque page que tu souhaites faviconiser :d

hrsg a dit:
On met le favicon à côté des pages quand on utilise le code? (même si pages pas dans la racine?) Car pour le site hébergé par la fft je n'ai pas l'autorisation pour mettre qqch dans la racine...
personnellement je met mes pages et le favicon a la racine de mon FTP.
La racine correspond a "/" sur Free et "Pub" sur Wanadoo.