DD Caviar de 250 Go en péril permissions en cause? Ne peut être copié (origine ICE)

MacpasMoc

Membre junior
28 Juillet 2004
12
0
Je pense n'avoir jamais été à ce point dans la panade informatique et je lance un SOS.

J'ai un G4 Sawtooth AGP d'origine à 450 MHz et maman Apple ne reconnaîtrait pas son rejeton tellement je l'ai amélioré: 1,25 Go de ram, Pionner 106, une carte graphique ATI 8500 flashée, une carte Gigadesign d'origine 1,25 poussée à 1,40, une carte SCSI Adaptec 2930 avec deux scanners en externe, deux disques sur le port ATA et une carte Acard ATA-133 AEC 6280M à deux ports avec donc possibilité de deux gros disques internes sur chaque nappe soit quatre (cela ne faisait que quelques jours que j'avais installé la deuxième nappe), le tout en plus des deux disques ATA sur le port ATA d'origine du G4 qui ne peut reconnaître sur ce bus que 128 Go.

J'ai acheté chez MacWay un boîtier externe Firewire ICE avec un Caviar 250 Go (WD 2500 avec 8mo de cache) à l'intérieur sur lequel je faisais mes sauvegardes de celui des gros disques internes sur la carte Acard qui hébergeait mon énorme dossier iTunes (60Go, j'ai revendu toute ma collection de CD d'origine par idiotie numérique), tous mes installateurs d'applis et de jeux et surtout une bonne partie de mes photos (plus de 50 Gigas rien que pour ces dernières). J'utilisais SuperDuper pour faire mes sauvegardes, parfois Tri-Backup et plus rarement SynchronizePro.

Problème : Un beau jour, ce disque FireWire dont il ne restait que 25 Giga de libre s'est mis à partir en quenouille: Il ne montait plus ou difficilement. Problème vérifié aussi sur mon PowerBook G4. Je suis sur Panther, toujours avec la dernière version du système (actuellement 10.3.9). J'ai d'abord cru que c'était le bridge Oxford qui était en cause et j'ai décidé de retirer le Caviar et de l'installer sur la deuxième nappe de la carte Acard interne du Sawtooth.

Peut-être ai-je été victime du fameux bug des ponts Oxford qui faisait disparaître les disques sous Panther. Je crois pourtant me souvenir que leur intégrité n'était pas en cause, une fois mis sur un bus ATA.

Deuxième problème, le pire : L'incident sur le FireWire est arrivé après avoir fait ma sauvegarde habituelle mais entre-temps, j'avais décidé d'effacer la partition du disque interne d'origine car elle plantait parfois pendant que je rippais de la musique dans iTunes. (Au redémarrage, en single user, mon "/sbin/fsck -y -f" me donnait souvent des "invalid orphaned nodes" dans la vérification des "multi-linked files" qui étaient ensuite réparés.) Cet ennui sur le disque interne (un Maxtor Maxline Plus II 250 Go avec 8 Mo de cache) était irrégulier mais pas très méchant, car après un plantage je pouvais très bien ripper dix CD sans aucun problème. De plus, DiskWarrior en qui j'ai toute confiance le trouvait inmanquablement sain après une réparation Apple en boot single user.

Je me trouve donc À POIL en terme de sauvegarde, car la seule dont je dispose est sur un disque malade (le Caviar) extrait de son boîtier FireWire.

Je l'ai d'abord mis seul (cavalier en position single) sur la deuxième nappe de la carte ACARD, nappe que j'ai étrenné pour l'occasion. Problème : Toutes les tentatives de restitution des données depuis sa partition de sauvegarde vers mon autre gros disque interne échouent car elles s'éternisent. J'ai essayé avec SuperDuper qui a mis deux jours avant que je ne l'arrête, Tri-Backup pareil. Je n'ai pas voulu lancer Carbon Copy Cloner car il n'y a que des données sur la partition qui m'obsède car elle a tout mon patrimoine informatique et donc pas de système bootable. Quand je tente une copie depuis le Finder, les premiers mégas sont ultra rapides à copier, puis la copie se bloque presque ou avance à la vitesse d'un escargot arthritique. J'ai essayé de copier depuis une partition en OS 9.2.2 pensant passer outre les éventuels problèmes de permissions, rien à faire : C'est toujours désespérément lent et cela risque de mettre plusieurs mois si on laisse les utilitaires de sauvegarde tenter de faire leur boulot.

Tous les utilitaires disque dont je dispose (Utilitaire de Disque, DiskWarrior 3.02, Drive Genius 1.1, Techtool 4.03) annoncent pourtant comme sains à la fois le Caviar 250 Go (ex FireWire) et le disque Maxtor interne également de 250 Go qui avait à l'origine mes données et qui tourne comme une horloge depuis la réinitialisation de sa partition de stockage. Les partitions et les répertoires sont donc sains. Techtool ne voit en plus aucun problème sur aucun des contrôleurs disques.

Troisième problème gravissime mais heureusement transitoire : Quand j'ai voulu cette nuit re vérifier la position des cavaliers maître esclave sur tous mes disques internes (c'était OK), le G4 a eu une panne d'alimentation au démarrage: Silence absolu quand j'appuyais sur le bouton, alim en rade. Visiblement je la surchargeais trop: Après un moment de panique, j'ai réinitialisé la PMU, enlevé la pile interne pendant un moment. Le G4 est reparti mais s'est éteint brusquement de nouveau, puis relancé de lui-même: J'ai décidé de le laisser reposer et de n'utiliser qu'une nappe de l'ACARD avec le Caviar 250 Go en esclave et le Maxtor 250 Go en maître, en plus des deux petits disques qui restent sur le bus ATA. Je n'ai plus donc que 4 diques à alimenter au lieu de six. Depuis plus de problème d'alim ni de bruit bizarre, peut-être qu'un câble était en court jus dans l'espace confiné de la tour.

Je suis preneur de conseils pour remplacer mon alim interne d'origine "Delta Electronics DPS-200 PB, Apple part n° 614-0091" qui apparemment ne peut dépasser les 125 W de consommation en +5v et +3,3v avec un maxi de 32Ampères. Je crois qu'il faudrait aussi que je change le ventilo interne qui est assez bruyant, mais je ne suis pas du tout un as du fer à souder et je suis donc preneur de coordonnées d'organisme ou de bidouilleur qui l'ont déjà fait sur la région parisienne.

Je n'ai donc plus de solution pour récupérer mes données: Peut-être pourtant qu'un conseil sur les permissions pourrait débloquer ma situation : Sur le disque source (le Caviar malade ex FireWire) et sur le Maxtor cible, le Finder annonce dans l'onglet permission : "Possesseur et autorisation : vous en lecture écriture" et dans "détails": "Possesseur: jeanmarc" en lecture écriture (mon nom d'utilisateur qui est aussi administrateur), "Groupe : staff" en lecture écriture et "Autres: lecture seulement". J'ai essayé de cocher la case "ignorer les autorisations de ce volume" mais cela a amené comme groupe "unknown" avec lecture seulement. J'ai même en désespoir de cause coché une fois l'onglet "appliquer aux éléments inclus" ce qui a amené une roue multicolore pendant un très, très long moment.

Je viens d'essayer de passer les deux disques en groupe "Admin" au lieu de "staff", mais cela n'a pas l'air beaucoup plus véloce.

Pour vérifier la théorie de la tartine beurrée, j'ai en plus un gros souci d'OS sur les partitions système qui me restent et que j'ai trop vite clonées l'une sur l'autre, ce qui n'a fait que dupliquer le problème: En voulant utiliser l'utilitaire 'Doktor Kleanor 10.3 qui doit faire appel à des routines UNIX, je me suis aperçu que Terminal s'ouvrait mais que la fenêtre du shell s'affichait minuscule, en fait réduite au simple petit bouton rouge (celui qui permet de fermer une fenêtre en haut et à gauche). Pas moyen d'avoir accès aux deux autres boutons orange et vert et encore moins à ce qui doit être affiché dans la fenêtre fantôme. Même souci quand on lance Terminal à part. J'ai vérifié que j'avais bien la police Helvetica d'origine Apple mais rien n'y a fait.

Pour résumer je suis avec un disque malade car incopiable sur un système devenu pourri et dans un G4 à l'alim incertaine, mais à part cela c'est le Printemps... Merci mille fois pour des pistes pour me sortir de ma galère et désolé d'être à cheval sur des problèmes de hard (je prie que ça ne soit pas le cas!) et de soft (pourvu que ça ne soit qu'un problème UNIX!).
 

supermoquette

Cas clinique
Club MacG
13 Mai 2002
29 365
3 495
Ton G4 est trop chargé. J'ai eu les même symptômes une fois : solution, enlève tout le superflu (carte scsi, disques inutiles, remet la carte graphique d'origine, débranche le pioneer, ...) ainsi tu auras peut etre une chance de refaire un backup et voir si le problème vient de là.
 

MacpasMoc

Membre junior
28 Juillet 2004
12
0
supermoquette a dit:
Ton G4 est trop chargé. J'ai eu les même symptômes une fois : solution, enlève tout le superflu (carte scsi, disques inutiles, remet la carte graphique d'origine, débranche le pioneer, ...) ainsi tu auras peut etre une chance de refaire un backup et voir si le problème vient de là.

Je veux bien. Je n'ai plus que 4 disques dans la bête (2 sur Acard et 2 sur le bus ATA), j'ai laissé la carte Adaptec mais elle n'est connecté à rien, car j'ai une peur bleue de rouvrir mon Mac par peur du faux-con qui mettrait tout en panade. Ton remède serait alors pire que le mal actuel. Mon Sawtooth a très bien marché pendant des années en étant plus chargé et je ne suis pas certain que ta solution soit la bonne;

J'ai par contre un gros doute sur l'intégrité de la carte ACARD (qui serait peut-être devenue sous-alimentée ?) bien que je n'utilise qu'un seul de ses deux ports. Le problème est que je ne peux pas mettre aucun disque de 250 Go sur le bus ATA car ils ne seraient pas reconnus. Quelqu'un a-t-il déjà eu une carte ACARD hyper ralentie ?

Mais comment expliquer que le même disque Caviar mis dans deux boitiers ICE différents soit aussi lent? Je crains qu'il ne soit sur le point de rendre l'âme.

Je pense en plus avoir fait une grosse bêtise avec le coup des permissions accordés à tout le volume quand j'ai cliqué sur "appliquer aux éléments inclus" . Peut-être qu'un bon coup de Netinfo Manager cornaqué par quelqu'un qui s'y connaît en UNIX pourrait me redonner un peu de vitesse de copie.

En lançant Path Finder je vois par exemple que mon disque malade a pour autorisations:
drwxrwxr -x (775)

Je ne sais pas qui peut bien être cet utilisateur 775.

Je suis demandeur d'explications sur les éventuels bienfaits de la case à cocher "ignorer les autorisations de ce volume".

Je sais je me raccroche peut-être à des chimères.