débuter dans la création de site..

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
30
$PWD
p4bl0.net
Tyite Bulle a dit:
oui mais en fait je voudrais créer mon image sous photoshop là (pcq sans ça j'ai pas de page d'acceuil, donc pas de site) mais je sais pas en quel dimension je dois la faire, c'est tout :)
En fait j'avais pas compris que ce qui doit prendre toute la place mais pasplus sur la page d'accueil devait être une image...

Je ne sais pas si c'est possible, surtout que non seulement les gens n'ont pas tous la même résolution, mais en plus certaines personnes navigues dans une fenêtre plein écran, d'autre dans une plus petite etc... donc entre le gars qui à un 24" et qui navigue en plein écran et le gars qui à un 12" et qui navigue dans une fenêtre plus petite que son écran... :rateau:

Sinon, mais faut pas avoir peur de la pixelisation, il y a la solution
Bloc de code:
<img src="monimage.png" width="100%" height="100%" alt="mon image" />
:p
 

Tyite Bulle

Membre confirmé
23 Mars 2006
273
437
Bon ben je vais faire mon égoïste alors: je vais le faire au mieux pour mon beaux macbook :D
 

Tyite Bulle

Membre confirmé
23 Mars 2006
273
437
Ayé j'ai fais mon petit fond d'acceuil. Si vous voulez voir c'est ici http://vestibulle.free.fr (je suis pas trop fière en fait c'est un peu brouillon mais c'est surtout pour tester, j'arrangerais après).
Et maintenant, vu que j'aime pas les choses simples, je voudrais qu'en cliquant sur certaines parties de l'image ça ouvre une nouvelle page (qui en faite aura pas grand chose de différent). Donc j'imagine qu'il faut que je mettre la partie d'image en question "par dessus" et que je lui attribut le lien vers la nouvelle page.
Mais :D comment faire pour que la partie d'image (l'oeil par exemple) soit bien placé au pixel près ? Comment "mesurer" la marge que je devrais mettre ?
 
  • J’aime
Réactions: alèm

largowin

Membre junior
23 Janvier 2004
36
1
54
cheznoir.com
Mauvaise idée de mettre directement une image de cette taille comme fond. Tu devrais passer par une css, genre:

Bloc de code:
<html>
<head>
<style type="text/css">

#conteneur {
	width: 750px;
	height:600px;
	margin: 0 auto;
	background-image: url(images/index.jpg);
	background-repeat: no-repeat;
}

</style>
</head>

<body>
<div id="conteneur"></div>

</body>
</html>
Mis à part ce détail, si t'as l'intention de mettre les mains dans le cambouis pour créer ton site, tu devrais te donner au moins la peine de lire quelques tutoriels et t'acheter un livre sur le sujet plutôt que de demander toutes les solutions sur ce forum durant la conception de ton site. Il te faut faire un effort et acquérir certaines bases, histoire de comprendre ce que tu fais et d'évoluer dans ta démarche de création d'un site web.
 
  • J’aime
Réactions: p4bl0

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
30
$PWD
p4bl0.net
Ay&#233; j'ai fais mon petit fond d'acceuil. Si vous voulez voir c'est ici http://vestibulle.free.fr (je suis pas trop fi&#232;re en fait c'est un peu brouillon mais c'est surtout pour tester, j'arrangerais apr&#232;s).
Et maintenant, vu que j'aime pas les choses simples, je voudrais qu'en cliquant sur certaines parties de l'image &#231;a ouvre une nouvelle page (qui en faite aura pas grand chose de diff&#233;rent). Donc j'imagine qu'il faut que je mettre la partie d'image en question "par dessus" et que je lui attribut le lien vers la nouvelle page.
Mais :D comment faire pour que la partie d'image (l'oeil par exemple) soit bien plac&#233; au pixel pr&#232;s ? Comment "mesurer" la marge que je devrais mettre ?
personnellement c'est pile &#224; la bonne taille pour moi :p

Pour rendre un image cliquable il faut utiliser une map en html. J'avais fais un post la dessus, je le retrouve et je te met un lien ;)

EDIT : c'est l&#224;. Il faut que tu adapte &#224; ce que tu veux (enl&#232;ve le javascript et met un lien dans href.

Cherche un tuto ou un logiciel qui g&#233;n&#232;re automatiquement une forme "poly" (polygone) en fonction de la zone que tu lui demande (je sais pas si il y en a sous mac, mais je pense que oui)
 
A

Anonyme

Invité
Bon, je me suis amusé un peu en adaptant le tutoriel de alsacreation : essais. ;)

Le fichier zip à télécharger. Faut juste enlever les contours sur les liens pour finir le truc. ;)
 

Tyite Bulle

Membre confirmé
23 Mars 2006
273
437
:eek: ouaw merci beaucoup vous êtes vraiment supers !!

Ne t'inquiête pas Largowin je n'avais pas l'intention de demander toutes les solutions sinon autant donné mon site à quelqu'un d'autres :) Mais en fait hier j'avais envie de continuer, j'ai cherché mais bon il était 4h donc j'ai rien trouvé lol.

Merci en tout cas pour tout ça :)
 
A

Anonyme

Invité
J'en profites aussi pour dire merci, tiens. Je me pose à peu près les même questions que Tyte bulle :)
 
A

Anonyme

Invité
Le seul désavantage de la méthode c'est que si quelqu'un surfe avec les images désactivées, il aura une belle page blanche. Sinon ça marche partout, même sur un gsm (sans l'image de fond œuf corse). ;)
 

Tyite Bulle

Membre confirmé
23 Mars 2006
273
437
voil&#224; j'ai r&#233;ussi, j'ai utilis&#233; TacoHTML Edit (qui rend mon dock magnifique avec son petit taco lol), je suis pas trop s&#251;re de respecter les "conventions" mais le rendu est le bon :D
Bon par contre j'ai pas fais les autres pages encore donc &#231;a sert &#224; rien lol. a suivre ...

Merci :)
 

Tyite Bulle

Membre confirmé
23 Mars 2006
273
437
youpi j'ai fais une nouvelle page, mais en fait ya pas le texte et pas la galerie, donc ca sert encore à rien :D

Au fait merci Alèm pour ton coup de boule :rose: :love:
 

Tyite Bulle

Membre confirmé
23 Mars 2006
273
437
Les personnes à qui j'ai montré mon site voient un cadre bleu autour de mes pages, comme ça:



C'est moche, ça gache tout mon découpage mais surtout je vois pas d'où ça sort ! J'ai regarder partout et j'ai pas trouver d'où ça pouvait venir.. Est-ce que ça peut venir du navigateur (sous safari on le voit pas (sur mon mac du moins), sous IE et FF oui, j'ai personne pour tester les autres)
Je comprend pas là ...:(
 
A

Anonyme

Invité
J'ai eut le même genre de problème ....

Tu n'aurais pas mis un cadre par hasard ? Parce que ils sont bien pris en charge par safari mais pas par firefox ....
 
A

Anonyme

Invité
Les personnes &#224; qui j'ai montr&#233; mon site voient un cadre bleu autour de mes pages, comme &#231;a:



C'est moche, &#231;a gache tout mon d&#233;coupage mais surtout je vois pas d'o&#249; &#231;a sort ! J'ai regarder partout et j'ai pas trouver d'o&#249; &#231;a pouvait venir.. Est-ce que &#231;a peut venir du navigateur (sous safari on le voit pas (sur mon mac du moins), sous IE et FF oui, j'ai personne pour tester les autres)
Je comprend pas l&#224; ...:(
Dans tes balises style ajoute :

Bloc de code:
<style type="text/css">
[B] map img, img {
    border: none;
}[/B]
</style>
Attention c'est pour toutes les images de la page.
 

Tyite Bulle

Membre confirmé
23 Mars 2006
273
437
ça marche en effet.. Merci :)
Ca venait d'où? J'avais mis aucune bordure nulle part donc je vois pas trop pourquoi ça a fait ça
 
  • J’aime
Réactions: p4bl0