démarrage auto de Tomcat avec Léopard

ziglou

Membre confirmé
20 Février 2007
24
1
Bonjour

Ma question a trait au démarrage de Tomcat . C'est en soit une question plus sur Os X que sur le développement WEB (merci au modérateur de déplacer le topic si ce forum n'est pas le bon).

je viens de switcher sur Macbook et j'ai installé le serveur Tomcat 5.5.26 sur léopard.
A ce niveau pas de problème, j'arrive à le lancer et à le voir dans safari.

néanmoins je ne peux le lancer que manuellement en utilisant le script shell Startup.sh qui se trouve dans le répertoire bin de Tomcat. J'aimerais qu'il se lance en auto mais ne connaissant pas très bien Unix et encore moins les spécificités Léopard je patauge. J'ai bien fait des recherches sur Google mais j'avoue ne pas avoir trouver de réponse à mon problème.

J'ai toutefois compris qu'en plaçant un fichier .plist dans /Library/LaunchAgents ( user ou tout user) on pouvait réaliser cette opération.

j'ai donc créé un .plist pour ça mais quelque soit l'endroit ou je le place il ne lance pas Tomcat.

voilà le contenu de mon .plist :

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Label</key>
<string>StartTomcat-5.5.26</string>
<key>ProgramArguments</key>
<array>
<string>/Library/Tomcat/apache-tomcat-5.5.26/bin/startup.sh</string>
</array>
</dict>
</plist>

est-il correct?
pouvez-vous m'indiquer , pour ceux qui l'on fait, comment lancer Tomcat au démarrage ?

merci
 
A

Anonyme

Invité
Je connais pas trop unix non plus mais si tu glisses ton fichier .sh sur le tableau de bord Préférences système/Comptes (onglet ouverture) ça ne marche pas?
 

ziglou

Membre confirmé
20 Février 2007
24
1
Ca fonctionne pas.
Ca m'ouvre le script dans un éditeur...

je me demande pourquoi c'est si compliqué à faire ? Quelque chose doit m'échapper ...

merci tout de même GLOUP GLOUP
 

ziglou

Membre confirmé
20 Février 2007
24
1
j'ai déjà consulté ces deux liens.
Sur le premier j'ai le même problème que la personne qui essaie de mettre en oeuvre la méthode de lancement à partir des LaunchAgents : ça ne lance rien.
Sur le deuxieme j'ai pas réussi à créer le fichier .plist à placer dans le dossier StartupItems.

si vous avez des précisions sur les deux méthodes , je suis preneur.
 

tatouille

Membre expert
1 Juin 2004
5 174
493
Stanford CA
Bloc de code:
-> /Library/LaunchDaemons/org.apache.jakarta.tomcat-5.5.26.plist
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>Label</key>
    <string>org.apache.jakarta.tomcat-5.5.26</string>
    <key>EnvironmentVariables</key>
    <dict>
        <key>JAVA_HOME</key>
        <string>/System/Library/Frameworks/JavaVM.framework/Home</string>
    </dict>
    <key>ProgramArguments</key>
    <array>
        <string>/Library/Tomcat/apache-tomcat-5.5.26/bin/catalina.sh</string>
        <string>run</string>
    </array>
    <key>RunAtLoad</key>
    <true/>
    <key>ServiceDescription</key>
    <string>Tomcat 5.5.26 Server</string>
</dict>
</plist>