10.14 Mojave Démarrage sur Grub qui tourne en boucle

terje26

Membre junior
1 Septembre 2017
10
0
38
Bonjour à tous,
Je me retrouve embarrassé mon MBA ne démarre plus automatiquement. Je m'explique:
J'ai la nécessité d'installer une distribution Linux et ai fait le choix de mettre Ubuntu sur un SSD relié à mon MBA par thunderbolt.

Après avoir suivi un tutoriel qui me semblait très bien construit ( https://florisvanbreugel.wordpress.com/tag/ubuntu-on-mac/ ) et lorsque j'arrive à "Making Ubuntu bootable part 2"
Mon Mac ne boot plus correctement. En effet, au démarrage, j'ai une fenêtre noire façon terminal qui m'indique: grub/ . Le tuto dit que cela peut arriver et qu'il suffit de taper exit. Sauf que je peux taper indéfiniment "exit" et rien n'y fait.
Je parviens à lancer tout de même mon macOs Mojave en appuyant avant le "chime" sur "Alt" et choisir ma partition qui contient l'OS.
Mais j'aimerais, grâce à vous et à minima, rétablir le démarrage auto de macOs et au mieux avoir la possibilité de créer mon dual-boot Ubuntu.
A fortiori, j'arrive à rétablir le démarrage initial de l'os, lorsque je vais dans "préférences systême/disque de démarrage" et que je choisi le disque dur interne.
Dans l'attente de vos réponses, s'il vous plaît, qui j'espère me permettront de sortir de l'embarras.
Merci d'avance
 

terje26

Membre junior
1 Septembre 2017
10
0
38
Merci de l'intérêt porté à mon "souci" et à la réactivité.
Le problème qui n'en est pas vraiment un et de booter sous linux lorsque le SSD est connecté en thunderbolt et de continuer comme actuellement à booter par défaut sur mojave lorsque le disque externe n'est pas branché.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
35 676
4 292
Mais j'aimerais, grâce à vous et à minima, rétablir le démarrage auto de macOs et au mieux avoir la possibilité de créer mon dual-boot Ubuntu.
Lorsque tu as la main sous macOS, tu vas dans Préférences Système/Disque de démarrage, un clic sur le petit cadenas en bas à gauche, tu sélectionneras ton disque dur Macintosh HD et un clic sur redémarrer. Ton problème perdure ?
lorsque j'arrive à "Making Ubuntu bootable part 2"
Mon Mac ne boot plus correctement. En effet, au démarrage, j'ai une fenêtre noire façon terminal qui m'indique: grub/ . Le tuto dit que cela peut arriver et qu'il suffit de taper exit. Sauf que je peux taper indéfiniment "exit" et rien n'y fait.
Cela sous-entendrait que la commande csrutil disable n'est pas passée. Lorsque tu es sous macOS, tu lances le Terminal, tu fais un Copier/Coller de cette commande...
Bloc de code:
csrutil status
...en validant avec la touche Entrée. Quel est le résultat ?

Par défaut...
Pour désactiver le SIP il faut lancer le Terminal et faire un Copier/Coller de cette commande…
Bloc de code:
csrutil disable

Pour activer et/ou réactiver le SIP il faut lancer le Terminal et faire un Copier/Coller de cette commande…
Bloc de code:
csrutil enable
...en validant avec la touche Entrée.

Pour être sûr de bien désactiver le SIP, tu redémarres en maintenant les touches alt+cmd+R jusqu'à voir un globe tournant indiquant une connexion sur les serveurs d'Apple et d'attendre l'apparition d'une fenêtre avec 4 outils. Il faudra aller dans la barre de menu en haut de sélectionner Utilitaires/Terminal.
 

terje26

Membre junior
1 Septembre 2017
10
0
38
Merci Locke et Aliboron, la sélection de mon disque dur depuis Préférences/disque de démarrage à résolu mon probleme.
Afin de démarrer sur le ssd, je n'ai qu'à maintenir Alt avant le "chime" et booter sur l'efiBoot de la partition linux.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
35 676
4 292
Merci Locke et Aliboron, la sélection de mon disque dur depuis Préférences/disque de démarrage à résolu mon probleme.
En fait c'était tout simple, mais beaucoup de membres ne pensent à aller activer de nouveau cette option après modification du disque de démarrage.
 

Invité

Pommé
Club MacG
19 Février 2005
8 262
468
21000
Sinon, quand "grub" prend le pas, il faut cliquer sur la touche escape ("esc")
Là, tu es en ligne de commande avec grub et "exit" fonctionne parfaitement
Tu te retrouve sur les valeurs que tu retrouves en utilisantant "alt au boot

Ca me le fait souvent sur mon MB 2007 qui est partionné avec Lion et Mint.
Normallement il devrait démarrer avec rEFInd et me laisser choisir le volume de boot, mais bien souvent le boot se fait sur "grub" et là, les commandes "esc", "exit" fonctionnent parfaitement…