Déplacer audio ET vidéo dans iMovie

imacwesker

Membre junior
16 Décembre 2004
65
4
51
www.survivhor.com
Bonjour :)

Je créé un petit film familial avec iMovie HD. J'y rajoute des sons/musiques ou extrait les musiques des clips. A chaque fois, je verrouille le clip audio au point de lecture pour associer vidéo et sons/musiques.

Mon problème, c'est que à chaque fois que je supprime ou rajoute un clip dans la chronologie, le son se désynchronise de la vidéo ! Donc quel est l'intérêt de "verrouiller" si ça ne verrouille pas ?!? Et existe t'il une solution pour que le son reste verrouillé avec la vidéo, même si on modifie l'ordre ou le nombre de clips dans la chronologie ?

Merci d'avance :zen:
 

Marcmaniac

Membre d’élite
Club MacG
31 Mai 2004
1 186
50
52
Besançon
www.vos-travaux-videos.fr
Perso, je fais le montage vidéo puis, le montage son car comme tu le dis, on ne peux pas vérouiller le sonet la vidéo dans imovie HD ....
ou alors, je ne sais pas le fa&ire et ce post aura cet intérêt ...
 

OlivierTassi

Membre d’élite
Club MacG
10 Avril 2003
1 174
13
53
Sur Terre
Pour verrouiller le son sur un clip, il faut sélectionner le son et bien placer le curseur sur l'image auquel on veut qu'il se rattache.
 

OlivierTassi

Membre d’élite
Club MacG
10 Avril 2003
1 174
13
53
Sur Terre
En lisant "verrouiller le son sur un clip", il faut comprendre "lier un clip vidéo avec un clip sonore". Ainsi, les 2 clips bougent ensemble s'ils doivent bouger.
 

imacwesker

Membre junior
16 Décembre 2004
65
4
51
www.survivhor.com
En lisant "verrouiller le son sur un clip", il faut comprendre "lier un clip vidéo avec un clip sonore". Ainsi, les 2 clips bougent ensemble s'ils doivent bouger.
Désolé mais je ne comprends pas ce que tu veux dire. Il me semble que c'est déjà ce que je fais avec Cmd + L (verouiller le clip vidéo au point de lecture), mais ça ne marche pas dès qu'on modifie la chronologie. Par contre, si le nombre de clips ne change pas (en plus ou en moins) et que je déplace des clips à l'intérieur de la vidéo alors là, oui, ça fonctionne. Mais ce n'est pas ce que je recherche ... mais peut-être ais-je mal compris ce que tu voulais dire ?

Marcmaniac : c'est une bonne idée mais qui n'est pas réaliste dans mon cas. Il y a plusieurs personnes qui donnent leurs avis/idées et je passe mon temps à enlever/rajouter des clips :nailbiting:
 

OlivierTassi

Membre d’élite
Club MacG
10 Avril 2003
1 174
13
53
Sur Terre
Désolé mais je ne comprends pas ce que tu veux dire. Il me semble que c'est déjà ce que je fais avec Cmd + L (verouiller le clip vidéo au point de lecture), mais ça ne marche pas dès qu'on modifie la chronologie. Par contre, si le nombre de clips ne change pas (en plus ou en moins) et que je déplace des clips à l'intérieur de la vidéo alors là, oui, ça fonctionne. Mais ce n'est pas ce que je recherche ... mais peut-être ais-je mal compris ce que tu voulais dire ?...
Oui, c'est bien ça (Pomme+L). Je viens de refaire le test. Même en ajoutant un clip à la chronologie, mes clips audios verrouillés sont bien liés aux clips vidéos. C'est pour ça : il est très important que ton curseur se trouve bien au bon endroit. Le mieux, c'est de verrouiller alors que ton curseur est au centre du clip. Ainsi, si tu en changes sa durée, tu ne risques pas de perdre le point de verrouillage.
 

Marcmaniac

Membre d’élite
Club MacG
31 Mai 2004
1 186
50
52
Besançon
www.vos-travaux-videos.fr
J'essaie de suivre ce post mais les explications sont compliquées ... je vais essayer ...
On en apprend tous les jours et merci à vous !
 

imacwesker

Membre junior
16 Décembre 2004
65
4
51
www.survivhor.com
Olivier Tassi : je dois être une buse parceque ça ne marche pas chez moi ...

Bon voilà comment je fais pour verrouiller l'audio sur un clip :
- je me place sur la vidéo à l'endroit exact où je veux que le son commence
- je copie-colle (ou place depuis iTunes) le son
- je fais un gauche-droite avec les flèches du clavier pour que la barre jaune apparaisse
- je fais Cmd + L

Est-ce qu'une de ses étapes est fausse ? Ou je fais quelque chose en trop ou en moins ?
 

bernie14

Membre confirmé
21 Octobre 2007
429
13
82
Vaulnaveys le haut 38410
Oui, c'est bien ça (Pomme+L). Je viens de refaire le test. Même en ajoutant un clip à la chronologie, mes clips audios verrouillés sont bien liés aux clips vidéos. C'est pour ça : il est très important que ton curseur se trouve bien au bon endroit. Le mieux, c'est de verrouiller alors que ton curseur est au centre du clip. Ainsi, si tu en changes sa durée, tu ne risques pas de perdre le point de verrouillage.
je reprends avec interet
Ok pour cette maneuvre qui fonctionne ,ce clip ainsi isolé peut il etre inseré dans l'etat dans une autre sequence de ma bibliotheque de projets ?

J'ai repris l'organisation de sequences referencées par années et je besoin de faire migrer certains clips d'un projet a un autre (erreur d'epoque)
merci ton aide me serait tres utile
 

OlivierTassi

Membre d’élite
Club MacG
10 Avril 2003
1 174
13
53
Sur Terre
A partir de la chronologie, il suffit de sélectionner le clip vidéo et le son associé, faire un copier, aller dans le nouveau projet, de cliquer n'importe où sur la chronologie, puis de faire coller.
 

bernie14

Membre confirmé
21 Octobre 2007
429
13
82
Vaulnaveys le haut 38410
A partir de la chronologie, il suffit de sélectionner le clip vidéo et le son associé, faire un copier, aller dans le nouveau projet, de cliquer n'importe où sur la chronologie, puis de faire coller.
merci c'est en effet sans probleme, le transfert demande qq secondes ,il faut parfois savoir attendre...

merci
 

bernie14

Membre confirmé
21 Octobre 2007
429
13
82
Vaulnaveys le haut 38410
A partir de la chronologie, il suffit de sélectionner le clip vidéo et le son associé, faire un copier, aller dans le nouveau projet, de cliquer n'importe où sur la chronologie, puis de faire coller.
oui ça marche, mais le son ou les images jointes ne suivent pas toujours?
 

OlivierTassi

Membre d’élite
Club MacG
10 Avril 2003
1 174
13
53
Sur Terre
Il faut bien sélectionner la vidéo et le son et faire un copier/coller. Le souci, c'est que même si l'audio est lié à la vidéo, l'audio se met à 5' du début du film s'il était à 5' du début dans le 1er film, alors que la vidéo va se mettre à l'endroit où se trouve le curseur. Apparemment qd l'audio est lié à la vidéo, c'est une position absolue et non relative.
Mais bon. Rien n'est perdu. Il faut réarranger un peu.
Si Apple avait amélioré certains points d'iMovie 6 au lieu de faire les versions 7/8 régressives ...
 

bernie14

Membre confirmé
21 Octobre 2007
429
13
82
Vaulnaveys le haut 38410
merci Olivier,
reajuster la place de la bande son c'est en effet mineur quand tout le reste est transféré, mais parfois je n'ai pas du tout de transfert du son, j'imagine que je ne dois pas lier correctement les deux/
les zones son possèdent un petit triangle dans la partie inferireure gauche , est ce bien cela qui indique que c'est lié?
je pense que je n'ai pas bien integré" l'association" car parfois c'est bon d'autres non,j'ai luun document qui parle de "punaise"
 

OlivierTassi

Membre d’élite
Club MacG
10 Avril 2003
1 174
13
53
Sur Terre
Une bande son liée possède une punaise jaune. Ci-dessous, les 3 bandes sons du haut sont liées mais pas celle du bas :

La manière de lier vidéo/son n'est pas le point fort d'iMovie 6. Des fois ça marche, des fois pas.
 

bernie14

Membre confirmé
21 Octobre 2007
429
13
82
Vaulnaveys le haut 38410
mais je suis avec iMovie 8,04,on pourrait penser que c'est meilleur, est ce le cas ?
 

OlivierTassi

Membre d’élite
Club MacG
10 Avril 2003
1 174
13
53
Sur Terre
Comme au début de votre post vous avez dit que vous "repreniez", et que nous avions commencé sur iMovie 6, j'en ai déduit (à tord) que vous étiez également sous la version 6 aussi...
Je ne pratique pas les versions 7/8/9 d'iMovie que je trouve bp moins pratique que la version 6, surtout au niveau du son. J'ai déjà exprimé mon avis dans d'autres posts. Pour résumé, les 2 gros points noirs sont :
- pas de possibilité de moduler le volume sonore au sein d'une piste sonore
- qualité vidéo dégradée en sortie de projet
 

bernie14

Membre confirmé
21 Octobre 2007
429
13
82
Vaulnaveys le haut 38410
comme quoi toujours plus (de gadgets) n'est pas forcement mieux....

merci pour ton aide et tes conseils qui m'ont néanmoins été precieux
bernard