• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

Des soucis pour lancer OpenOffice 1.0.3

Zitoune

Membre d’élite
Club MacG
16 Octobre 2000
4 852
4
J'ai téléchargé et installé X11 b3, puis OpenOffice 1.0.3 pour Darwin/MacOS X.

En double-cliquant sur l'application "Start openOffice.org", X11 'ouvre mais j'obtiens un message m'informant que "Could not launch XWindow server : X11"


A la fin de l'installation d'OpenOffice, j'avais un message m'indiquant ce qu'il fallait taper si je rencontrais des difficultés à lancer le programme. J'ai fait une copie d'écran et recopié, mais je n'arrive à rien.

D'avance, merci pour l'aide que vous pourrez m'apporter !





Voilà une copie de ce que j'ai tapé dans la fenêtre X11 :

[iMac:~] o% setenv DISPLAY localhost:0
[iMac:~] o% setenv DYLD_LIBRARY_PATH /Applications/OpenOffice.org1.0.3/program:/Applications/OpenOffice.org1.0.3/program/filter:/usr/X11R6/lib
[iMac:~] o% cd /Applications/OpenOffice.org1.0.3/program
[iMac:/Applications/OpenOffice.org1.0.3/program] o% sh soffice
soffice: dirname: command not found
soffice: basename: command not found
soffice:
=: unary operator expected
soffice: dirname: command not found
soffice: basename: command not found
/Applications/OpenOffice.org1.0.3/program/sopatchlevel.sh: dirname: command not found
soffice: /Applications/OpenOffice.org1.0.3/program/.bin: No such file or directory
soffice: exec: /Applications/OpenOffice.org1.0.3/program/.bin: cannot execute: No such file or directory
[iMac:/Applications/OpenOffice.org1.0.3/program] o%
 

Zitoune

Membre d’élite
Club MacG
16 Octobre 2000
4 852
4
PS : le smiley n'a rien à faire là, c'est normalement les signes "[" et ":" collés l'un à l'autre, mais MacG fait la transformation sans me demander mon avis !
 

macmarco

Vénérable sage
Club MacG
25 Juillet 2002
11 068
4 026
51
Rennes
Voilà pour démarrer OpenOffice :
Lance X11, dans le menu Application sélectionne "Personnaliser", puis "Ajouter un élément, puis dans le champ de texte de gauche tu mets le nom que tu veux voir apparaître dans le menu et dans le champ de droite tu mets le chemin.
Le voici, fais un copier/coller : /Applications/OpenOffice.org1.0.3/program/soffice
Et maintenant, ça marchera !
 

macmarco

Vénérable sage
Club MacG
25 Juillet 2002
11 068
4 026
51
Rennes
Zitoune a dit:
PS : le smiley n'a rien à faire là, c'est normalement les signes "[" et ":" collés l'un à l'autre, mais MacG fait la transformation sans me demander mon avis !
Pour le smiley, c'est simplement qu'il se trouve que la combinaison de signes correspond à ce smiley.
Par ex. ce smiley -->
= ; plus )
Comme tu n'as pas désactivé les smileys en ecrivant ton post, la combinaison de signes a été considérée comme un smiley.


Voilà toute l'histoire !
 

Zitoune

Membre d’élite
Club MacG
16 Octobre 2000
4 852
4
macmarco a dit:
Voilà pour démarrer OpenOffice :
Lance X11, dans le menu Application sélectionne "Personnaliser", puis "Ajouter un élément, puis dans le champ de texte de gauche tu mets le nom que tu veux voir apparaître dans le menu et dans le champ de droite tu mets le chemin.
Le voici, fais un copier/coller : /Applications/OpenOffice.org1.0.3/program/soffice
Et maintenant, ça marchera !
Ben, je me suis peut-être trompé, mais il ne se passe rien lorsque je suis dans X11 et que je vais dans Applications > OpenOffice

> faut que je tape des lignes de commande ?
> je me suis trompé dans la manipulation indiquée ?
 

macmarco

Vénérable sage
Club MacG
25 Juillet 2002
11 068
4 026
51
Rennes
As-tu installé d'autres logiciels(Gimp, par ex.) et fonctionnent-ils ?
 

macmarco

Vénérable sage
Club MacG
25 Juillet 2002
11 068
4 026
51
Rennes
As-tu bien édité le fichier .cshrc avec pico dans le terminal ?
As-tu mis OpenOffice dans un dossier particulier ?
Vas dans le dossier OpenOffice, puis program, puis sélectionne le fichier soffice, dans le Finder/Services choisis "Créer un nouvel aide-mémoire', puis copie l'url et colle-le dans le menu d'X11 et réessaie.
 

Zitoune

Membre d’élite
Club MacG
16 Octobre 2000
4 852
4
macmarco a dit:
Vas dans le dossier OpenOffice, puis program, puis sélectionne le fichier soffice, dans le Finder/Services choisis "Créer un nouvel aide-mémoire', puis copie l'url et colle-le dans le menu d'X11 et réessaie.
C'est bien d'un raccourci que tu parlais ?

Quand je tape ceci :

D2 :Applications :Openoffice.org1.0.3
rogram :soffice

dans la fenêtre X11, j'obtiens ce message :
[iMac:~] o% Applications : OpenOffice.org1.0.3 : program : soffice
/Users/o/Applications: Permission denied.
 

macmarco

Vénérable sage
Club MacG
25 Juillet 2002
11 068
4 026
51
Rennes
Si tu n'as pas édité le fichier .cshrc, tes soucis viennet de là !
Il est nécessaire d'éditer ce fichier pour que soit pris en compte ce que tu installes avec Fink.
Suis ce lien et les étapes décrites pour l'édition du fichier .cshrc.

Et garde ce lien dans tes favoris !
 

Zitoune

Membre d’élite
Club MacG
16 Octobre 2000
4 852
4
désolé d'avoir laissé l'installeur faire son boulot et d'avoir cru que tout irait tout seul

En tous cas, merci.
 

macmarco

Vénérable sage
Club MacG
25 Juillet 2002
11 068
4 026
51
Rennes
Zitoune a dit:
C'est bien d'un raccourci que tu parlais ?

Quand je tape ceci :

D2 :Applications :Openoffice.org1.0.3
rogram :soffice

dans la fenêtre X11, j'obtiens ce message :
[iMac:~] o% Applications : OpenOffice.org1.0.3 : program : soffice
/Users/o/Applications: Permission denied.
Primo, utilise des slashs (/) au lieu des points(comme ça tu n'auras plus le petit bonhomme qui tire la langue !
)...

Secundo je parlais de la personnalisation du menu Applications d'X11.
 

macmarco

Vénérable sage
Club MacG
25 Juillet 2002
11 068
4 026
51
Rennes
Zitoune a dit:
désolé d'avoir laissé l'installeur faire son boulot et d'avoir cru que tout irait tout seul

En tous cas, merci.
Y'a pas de mal, ça m'est arrivé une fois que j'étais trop pressé !
 

macmarco

Vénérable sage
Club MacG
25 Juillet 2002
11 068
4 026
51
Rennes
PS : Pour tout ce qui concerne X11, il vaut mieux poster dans Unix, Linux & Open Source.Si tu n'y étais pas allé, je n'aurais pas vu ton post...
 

Zitoune

Membre d’élite
Club MacG
16 Octobre 2000
4 852
4
Oké, je comprends mieux.
Là, j'en suis à suivre les étapes indiquées sur la page que tu m'as recommandée...
 

Zitoune

Membre d’élite
Club MacG
16 Octobre 2000
4 852
4
ben je suis bloqué à l'étape 5 (c'est à dire que X11 ; X11 SDK ; Fink sont installés) car lorsque j'ouvre une fenêtre du terminal et que je tape la commande "pico .cshrc", j'obtiens :

[iMac:~] o% pico .cshrc
pico: Command not found.
 

Zitoune

Membre d’élite
Club MacG
16 Octobre 2000
4 852
4
c'est peut-être parce que le sous-système BSD n'était pas installé que ça ne fonctionnait pas. Alors j'installe le package et je reviens.
 

macmarco

Vénérable sage
Club MacG
25 Juillet 2002
11 068
4 026
51
Rennes
Zitoune a dit:
ben je suis bloqué à l'étape 5 (c'est à dire que X11 ; X11 SDK ; Fink sont installés) car lorsque j'ouvre une fenêtre du terminal et que je tape la commande "pico .cshrc", j'obtiens :

[iMac:~] o% pico .cshrc
pico: Command not found.
Ben v'la aut'chose !


Pico est un éditeur de texte qui est installé par défaut...

A la racine de ton disque dur, y a t'il un dossier "sw" ?
As-tu plusieurs partitions et as-tu installé fink et X11 sur ta partition de démarrage ?