• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

MacBook Air Disque Dur externe LaCie non reconnu

thochar

Nouveau membre
2 Juillet 2016
8
0
28
Paris
Bonjour,
J'ai un disque dur externe LaCie Porsche Design qui marchait très bien sur mon MacBook Air 2013 (Version El Captain 10.11.4).
Or, il n'est à présent plus reconnu ni dans le finder ni dans Utilitaire de Disque.

Il ne contient que des sauvegardes Time Machine, cela ne me dérange donc pas de perdre l'intégralité de son contenu et de le restaurer totalement.

J'ai utilisé Terminal et la commande suivante :
diskutil eraseDisk JHFS+ Test /dev/disk2
Après un temps de chargement, le message suivant apparaît :
Error: -69888: Couldn't unmount disk

Comment puis-je récupérer l'usage de mon disque dur ...?
Merci par avance de vos réponses.
Thomas
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
60 681
19 876
Forêt de Fontainebleau
Salut thochar

Ta commande était adéquate.

Le message d'échec retourné :
Bloc de code:
Couldn't unmount disk
signifie régulièrement que l'utilitaire diskutil n'a pas réussi à désactiver tous les système de fichiers des partitions du disque - ce qui est le préalable à une opération d'effacement de la table de partition (eraseDisk) d'un disque.

Ce qui est quand même bizarre, parce que tu dis que le volume de ce DDE n'apparaissait pas graphiquement dans le Finder ni dans l'«Utilitaire de Disque» > signe qu'il était démonté > càd. que son système de fichiers n'était pas activé => il y a du louche.

Est-ce que tu peux, ton DDE attaché au Mac, passer une commande :
Bloc de code:
diskutil list
et faire un copier-coller ici (pas de cliché) du tableau retourné ? - que je vois comment ton disque est actuellement identifié...
 
Dernière édition:

thochar

Nouveau membre
2 Juillet 2016
8
0
28
Paris
Bonsoir,
Merci pour ta réponse,
le diskutil disk donne la réponse suivante :

/dev/disk0 (internal, physical):
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *251.0 GB disk0
1: EFI EFI 209.7 MB disk0s1
2: Apple_CoreStorage Macintosh HD 250.1 GB disk0s2
3: Apple_Boot Recovery HD 650.0 MB disk0s3

/dev/disk1 (internal, virtual):
#: TYPE NAME SIZE IDENTIFIER
0: Apple_HFS Macintosh HD +249.8 GB disk1
Logical Volume on disk0s2
58121144-3578-4F99-BF98-57FE6949EA85
Unlocked Encrypted

/dev/disk2 (external, physical):
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *1.0 TB disk2
1: EFI EFI 209.7 MB disk2s1
2: Apple_HFS LaCie 999.9 GB disk2s2
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
60 681
19 876
Forêt de Fontainebleau
La table de partition qui concerne ton DDE :
Bloc de code:
/dev/disk2 (external, physical):
#:                  TYPE NAME        SIZE        IDENTIFIER
0: GUID_partition_scheme            *1.0 TB      disk2
1:                   EFI EFI         209.7 MB    disk2s1
2:             Apple_HFS LaCie       999.9 GB    disk2s2
est complète. La partition disk2s2 est identifiée et le volume reconnu par son nom : Lacie.

Pourquoi le volume ne monterait-il pas dans ces conditions ?

Avant de tenter des opérations logiques, je me demande s'il n'y a pas un problème de câblerie. Comment attaches-tu ce DDE au Mac ? En USB ? Avec 2 cordons : un pour l'alimentation, un autre pour le transfert des données ? Ou un seul  USB ?

Est-ce que tu entends le disque tourner quand tu attaches ton DDE ? As-tu la possibilité de l'attacher à un autre Mac (dont le disque supporterait un OS antérieur à «El Capitan») > pour voir si le volume monte ? Si tu as 2 cordons USB pour ce DDE, pourrais-tu attacher le cordon d'alimentation électrique à un hub auto-alimenté sur le secteur, pour voir ce qui se passe ?

Comme j'utilise exclusivement des DDE Lacie depuis lurette, je dois dire qu'avec certains modèles j'ai eu pas mal de déboires du même type que le tien : impossibilité de faire monter le volume du disque (alors que le disque n'avait intrinsèquement rien) - même quand je sentais à la main le disque tourner dans le boîtier. Jamais les Lacie Thunderbolt, qui sont d'une stabilité à toute épreuve. Jamais les Lacie FireWire_400, complètement stables (mais réclamant un Mac ancien). Très souvent avec les Lacie FireWire_800, d'une instabilité dramatique. Parfois avec les Lacie USB-2 (je n'ai pas de Mac supportant l'USB-3).

J'en ai tiré l'impression que l'alimentation électrique, délivrée par le port dédié du Mac, était parfois insuffisante (et que cette insuffisance, déjà notable en USB-2, pouvait avoir à voir, de surcroît, avec la gestion de l'USB par l'OS - «El Capitan» se trouvant très loin d'être irréprochable sous ce rapport).
 

peyret

Membre d’élite
Club MacG
22 Octobre 2001
4 277
739
70
43110
Bonjour à toutes et à tous,
Je vous fais part d'une expérience que j'ai eu avec mon DDE LaCie : s'il n'est pas branché au mac : il ne démarre pas, même si au dos l'interrupteur est sur ON.... et l'alimentation électrique branché (connexion FW).:eek: J'ai pensé un instant qu'il était décédé....
 

thochar

Nouveau membre
2 Juillet 2016
8
0
28
Paris
Bonjour,
Merci pour ta réponse.
Je branche le cordon du DDE avec un seul USB, il n'y a qu'un emplacement.
Lorsqu'il est branché, j'entends en effet le DDE tourner, et sa lumière clignote.

J'avais branché le DDE sur un autre mac, El Capitan aussi, et en effet il n'était pas reconnu.
Je l'ai branché tout à l'heure sur un Macbook Pro tournant sur une ancienne version, pas El Capitan, et tu as raison le DDE est reconnu dans Utilitaire de Disque.
J'ai tenté de l'effacer, mais l'étape "Démontage du disque" ne se termine pas...
 

Flo67

Membre junior
15 Avril 2013
78
4
France
J'ai un Lacie Porsche design qui n'est plus reconnu dès lors qu'il est éjecté de façon incorrecte. Une réparation du disque a été tentée par le terminal ?
 

Flo67

Membre junior
15 Avril 2013
78
4
France
Bonjour à toutes et à tous,
Je vous fais part d'une expérience que j'ai eu avec mon DDE LaCie : s'il n'est pas branché au mac : il ne démarre pas, même si au dos l'interrupteur est sur ON.... et l'alimentation électrique branché (connexion FW).:eek: J'ai pensé un instant qu'il était décédé....
C'est normal, les Lacie "économisent" l'énergie dès lors qu'un accès au disque n'est pas demandé, il ne s'allume pas pour la plupart.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
60 681
19 876
Forêt de Fontainebleau
:coucou: thochar

Quand tu attaches ton DDE au MacBook Pro qui permet de faire monter son volume Lacie, est-ce que tu peux copier des fichiers dans le volume affiché > les ouvrir > les supprimer ? Ou bien le volume apparaît-il en lecture seule ?


Par ailleurs, as-tu essayé d'attacher ton DDE avec un câble USB en Y =>

- soit de type mini-USB côté boîtier : ☞câble en Y mini-USB-2

- soit micro-USB-3 côté boîtier : ☞câble en Y micro-USB-3

- soit encore ☞câble en Y USB standard☜​

selon le type de port de ton DDE ? => histoire de vérifier si un apport d'alimentation côté Mac règlerait la question...
 

thochar

Nouveau membre
2 Juillet 2016
8
0
28
Paris
:coucou: thochar

Quand tu attaches ton DDE au MacBook Pro qui permet de faire monter son volume Lacie, est-ce que tu peux copier des fichiers dans le volume affiché > les ouvrir > les supprimer ? Ou bien le volume apparaît-il en lecture seule ?


Par ailleurs, as-tu essayé d'attacher ton DDE avec un câble USB en Y =>

- soit de type mini-USB côté boîtier : ☞câble en Y mini-USB-2

- soit micro-USB-3 côté boîtier : ☞câble en Y micro-USB-3

- soit encore ☞câble en Y USB standard☜​

selon le type de port de ton DDE ? => histoire de vérifier si un apport d'alimentation côté Mac règlerait la question...
Bonjour,
Lorsque je le branche sur le MacBook pro, il n'est pas reconnu dans le finder, uniquement dans utilitaire de disque.

Je n'ai pas ces cables, Est-ce que tu penses que je devrais en acheter un ?

merci,
thomas
 

thochar

Nouveau membre
2 Juillet 2016
8
0
28
Paris
Je me demande si notre ami n'est pas allé un peu vite avec l'effacement de son disque externe. Il arrive que les miens ne se réveillent pas à l'allumage, généralement un reboot règle le problème...
Bonjour,
L'effacement n'a pas marché, l'étape "démontage du disque" ne s'est jamais terminée...
Comment fais-tu un reboot ?
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
60 681
19 876
Forêt de Fontainebleau
Salut Thomas

Je te soumets une première expérimentation (sans trop y croire) :

- a) ton DDE Lacie attaché au Mac > tu repasses un :
Bloc de code:
diskutil list
histoire de vérifier si le disque est toujours identifié comme disk2 et la partition Lacie comme disk2s2 (comme dans ton tableau antérieur).

Je vais prendre ces paramètres de device en exemple (tu changes leurs valeurs s'il y avait lieu).

--------------------​

- b) tu passes alors la commande de démontage du volume Lacie :
Bloc de code:
diskutil umount /dev/disk0s2
Cette commande démonte le volume sans déconnecter le disque du Système (démonter graphiquement par ⌘E dans le Finder a l'inconvénient de déconnecter le disque en plus de démonter le volume). Si ça marche > normalement le système de fichiers de Lacie est bien désactivé.
--------------------​

- c) tu complètes par la commande de re-partitionnement :
Bloc de code:
diskutil partitionDisk /dev/disk2 gpt jhfs+ Lacie 100%
Cette commande recrée globalement une GPT (GUID Partition Table) et exporte un volume Lacie prenant l'espace total du disque moins les 209 Mo de l'en-tête ESP (EFI System Partition).

--------------------​

=> tu vas bien voir si tu as encore une fois ton message d'erreur...
 

thochar

Nouveau membre
2 Juillet 2016
8
0
28
Paris
Salut,
Merci pour ta réponse.
Voilà ce qui s'affiche en fin de processus décrit :

Air-de-THOMAS:~ ThomasCompagne$ diskutil list
/dev/disk0 (internal, physical):
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *251.0 GB disk0
1: EFI EFI 209.7 MB disk0s1
2: Apple_CoreStorage Macintosh HD 250.1 GB disk0s2
3: Apple_Boot Recovery HD 650.0 MB disk0s3
/dev/disk1 (internal, virtual):
#: TYPE NAME SIZE IDENTIFIER
0: Apple_HFS Macintosh HD +249.8 GB disk1
Logical Volume on disk0s2
58121144-3578-4F99-BF98-57FE6949EA85
Unlocked Encrypted

/dev/disk2 (external, physical):
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *1.0 TB disk2
1: EFI EFI 209.7 MB disk2s1
2: Apple_HFS LaCie 999.9 GB disk2s2

Air-de-THOMAS:~ ThomasCompagne$ diskutil umount /dev/disk0s2
disk0s2 was already unmounted

Air-de-THOMAS:~ ThomasCompagne$ diskutil partitionDisk /dev/disk2 gpt jhfs+ Lacie 100%
Started partitioning on disk2
Unmounting disk
Error: -69888: Couldn't unmount disk
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
60 681
19 876
Forêt de Fontainebleau
Je te propose une 2è expérimentation visant à faire sauter la table de partition GPT.

- a) d'abord tu télécharges le paquet installateur de gdisk à cette adresse : ☞GPT fdisk☜ > tu obtiens un gdisk-1.0.1.pkg que tu double-cliques pour installer le binaire. C'est un programme créé par Roderick Smith pour gérer les tables de partition.

- b) tu lances le «Terminal» (ton DDE attaché au Mac) et =>

- 1° tu appelles gdisk sur la cible de ton DDE par la commande :
Bloc de code:
sudo gdisk /dev/disk2
et ↩︎ --> une demande de password s'affiche (commande sudo) --> tape ton mot-de-passe admin à l'aveugle - aucun caractère ne se montrant à la frappe - et derechef ↩︎

=> après affichage des paramètres de la table de partition du disque, l'utilitaire te restitue une invite de commande :
Bloc de code:
Command (? for help):
- 2° tu tapes la commande :
Bloc de code:
x
et ↩︎ > par laquelle tu passes en opérateur expert > tu récupères une invite de commande :
Bloc de code:
Expert command (? for help):
- 3° tu tapes la commande :
Bloc de code:
z
et ↩︎ > par laquelle tu demandes l'effacement de la table de partition GPT du disque > le logiciel te retourne :
Bloc de code:
About to wipe out GPT on /dev/disk2. Proceed? (Y/N):
> tu tapes la commande :
Bloc de code:
Y
et ↩︎ > le programme te retourne un :
Bloc de code:
Warning: Devices opened with shared lock will not have their
partition table automatically reloaded!
Warning: The kernel may continue to use old or deleted partitions.
You should reboot or remove the drive.
GPT data structures destroyed! You may now partition the disk using fdisk or
other utilities.
Blank out MBR? (Y/N):
> tu tapes la commande :
Bloc de code:
Y
et ↩︎ pour garder un disque vide > le programme quitte en te restituant l'invite de commande régulière :
Bloc de code:
ThomasCompagne$
Si l'opération a réussi, le volume Lacie apparaît toujours monté sur ton Bureau (parce que le kernel ne s'est encore aperçu de rien) > auquel cas > démonte le volume (sélection > ⌘E) et retire ton DDE > reconnecte ton DDE => obtiens-tu le panneau : le disque que vous avez inséré n'est pas lisible par cet ordinateur avec 3 boutons de choix : Initialiser... Ignorer Éjecter ? > Initialiser lance l'«Utilitaire de Disque» qui peut te permettre de recréer un dispositif logique sur ton disque (menu "Effacer") --> sinon, c'est ma commande :
Bloc de code:
diskutil partitionDisk /dev/disk2 gpt jhfs+ Lacie 100%
Si l'opération a échoué : à quel moment ? message d'erreur de gdisk ?​
 
Dernière édition:

thochar

Nouveau membre
2 Juillet 2016
8
0
28
Paris
Salut Macomaniac,
C'est incroyable ta manipulation a marché !
J'ai retrouvé mon DDE dans le finder ainsi que dans Utilitaire de Disque, il est en cours de sauvegarde Time Machine, donc tout semble fonctionner parfaitement !

Merci beaucoup pour tes explications de démarches à effectuer, tout était extrêmement clair et très bien expliqué.
Ca m'évite d'acheter un nouveau DDE !
:)
Thomas
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
60 681
19 876
Forêt de Fontainebleau
Salut Thomas

Je suis content pour toi que l'utilitaire de Roderick Smith t'ait tiré d'affaire.

J'ai senti que la table de partition était en vrac tout en bloquant toute manipulation > et qu'il fallait donc utiliser un levier logique plus brutal que ce que diskutil pouvait fournir.
 

Kamelbleu75

Nouveau membre
20 Novembre 2016
2
0
40
Salut Thomas

Je suis content pour toi que l'utilitaire de Roderick Smith t'ait tiré d'affaire.

J'ai senti que la table de partition était en vrac tout en bloquant toute manipulation > et qu'il fallait donc utiliser un levier logique plus brutal que ce que diskutil pouvait fournir.

Bonjour Macomaniac

Je me permets de t'écrire car j'ai le meme problème que Thomas, je m'explique

MacBook Pro 15 en OSX 10.11

J'ai récemment acheté un lacie rugged raid 4tb thunderbolt, que je n'utilise pas en Raid (j'espère que ce n'est pas la source de mes problèmes ...)

et qui a des difficulté a monter ... il peut mettre parfois 1 heure 30 pour apparaitre sur le finder, alors qu'il est visible sur l'utilitaire disque (sans affiché aucune info), et il est visible physiquement dans le rapport system (mais pareil toujours sans info precise ... que la capacité sans le disponible) ...


Bref ... ai je fais une bêtise en l'utilisant en disque normal ?

Merci de votre aide
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
60 681
19 876
Forêt de Fontainebleau
Salut Kamelbleu

Le Lacie Rugged Raid 4t To Thunderbolt est un boîtier complexe, qui inclut 2 HDD solidarisés par défaut dans une matrice RAID 0 (entrelacé) qu'on peut basculer vers le mode RAID 1 (miroir) par action physique dans 2 trous de la tranche du boîtier. Ce boîtier est attachable au Mac soit en Thunderbolt, soit en USB-3 mais nécessite alors en parallèle un adaptateur secteur.

Si tu dis que tu ne l'utilises pas en mode RAID > je subodore alors qu'on n'a pas affaire à un RAID « matériel » au sens strict > mais sans doute à un RAID « pseudo-matériel » susceptible d'être déconstruit logiciellement. Les 2 disques internes, dès lors que désolidarisés, sont-ils dans de telles conditions susceptibles de transferts de données séparés via le même cordon ? S'ils étaient désolidarisés > ils monteraient 2 volumes distincts > ce que tu ne parais pas signaler ; s'ils ne montent qu'un seul volume > alors ces 2 disques sont toujours solidarisés dans une matrice RAID.

Afin que je cerne plus adéquatement l'état des lieux, je te propose d'attacher ton Lacie à ton Mac > d'aller alors à : Applications > Utilitaires > pour lancer le «Terminal» > dans la fenêtre qui s'ouvre, saisis la commande (purement informative) :
Bloc de code:
diskutil list
et ↩︎ (presse la touche "Entrée" du clavier pour activer la commande). Cette commande appelle l'utilitaire diskutil (le même que met en œuvre graphiquement le logiciel «Utilitaire de Disque» > avec le verbe list (lister) > en retour, tu vas voir s'afficher le tableau des disques attachés à ton Mac (en interne / externe) > avec leurs tables de partition > et leurs partitions décrites en format > nom > taille > device (appareil logique).

=> peux-tu faire un copier-coller de ce tableau ici (ne fais pas de capture d'écran --> sélection du tableau au pointeur > ⌘C pour copier ta sélection dans le presse-papier > ⌘V pour la coller) ? - sans ces informations logiques en mode texte > je ne peux pas me faire une idée adéquate de la « nature des choses ».

=> il serait bon aussi que tu précises comment tu attaches ce boîtier à ton Mac : en Thunderbolt ? De quelle année date alors ton MacBook Pro (pour savoir s'il a le Thunderbolt-1 ou 2) ? en USB-3 ? Utilises-tu alors l'adaptateur secteur en parallèle ?

De plus : comment t'y es-tu pris pour défaire la Matrice RAID 0 qui était le dispositif par défaut ? Y avait-il une option pour ce faire dans le mode d'emploi du boîtier ? Par un procédé mécanique ? As-tu utilisé l'«Utilitaire de Disque» pour la déconstruire logiquement ?

En résumé : ton boîtier n'a pas la même nature que celui de Thomas même s'il s'agit également d'un Lacie --> car le sien ne contenait qu'un disque dur (boîtier simple) > alors que le tien contient 2 disques durs (boîtier complexe) - ce qui est susceptible de changer la donne.