10.13 High Sierra Disque interne qui a disparu après mise hors tension

ericxt

Membre junior
11 Mai 2020
13
0
49
Bonjour, Je viens vers vous pour vous demander un peu d'aide sur mon imac 21,5 fin 2009 en core2duo, high sierra.

J'ai installé un ssd à la place du disque dur d'origine, pas de problème particulier.
Comme le mac était ouvert et que j'avais un disque 1To sous la main, j'ai enlevé le lecteur optique et j'ai mis ce disque à la place qui me servira d'espace de stockage. Pas de problème non plus.

Avant hier, ma femme par habitude par rapport aux pc portables de la maison a débranché le mac sans l'éteindre....

Depuis, l'ordinateur démarre bien, j'ai bien accés à mon ssd système mais le disque dur de stockage n'apparait plus.
J'ai réussi à le voir une fois en passant par l'utilitaire de disque mais au démarrage suivant il avait disparu et il n'est maintenant plus visible dans l'utilitaire de disque.

Sur les conseils (avisés ou pas,je ne suis pas capable d'en juger !) de quelqu'un sur un groupe facebook, j'ai réinstallé l'os (à l'aide de time machine) sur le ssd.

Au moment de l'installation, avant d'avoir démarré sur l'os, j'ai pu voir aussi le disque sur l'utilitaire de disque. J'aurai peut être du le réinitialiser à ce moment là mais je n'y ai pas pensé.

Os réinstallé, toujours pas de visibilité sur ce disque...( ou il y avait aussi mes sauvegardes time machine récentes, les autres ont une semaine, c'est pas la mort non plus...)

j'ai retenté une nouvelle installation en espérant avoir accés au HDD par l'utilitaire de disque mais maintenant je ne le vois plus du tout...

Là je suis un peu perdu du coup !

Les données contenues sont presque à jour sur un autre disque time machine, tant pis pour le peu qui manque mais j'aimerai quand même pouvoir faire fonctionner ce disque....quitte à le formatter.

Pouvez vous me diriger vers une solution ?

sur l'image jointe , on voit le disque (stockage interne) , c'était lors de la première réinstallation time machine, depuis....plus rien.

Je ne pense pas que ce soit un problème de nappe, l'ordi n'a pas bougé de sa place.

merci d'avance à ceux qui me lisent

Eric
 

Fichiers joints

  • IMG_20200521_073633.jpg
    IMG_20200521_073633.jpg
    57,7 KB · Affichages: 48

Findor

Chat qui utilise OS X
Club MacG
10 Avril 2019
2 101
276
Bonjour Eric

C'est donc le volume stockage interne qui ne s'affiche pas dans le Finder (et maintenant non plus dans l'Utilitaire de disque) ?
 

ericxt

Membre junior
11 Mai 2020
13
0
49
exactement, il ne s'affiche dans ni l'un ni l'autre.
Je refait une troisième installation et je l'ai vu à nouveau apparaitre au moment de la réinstal. Je l'ai reformaté du coup au cas ou (oui,c'est un peu au pif...) mais toujours rien une fois macos démarré.
Par contre l'ordi a planté tout seul et a redémarré (en plus pendant ma sieste, sacrilège !) et m'a mis un message que je n'arrive pas à copier ici, trop long ,ou format de texte pas accepté (c'est la première fois que ça arrive, le plantage),je le met en lien : https://docs.google.com/document/d/1qbDP44xG5bo2UeQo3TGG7ACWRBVDO02q4vLJ8_t5vio/edit?usp=sharing

inutile de préciser que c'est du chinois prononcé par un finlandais pour moi...
 

Findor

Chat qui utilise OS X
Club MacG
10 Avril 2019
2 101
276
C'est un kernel_panic (le noyaux qui panique et fait planter le Mac). Ça peux arriver. Revenons à l'idée de retrouver ton volume -->

- peux-tu réouvrir ta session ?​
 

ericxt

Membre junior
11 Mai 2020
13
0
49
je ne sais pas si ça peut être utile :

Bloc de code:
Last login: Thu May 21 14:06:20 on console

iMac-de-Eric:~ EricRoulet$ diskutil list

/dev/disk0 (internal, physical): 

   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS ssd mac                 499.1 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

je suis dessus actuellement

je pense à un truc : j'ai fait une restauration via time machine. Le nom que portait mon DD au moment de la création de la time machine était "imac de éric"
lors de l'installation de mon ssd , j'ai nommé mon disque système "ssd"
ça n'a surement rien à voir mais on ne sait jamais....(quand on est perdu, on se raccroche à n'importe quelle brindille !)
 
Dernière édition par un modérateur:

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
35 753
4 316
Comme le mac était ouvert et que j'avais un disque 1To sous la main, j'ai enlevé le lecteur optique et j'ai mis ce disque à la place qui me servira d'espace de stockage. Pas de problème non plus.
Un ancien disque ou un neuf ? De plus quel est le modèle de caddie que tu as utilisé ?
Sur les conseils (avisés ou pas,je ne suis pas capable d'en juger !) de quelqu'un sur un groupe facebook, j'ai réinstallé l'os (à l'aide de time machine) sur le ssd.
Faire une réinstallation ne sert à rien, ton problème de non-reconnaissance est lié soit de la défectuosité du disque dur, soit de la connexion du caddie sur la carte mère. Il n'y a qu'un minuscule connecteur, est-il bien clipsé ? Le seul choix possible est de retirer le caddie, de tester ton disque dur dans un boîtier USB pour en vérifier son fonctionnement.

Si tout est OK, il faudra mettre en cause la qualité dudit caddie. Avant de démonter, vérifie bien que le petit connecteur est bien clipsé sur la carte mère.
 

baron

Membre d’élite
22 Avril 2008
1 488
367
LLN
Si c'est arrivé suite à une déconnexion brutale, on peut aussi soupçonner une corruption de la table des fichiers — à corriger alors avec DiskWarrior si l'Utilitaire de disques ne peut rien…
 

ericxt

Membre junior
11 Mai 2020
13
0
49
j'ai bien pensé au démontage pour le tester avec un pc mais windows sera t'il capable de lire ce format ?
le caddy est un caddy de pc portable, pas parfaitement adapté mais je ne pense pas qu'il ait une quelconque infuence sur le branchement de la nappe.
Le disque est neuf, il a une semaine (acheté depuis des mois mais utilisé depuis quelques jours seulement...)
je suis prêt à tout démonter mais si il y avait une solution de test avant, je préférerai évidemment !

je ne connais pas DiskWarrior , peut il m'aider à voir un volume invisible ?
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
35 753
4 316
le caddy est un caddy de pc portable, pas parfaitement adapté mais je ne pense pas qu'il ait une quelconque infuence sur le branchement de la nappe.
Ça c'est que tu penses, quel est donc ce caddie ?

Par défaut ton iMac devrait être ce modèle là... https://fr.ifixit.com/Device/iMac_Intel_21.5"_EMC_2308 ...et il faut utiliser ce type de caddie... https://fr.ifixit.com/Tutoriel/Installation+d'un+second+disque+dur+dans+l'iMac+Intel+215-Inch+EMC+2308/8641 ...il y a des variantes... https://www.amazon.fr/s?k=optical+bay&__mk_fr_FR=ÅMÅŽÕÑ&ref=nb_sb_noss_1

je ne connais pas DiskWarrior , peut il m'aider à voir un volume invisible ?
Ben non, aucun logiciel ne le détectera puisque le Terminal ne le voit pas.
j'ai bien pensé au démontage pour le tester avec un pc mais windows sera t'il capable de lire ce format ?
Non, pas depuis un PC, il faut installer ce disque dur dans un boîtier USB que tu connecteras à ton iMac. S'il est visible, c'est ton caddie le problème.
 

ericxt

Membre junior
11 Mai 2020
13
0
49

voila ce que j'ai mis (je sais,il n'est pas adapté), mais c'est un ordi fixe, je ne vois pas ce qui le ferait bouger . Mon disque est fixé au double face scratch,je sais c'est pas top mais je suis certain que ça tient.
de plus, je trouve que la coïncidence avec le débranchement à chaud n'indique pas trop cette piste.
J'ai lu pas mal de sujets ressemblant au mien (je reconnais que je n'ai malheureusement pas tout compris !). J'ai vu qu'il pouvait y avoir des sortes de conflits entre les disques ,l'un prenant le pas sur l'autre (bon,je m'embourbe pas dans les explications,tu vas te moquer de mois sinon !). bref, certains ont pu résoudre leur problème de façon informatique, j'ai donc encore un petit espoir qu'un magicien de ce forum tente un truc ,mais je suis peut être un doux réveur !

J'attends encore un peu,on ne sait jamais !
 

Fichiers joints

  • IMG_20200513_185612.jpg
    IMG_20200513_185612.jpg
    169,5 KB · Affichages: 31

Findor

Chat qui utilise OS X
Club MacG
10 Avril 2019
2 101
276
J'ai quelque chose à dire -->

- au moment de la réinstallation de l'OS > n'aurais-t-il pas effacer complètement le disque (au lieu d'effacer seul le volume ssd mac) ainsi ça aurait provoqué la suppression du volumes ssd interne (?)​
Le volume avait peut-être tout simplement un problème dans son système de fichiers ?
 

ericxt

Membre junior
11 Mai 2020
13
0
49
alors effectivement, c'est tout à fait possible que j'ai fait cette bétise !
c'est grave docteur ? amputation ou on peut faire une greffe ?

par contre,je précise que ce n'est pas le ssd qui merde mais bien l'autre (mais c'est peut être lié...)
 

Findor

Chat qui utilise OS X
Club MacG
10 Avril 2019
2 101
276
Oui : si tu tiens à tes données... c'est grave.

Ton volume n'existe plus. Je pense que tu sais ce que sa signifie (?)

- d'après moi : aucun moyen de récupérer tes données.​
 

ericxt

Membre junior
11 Mai 2020
13
0
49
le volume n'existe plus,je pense comprendre, c'est l'espace attribué sur un disque ?
mais le disque lui,il n'a pas disparu quand même ?? il doit bien y avoir moyen de le faire réapparaître ou de créer un autre volume ? sauf si c'est un problème de nappe, et si tout le monde se range à cet avis,je sortirai le tournevis,c'est pas un problème.
les données, je les ai à 95% sur une sauvegarde, je veux juste voir apparaître mon disque et bénéficier de mon espace de stockage.
 

Findor

Chat qui utilise OS X
Club MacG
10 Avril 2019
2 101
276
Ah :hilarious:. Suis-je bête.

Tu veux attribuer un nouveau volume vierge sur ton disque ? combien de Go ? - je te fourni une commande magique pour ce désir.
 

ericxt

Membre junior
11 Mai 2020
13
0
49
j'ai pas dit que je voulais,je demande si c'est possible....
tu as été le premier à gentiment me répondre en me demandant si je pouvais réouvrir la session. En bon newbie que je suis ,j'ai interprété que tu avais peut être une piste. Si ce n'est pas possible, il faut le dire directement (je pense que mon exposé était clair sur mon problème), inutile de se foutre de moi...
Je vais donc démonter le disque et le brancher en externe voir s'il est reconnu.
Merci pour vos interventions.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
35 753
4 316
Je vais donc démonter le disque et le brancher en externe voir s'il est reconnu.
Oh il sera très bien reconnu, parce que ta photo est assez parlante et tu as tout faux. La sonde ne doit pas être collée sur le disque dur de 1 To, il ne contient pas la version de macOS en cours ! C'est masOS qui gère la vitesse du ventilateur en fonction de la température du disque dur le contenant. Il n'y a pas de sonde de température pour le SuperDrive qui a été remplacé par le disque dur de 1 To. Elle doit-être collée sur le SSD Crucial au plus près du connecteur de données.

IMG_20200513_185612.jpg

Ton montage, c'est un château de carte, le support dans le support, alors que tu n'avais même pas besoin de quoi que ce soit. Dans mon iMac de 2011, j'ai réutilisé le support d'origine en ayant tout bêtement mis un bout de scotch double face (encadré en rouge)...

image-3.jpg image-4.jpg

...et comme tu le vois, c'était devenu très aéré avec une baisse significative de 10°.