• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

DVDStudioPro : menu animé : problème de couleur

JeromeC286

Membre junior
22 Août 2004
29
0
Bonjour,

Je suis en train de créer un DVD avec DVDStudioPro 3 et je rencontre un petit problème de détail, mais qui me gène.

Je cherche à faire la chose suivante : je veux qu'une animation aie lieu pour l'apparition du menu principal. Une fois l'animation finie (et pas avant), l'utilisateur pour naviguer dans le menu.

J'ai tout d'abord essayé de mettre l'animation comme arrière-plan du menu, puis de dire qu'à l'issue de l'anim, il faut faire une image fixe. Mais, ce qui me gêne, c'est que pendant la durée de l'anim, on voit déjà les boutons et l'utilisateur peut déjà les sélectionner. D'autre part, la musique de fond du menu s'arrête dès que l'animation est terminée (alors que la musique est censée durer plus longtemps).

Face à ces problèmes, j'ai choisi la solution suivante : le premier titre à lire pour le DVD n'est pas le menu, mais une piste vidéo, qui contient mon animation. Puis, à l'issue de cette piste, je passe au menu, qui possède une image fixe, correspondant à la dernière image de l'animation. C'est là que j'ai un problème : je créé l'image de fond à partir de la dernière image de mon film DV avec Quicktime (exporter vers image), mais l'image que j'obtiens ne possède pas tout à fait les même couleurs que celle de l'animation. Je ne sais pas si c'est lié, mais je constate également que l'image extraite de l'animation à une résolution excellente, alors que l'animation elle-même est de moins bonne qualité (comme s'il manquait une ligne sur deux).

Le problème est donc que ce changement de couleur (très léger) et de qualité d'image est perceptible lors du passage de la piste de d'introduction du menu et le menu en lui-même.

Quelqu'un a-t-il une proposition à me faire pour résoudre ce problème ? Merci !
Jérôme
 

nikolo

Membre d’élite
Club MacG
15 Février 2003
2 003
74
Cela ne serais pas du au reglages de couleurs lors de ton export.

Par exemple , si tu chosi un export en TIff (je suis pas ur mac merci à celui qui peut confirmer ou modifier mes propos), tu as dans les options, un menu où tu choisis le types de couleurs : milliers, optimale, millions, millions + etc...

Regarde si en modifiant cela , tu as une meilleur image.

Car je fais souvent comme toi pour mes montages et j'ai aucune perte de couleur. Tout comme FBS apparement.
 

JeromeC286

Membre junior
22 Août 2004
29
0
Tout d'abord, merci d'avoir confirmé que ma méthode est la bonne, je me demandais si quelque chose m'échappais au niveau de DVD Studio Pro.

J'ai essayé d'exporter dans plusieurs formats, en vérifiant que la qualité soit optimale (lorsque disponible) et que les couleurs soient en milliers+ (lorsque disponible). J'obtiens toujours le même résultat :

Voici un capture de l'image de la vidéo :


et le résultat une fois l'image exportée :


Vous constaterez une légère différence au niveau de la couleur de fond. De plus, lors du passage de la piste au menu, on voit clairement le changement de qualité des textes.

D'autres idées ?
Jérôme
 

nikolo

Membre d’élite
Club MacG
15 Février 2003
2 003
74
Evite le Jpeg qui est un format tres compréssé.

Perso , je prefere la couleur de ton export (plus chaude) que celle de ton montage sur lequel on voit un voile gris dessus .

Préfére le TIff moins destructeur.

Et fais nous une capture de ton resultat.
 

JeromeC286

Membre junior
22 Août 2004
29
0
Décidément, tout cela est bien mystérieux. J'ai essayé le Tiff, mais le problème subsiste. En fait, la couleur obtenue avec le Tiff est la même que celle obtenue en BMP ou PCT, mais reste différente de celle de l'animation.

Jérôme
 

JeromeC286

Membre junior
22 Août 2004
29
0
Non : j'exporte le film depuis FCP comme séquence Quicktime, puis ouvre la vidéo avec Quicktime et utilise la fonction Export de QT.

A première vue, depuis FCP, je ne parviens pas à exporter une image unique d'une séquence. Est-ce possible ?

Jérôme
 

Zdenek

Membre confirmé
20 Janvier 2002
164
0
Suisse, au pied des Alpes
Jerôme
essaie ceci (je viens de faire un test et n'observe aucune différence de qualité entre les 2 images):

- ouvre ta séquence dans QT (pro) à l'endroit de la dernière image
- menu: fichier - exporter
- tab exporter: séquence vers image
- tab options: réglage de compression - sans - Ok (l'étendu de la palette couleurs est à ce moment identique à l'original)
- enregistrer

marche toujours pas ?? :confused:
 

JeromeC286

Membre junior
22 Août 2004
29
0
Finalement, exporter l'image directement depuis FCP (merci FatBossSlim) a résolu le problème : les couleurs sont préservées !

Mais c'est quand même bien dommage que le comportement de QT soit si étrange. Moi qui avait opté pour un Mac pour la vidéo pour sa simplicité et son absence de problèmes (comparé au PC), je déchante un peu !

Merci pour votre aide à tous,
Jérôme
 

Fat Boss Slim

Vétéran
17 Mai 2001
7 786
599
53
Brissac-Quincé
perso.numericable.fr
JeromeC286 a dit:
Moi qui avait opté pour un Mac pour la vidéo pour sa simplicité et son absence de problèmes (comparé au PC), je déchante un peu !
C'est toi qui as compliqué les choses ;)

L'export direct depuis FCP était bien le plus simple... et le plus efficace...

Tu peux continuer à chanter :D


;)