économiseur d'écran complètement déréglé

sconie

Membre d’élite
15 Juillet 2007
1 201
27
Bonjour
Impossible (sous ML 10.8.5) de regler l'economiseur d'écran. Soudainement impossible de selectionner le dossier iPhoto qui a disparu de la selection...
Merci d'avance pour les suggestions :)
iPhoto reste gris.
 
Dernière édition:

boninmi

Membre d’élite
Club MacG
4 Avril 2008
4 590
2 326
Ardèche
Tu as fait un entretien genre Onyx (réparation des permissions du disque) ?
Impossible de sélectionner, donc éventuellement de supprimer et remettre iPhoto, je suppose.
As-tu testé le fonctionnement dans une autre session utilisateur (à créer au besoin) ?

Il pourrait y avoir un fichier de préférences corrompu, je vois les fichiers:

com.apple.screensaver.mobilemegallery.plist
com.apple.screensaver.plist

peut-être.

Il faut les localiser (je suis sous 10.7, sous 10.8 c'est peut-être différent). Chez moi il sont dans

Maison -> Bibliothèque -> Preferences

Pour accéder à Bibliothèque qui est un fichier caché, utilise le menu

Finder -> Aller en appuyant sur la touche alt.

Il faut alors faire glisser (en attente) sur le bureau les fichiers suspects, quitter et relancer la session, re tester l'économiseur.
 

dakar

Membre émérite
28 Mars 2001
755
18
Marseille
Bonjour, Boninmi, je lis avec intéret ta réponse, vu que je suis aussi sur Lion 10.7 et que j'ai exactement le même problème : mon Economiseur d'écran, et mon Bureau (onglets dans Préférences) affichent tous les deux Iphoto et Dossier, en noir. Quand je clique sur Bureau, les deux affichent les images contenues dedans, quand je clique sur Economiseur d'écran, il n'y a plus que iPhoto qui s'affiche. Pas le Dossier.
Mais le problème que je n'arrive pas à régler, c'est qu'il est impossible de sélectionner les images dans iPhoto, et dans Dossier, et de les supprimer ensuite. Je sélectionne une image : le tiret Moins reste gris..et l'image reste.
Dans l'Aide Mac, on dit qu'on peut le faire, mais ce n'est pas vrai, ça ne marche pas chez moi ; par conséquent, j'ai besoin de l'aide de quelqu'un qui pourrait me dire comment faire.
De plus, cette Library d'IPhoto, je ne comprends pas comment elle a pu arriver là, plutôt qu'une autre, j'en ai 10…Et je ne me souviens pas de l'avoir mise là…Je voudrais l'enlever , pas moyen. Et toutes les images restent dedans...

Et enfin, oui, j'ai fait il y a quelque temps un nettoyage Onyx, avec réparation des permissions du disque : Quel serait le rapport avec mon problème ?
J'ai fait la manoeuvre indiquée, de sortir le fichier screensaver.plist, et de relancer, mais c'est pareil, sauf que maintenant je ne vois pas de nouveau fichier screensaver.plist dans les Préférences de la Bibliothèque…pas même en ayant relancé l'Economiseur : faut-il le remettre à sa place ? je croyais que quand on relance une appli, le fichier.plist se refait tout seul !...
Merci si tu pouvais, ou quelqu'un d'autre, m'aider à régler le problème.
 

boninmi

Membre d’élite
Club MacG
4 Avril 2008
4 590
2 326
Ardèche
A y réfléchir, je me demande s'il n'y a pas là un vieux bug, non résolu ... J'ai un peu la flemme de faire une recherche là dessus, mais il me semble que le bouton "-" reste gris, pour une raison inexpliquée, et Apple n'a pas souhaité améliorer ce fonctionnement. Néanmoins, le bug de sconie semble différent. Si j'ai compris, elle ne peut plus sélectionner iPhoto.
 

dakar

Membre émérite
28 Mars 2001
755
18
Marseille
Eh bien, tu n'es pas encourageant !…mais alors, je comprendrais pourquoi ce truc ne marche pas…penses-tu qu'avec Mountain Lion, je n'aurais plus ce problème ?
Tu ne m'as pas expliqué ce truc d'Onyx, à quoi tu pensais ?

D'ailleurs, j' ai un autre problème, aussi inexplicable, dont j'ai déjà parlé ici, sans trouver d'aide : quand je mets le Mac en suspension d'activité, ou quand il s'y met lui-même, après une heure de suspension à la reprise en cliquant sur une touche, voilà qu'un Bureau complètement incongru s'affiche : un quart Nord-Est est recouvert par un écran gris avec la pomme au milieu, et si je m'avise de bouger ma souris, elle trace un beau chemin noir épais sur le Bureau.. et en bas de cet écran gris, un petit onglet me demande mon nom, puis ensuite mon mot de passe, et si ensuite je clique OK le Bureau redevient comme il doit l'être…!!!
je n'arrive pas à comprendre pourquoi. Si quelqu'un le sait….
 

sconie

Membre d’élite
15 Juillet 2007
1 201
27
bon... tout est revenu apparemment sans que je n'y ai rien fait. Par ailleurs, je n'utilise jamais Onyx. C'est peut-être la mise à jour du passage à 10.8.5 qui a un moment tout déréglé. Quand j'ai ouvert mon iPhoto une fenêtre s'est ouverte disant que la photothèque etait endommagée et que si je desirais qu'elle soit retablie j'aicliqué oui et tout s'est fait tout seul...
 

boninmi

Membre d’élite
Club MacG
4 Avril 2008
4 590
2 326
Ardèche
Eh bien, tu n'es pas encourageant !…mais alors, je comprendrais pourquoi ce truc ne marche pas…penses-tu qu'avec Mountain Lion, je n'aurais plus ce problème ?
Tu ne m'as pas expliqué ce truc d'Onyx, à quoi tu pensais ?

D'ailleurs, j' ai un autre problème, aussi inexplicable, dont j'ai déjà parlé ici, sans trouver d'aide : quand je mets le Mac en suspension d'activité, ou quand il s'y met lui-même, après une heure de suspension à la reprise en cliquant sur une touche, voilà qu'un Bureau complètement incongru s'affiche : un quart Nord-Est est recouvert par un écran gris avec la pomme au milieu, et si je m'avise de bouger ma souris, elle trace un beau chemin noir épais sur le Bureau.. et en bas de cet écran gris, un petit onglet me demande mon nom, puis ensuite mon mot de passe, et si ensuite je clique OK le Bureau redevient comme il doit l'être…!!!
je n'arrive pas à comprendre pourquoi. Si quelqu'un le sait….
- Je ne sais pas si ML a pris en compte le problème (je reste à Lion, voir ici)
- Onyx est un logiciel de maintenance du système, voir ce lien. Mais tu peux aussi faire une réparation des permissions du disque via Utilitaire de Disque.
- Ton autre problème est très bizarre, tu pourrais poster séparément (si ce n'est fait) et déjà tenter une réparation des permissions du disque.

bon... tout est revenu apparemment sans que je n'y ai rien fait. Par ailleurs, je n'utilise jamais Onyx. C'est peut-être la mise à jour du passage à 10.8.5 qui a un moment tout déréglé. Quand j'ai ouvert mon iPhoto une fenêtre s'est ouverte disant que la photothèque etait endommagée et que si je desirais qu'elle soit retablie j'aicliqué oui et tout s'est fait tout seul...

OK, visiblement ton problème personnel était lié à ce problème iPhoto. Avant et après une mise à jour système une réparation des permissions du disque est également conseillée, Utilitaire de Disque le fait.
 

dakar

Membre émérite
28 Mars 2001
755
18
Marseille
Oui Boninmi j'ai fait par Utilitaire, la réparation des permissions (il y avait un tas d'erreurs, toutes provennt d'iTunes !) et j'ai vérifié le disque : RAS.

---------- Nouveau message ajouté à 20h03 ---------- Le message précédent a été envoyé à 19h47 ----------

Mais comment se fait-il que je n'arrive pas à enlever de iPhoto, dans Préférences Economiseur d'écran, toutes les photos que je ne veux pas y voir ??? Je peux en ajouter mais pas en enlever…!

Pour mon autre problème, voilà ce qui se passe : j'ai porté mon iMac au représentant local de Apple, en parlant de la garantie Consommateur de 2 ans de Apple , et là, on a fait un changement de la carte video, au vu de la photo d'écran que j'avais apportée, et aussi un changement de la carte logique. Donc, de retour chez moi, ça a marché un jour, et le lendemain, rebelote, de nouveau cet écran masqué au quart, et pourtant l'Imac marche très bien, quand il accepte de me mettre mon Bureau habituel…Je les ai appelés, et on me dit qu'on va "inspecter l'imac à fond", mais j'ai l'impression qu'ils flottent…Peut-être est-ce un bug, et qu'il n'y a rien à faire pour le corriger, mais quand même, un bug qui ne se manifeste qu'après 15 mois d'utilisation normale, ça me semble pas très possible ?
je voudrais bien mettre la photo sur ce forum, peut-être que quelqu'un a eu le même problème et pourrait m'éclairer, mais je vois en bas de la page qu'on ne peut pas envoyer des P.J. …je vais quand même essayer !
Remarque, l'Imac marche bien à part ça, je pourrais continuer comme ça, mais je me demande si ce n'est pas le prélude à quelque chose de plus grave, et s'il ne faudrait pas en effet inspecter l'Imac à fond ??...
 

boninmi

Membre d’élite
Club MacG
4 Avril 2008
4 590
2 326
Ardèche
Pour le bug de Préférences Economiseur d'écran, je n'ai rien à ajouter à ce que j'ai dit plus haut, sauf plus ample informé, je penche pour un vieux bug Apple non résolu.

Pour ce qui est de ton autre bug, dont effectivement il n'est pas clair de savoir s'il est matériel, logiciel, ou micro logiciel, tiens bon avec le SAV Apple jusqu'à ce qu'ils aient résolu le problème, quitte à faire preuve de patience. Dans toute production il peut y avoir des ratés, il vaut mieux dans ton cas qu'il se soit produit au bout de 15 mois plutôt que de 25 ... Un composant défectueux peut lâcher aussi bien au bout de 15 jours que de trois ans ... Cela arrive aussi bien pour des machines à laver (mon lave vaisselle, un œil électronique, au bout d'un an), des voitures, que des ordinateurs, même en général de bonne qualité.

Retourne au SAV, mais non sans avoir fait avant une sauvegarde de ton disque sur support externe, si ce n'est déjà fait. S'il y a un problème matériel, il faut toujours se méfier d'un risque de perte de données.

Pour poster des photos sur le forum, vois ici:

Forum Mac - Annonces dans le forum : Portfolio
 

dakar

Membre émérite
28 Mars 2001
755
18
Marseille
eh bien Boninmi, tu es de bon conseil . Je viens de créer un compte invité, et ayant ouvert sa session, dans les Préférences système, Bureau et Economiseur d'écran, tout est différent de ce que je trouve sur ma session d'administrateur !
Dans l'onglet Bureau, je trouve Image (d'Apple) et Dossier, VIDE. Pas de trace d'iPhoto ni de ma Library qui s'y trouve sur mon compte. Dans l'onglet Economiseur d'écran, il y a des images Apple, et pas les miennes…

Alors , là, peux-tu me dire si je peux créer un second compte Administrateur, et enlever ensuite le premier ? je n'ai jamais fait ça encore.. je ne peux pas me servir uniquement, à l'avenir, de ce compte Invité !! c'est pourquoi je pense que l'on peut créer un second compte Administrateur, mais comment ??
Merci, si tu peux m'aider à le faire...

Je me demande d'ailleurs maintenant si mon problème d'affichage sidérant ne viendrait pas de ce bug sur l'onglet Bureau… je vais vérifier , en passant sur la session Invité, si ça arrive aussi avec cette session…
je donnerai la suite , si jamais quelqu'un a le même problème...
 

ergu

passant qui passe
Club MacG
13 Octobre 2011
2 728
614
27
Dans l'onglet Bureau, je trouve Image (d'Apple) et Dossier, VIDE. Pas de trace d'iPhoto ni de ma Library qui s'y trouve sur mon compte. Dans l'onglet Economiseur d'écran, il y a des images Apple, et pas les miennes…

Normal.
Chaque session a sa propre library iPhoto - donc nouvelle session = library vide.

Alors , là, peux-tu me dire si je peux créer un second compte Administrateur, et enlever ensuite le premier ?

Oui - quand tu crées un compte, tu as la possibilité de le rendre admin.
Et, tant qu'il te reste au moins un compte admin, tu peux supprimer tous les autres.

Attention, si tu supprimes ton premier compte admin, tu risques de supprimer avec toutes les données qui y sont particulières, y compris tes photos...
 

dakar

Membre émérite
28 Mars 2001
755
18
Marseille
merci, Ergu, j'ai créé un second compte Administrateur, et en allant dessus, je vois que dans Préférences, Bureau, et Economiseur d'écran, il n'y a que les images d'Apple, ce qui me semble normal.

Je vais essayer de laisser l'Imac en suspension d'activité plusieurs heures sur ce second compte, et à la reprise d'activité, je verrai bien si là aussi, l'écran s'affiche n'importe comment ; si oui, il y a un problème DANS l'imac, et si non, je resterai sur ce second compte ; mais alors, pourrais-je y importer tout mon dossier Utilisateur que j'ai sur Time Machine dans un DD externe ? ce qui éviterait que je perde tout…Dans l'aide Mac, on ne parle pas de cela, donc je voudrais des précisions ...
un grand merci
 

ergu

passant qui passe
Club MacG
13 Octobre 2011
2 728
614
27
, pourrais-je y importer tout mon dossier Utilisateur que j'ai sur Time Machine dans un DD externe ?

Normalement, oui.
Bien sûr, teste et assure-toi d'avoir tout récupéré avant d'effacer ta session admin de base...

---------- Nouveau message ajouté à 14h22 ---------- Le message précédent a été envoyé à 14h05 ----------

je voudrais bien mettre la photo sur ce forum


Ce tutoriel date un peu, mais ça devrait te permettre de nous montrer une photo de ton problème.
 

dakar

Membre émérite
28 Mars 2001
755
18
Marseille
bon, pas possible de trouver le moyen, la FAQ ne correspond à rien, car une fois que j'ai envoyé ma photo dans un album, nulle part je ne vois le moyen de la joindre à un post. La FAQ parle de bouton Gérer les pièces jointes, de bouton en forme de trombone, etc… et d'ajouter une image dans un message par le moyen de cliquer sur une flèche vers le bas dans l'éditeur du message, mais pas de flèche visible ni de trombone…et tout à l'avenant.
C'est consternant.
Ou je ne comprends plus le français, ou la page de la FAQ ne correspond plus à ce que je vois, ou il existe ailleurs sur le Forum une explication utile.

---------- Nouveau message ajouté à 19h45 ---------- Le message précédent a été envoyé à 19h42 ----------

et il n'y a plus de "galerie"…donc ton lien ne peut pas marcher…..c'est bien dommage, la photo de mon écran vaut le coup d'oeil...
 

dakar

Membre émérite
28 Mars 2001
755
18
Marseille
voila le lien pour voir mon bel écran nouveau style…
si quelqu'un a déjà vu ça et peut me dire ce qu'il faut faire pour qu'il redevienne un honnête écran IMac !

photo-ecran - Hébergement d'image - Casimages

---------- Nouveau message ajouté à 17h04 ---------- Le message précédent a été envoyé à 16h54 ----------

le gros trait gris qui rature le Bureau , je l'ai fait pour bien montrer la trace que fait le pointeur quand je promène ma souris pour aller sur Pomme , Redémarrer, par exemple...
 

boninmi

Membre d’élite
Club MacG
4 Avril 2008
4 590
2 326
Ardèche
J'étais absent quelques jours. Vraisemblablement, tu as un problème matériel, ou au mieux un problème d'EFI (micro logiciel). Tu as fait toutes les mises à jour proposées via "Mise à jour de logiciel" ? Une mise à jour d'EFI t'a-t-elle été éventuellement proposée ? A mon avis il te faut retourner à ton SAV agréé Apple ou mieux peut-être joindre par téléphone (voir le site d'Apple) le SAV d'Apple. Munis toi de façon précise des références de ton iMac, numéro se série, type de la carte graphique, etc (tu trouve ça dans le menu Pomme -> A propos de ce Mac -> Plus d'info) et ne les lâche pas avant qu'ils aient résolu ton problème.
 

dakar

Membre émérite
28 Mars 2001
755
18
Marseille
bonjour, non, on ne m'a jamais proposé de MAJ EFI, d'ailleurs je n'en ai jamais entendu parler sur mon Imac.. ??
j'ai fait ttes les mises à jour proposées sauf celles où on parle de Mavericks ou de logiciels que je n'ai pas sur l'Imac.

J'ai créé un nouveau Compte administrateur, qui s'ouvre bien, et jusqu'ici n'a pas affiché d'écran anormal, et bien sûr, dans les réglages Bureau et Economiseur, il n'y a que les images fournies par Apple ; donc je me demande su le problème ne viendrait pas des images que j'y ai incluses. Aussi, je voudrais savoir comment faire pour , rapatriant ma sauvegarde T.M. sur ce nouveau compte, ne pas y rapatrier aussi mes réglages de Préférences, Bureau, Economiseur d'écran.
Parce que ainsi, il n'y aurait que les images fournies par Apple, et pas celles que j'y ai incluses, d'où viennentt peut-être mon problème d'affichage...Peut-être comme cela, le problème serait réglé ?

QUand j'ai réinstallé le système la première fois, bien sûr j'ai ensuite récupéré tout ™ et l'ai installé, et le problème a recommencé ; je pense qu'il faudrait ne récupérer que tout mon dossier personnel ; seulement, dans ce dossier, il y a Bibliothèque, dans laquelle il y a probablement aussi mes réglages..

Donc, peut-on exclure d'une sauvegarde ™ tous les réglages appelés Préférences, avant de la récupérer sur mon nouveau compte Administrateur, quitte à ensuite refaire ceux que je veux ?
Si oui, comment faire ?

Merci beaucoup pour l'aide que tu essaies de m'apporter..
 

boninmi

Membre d’élite
Club MacG
4 Avril 2008
4 590
2 326
Ardèche
Si c'est un problème logiciel, il paraît très bizarre ... J'essaie de tout bien comprendre, comme la discussion a été complexe:
- le moment du bug est à la sortie de veille ?
- l'image affichée aux trois quarts par ton iMac au moment du bug est-elle une image Apple ou une image personnelle ?
- d'où provient-elle ? Si elle vient de iPhoto, que se passe-t-il si tu la supprime de iPhoto (quitte à l'exporter ailleurs avant) ?
- que se passe-t-il si tu sélectionnes une autre image ?

Si ça vient du dossier Préférences (ce qui reste à prouver), plutôt que de réimporter une sauvegarde TM dans un nouveau compte administrateur, il est peut-être plus facile de faire glisser ton dossier de Préférences du compte qui pose problème sur le bureau, et de regarder ce que ça donne, quitte à remettre en place ensuite les Préférences qui te manqueraient vraiment.

Tu peux je pense exclure des dossiers de la restauration TM, tu peux me semble-t-il dire quels dossiers tu veux restaurer. Si tu as des problèmes là-dessus (je n'ai pas énormément de lumières sur le sujet), il y a un sujet dédié TM sur le forum.
 

dakar

Membre émérite
28 Mars 2001
755
18
Marseille
Merci pour ta réponse.
-c'est à la "reprise d'activité" que le bug se produit, quand j'appuie sur une touche du clavier pour repartir, le bureau s'affiche comme sur la photo ; j'ai essayé les deux façons, soit en laissant l'Imac se mettre en suspension d'activité tout seul , soit en le mettant moi-même en passant par Pomme, Suspension d'activité. Les deux fois, ça fait le bug. Je dois donc éteindre le Mac en appuyant sur la touche au dos , sinon en dirigeant la souris vers le menu Pomme, pour l'éteindre, tu as vu la trace que cela fait. Mais en l'allumant, ou en le re-allumant avec la touche au dos, le bureau s'affiche normal ;
Je ne comprends pas si c'est la reprise d'activité, ou le rallumage que tu veux dire en parlant de "sortie de veille"…cela concerne le re-allumage, ou la sortie de la suspension d'activité?

-l'image grise avec une pomme affichée aux 3/4 , apparait toute seule, je n'y suis pour rien, j'ai l'impression que c'est là le problème, car il me semble que c'est un morceau de l'écran gris que l'on voit apparaitre, au moment de l'allumage duMac, tu ne crois pas ?
Elle ne vient pas d'Iphoto, ni de mes images personnelles.
Cependant ce qui est bizarre, c'est qu'avec l'allumage du Mac par le bouton au dos, le Bureau est normal. Cela ne se produit qu'avec la reprise d'activité.

-Avant ce bug, j'avais mis des images personnelles dans un dossier, avec celles d'Apple, dans les Préférences , Bureau, et elles apparaissaient . Depuis ce bug, j'ai beau essayer de le remettre , le dossier de mes images ne rentre pas avec celles d'Apple ;
et de plus, il y a une des Libraries de mon Iphoto qui y est, (je ne me souviens pas de l'y avoir mise !..) et il est impossible de l'effacer, le petit "-" reste gris. Et ses images s'affichent bien sur le Bureau !…

-faire glisser TOUT le dossier des Préférences sur mon bureau ? c'est bien ça que tu dis ? je veux bien essayer, mais ça ne va pas faire bloquer le Mac ? veux-tu me confirmer que j'ai bien compris ?

-Merci, je vais aussi aller voir en effet sur le forum ™ pour voir si on peut exclure des dossiers d'une restauration.
-Je voudrais restaurer tout mon dossier Utilisateur, SAUF les Préférences !…si je restaure tout, le bug va recommencer ! donc il faudrait que je restaure peu à peu tout le dossier Utilisateurs, sans les Préférences , je suppose.
Merci...

---------- Nouveau message ajouté à 16h11 ---------- Le message précédent a été envoyé à 14h55 ----------

je reviens pour te demander de quel dossier Préférences tu pzrles ? j'ai une Application Préférences dans les App et celui là, on ne peut pas le déplacer, seulement le copier sur le Bureau ; que je lance cette copie, ou l'Application, c'est toujours le même panneau des Préférences qui s'affiche. Rian de changé ; il y a aussi un dossier Préférences dans la Bibliothèque de ma maison ; est-ce celui - là ?
 

boninmi

Membre d’élite
Club MacG
4 Avril 2008
4 590
2 326
Ardèche
- par "sortie de veille", je voulais bien dire "reprise d'activité", pas réallumage
- par "image affichée au trois quarts", je ne voulais pas dire l'image grise, mais le reste (le ciel étoilé). Il me semble que c'est une image Apple. As-tu essayé ce que ça donne en choisissant une autre image ?
- s'agissant semble-t-il d'un problème lié à la session (au compte utilisateur), je parle toujours comme au début de la discussion du dossier de Préférences dans:
Maison -> Bibliothèque
Je voulais bien dire tenter de faire glisser tout ce dossier sur le bureau, si c'est accepté par le système, puis relancer la session. En principe, cela ne devrait pas bloquer le Mac, et tu devrais pouvoir revenir à l'état antérieur si nécessaire par la manœuvre inverse ou une restauration Time Machine. Tu peux aussi y aller plus doucement, en ne faisant glisser sur le bureau que les fichiers plist qui pourraient être en cause, mais je ne vois rien de relatif à la reprise d'activité, il faut peut-être chercher ailleurs que dans ce dossier, mais là je ne sais pas. Tu as peut-être tout de même besoin du SAV Apple, ou d'une recherche plus approfondie sur le net (discussions officielles anglophones Apple ?). J'avoue que là, je coince un peu.

---------- Nouveau message ajouté à 17h43 ---------- Le message précédent a été envoyé à 17h03 ----------

une fois que j'ai envoyé ma photo dans un album, nulle part je ne vois le moyen de la joindre à un post.
Tu as un bouton Image (le sixième à partir de la droite dans la deuxième ligne de boutons de la fenêtre d'édition de message). Ou même, quand l'image est affichée dans ton album, tu recopies la balise BB qui est en dessous de l'image.

L'image dont je parle (celle qui ne s'affiche qu'aux trois quarts) est située chez moi dans:

Macintosh HD -> Bibliothèque -> Desktop Pictures -> Andromeda Galaxy.jpg

Commence par regarder ce que ça donne si tu fais glisser cette image sur le bureau et que tu relances la session.

Cette discussion pourrait t'être utile:

http://forums.macg.co/mac-os-x/comportement-fond-ecran-etrange-810592.html
 
Dernière édition: