Écran bleu bloqué lors du démarrage du Mac (OS X 10.5)

kreator

Membre junior
5 Août 2013
19
0
29
Bonsoir tout le monde ! Et bonne année, bonne santé à vous !

Avant de poster mon problème ici, j'ai chercher partout sur le net pour résoudre mon problème mais rien n'y fait...

J'ai vue que ce forum à l'air d'être un forum sérieux, c'est pour cela que je poste mon problème ici.


Pour commencer, je possède un mac os 10.5 qui doit avoir au moins 7 ou 8 ans.


Voici le problème:


Mon mac fonctionnait très bien, jusqu'au jour ou il a commencer a figer en pleine activité dans ma session mac, même si je laissait mon mac inactif sur ma session, il trouvais le moyen de rester bloqué. Le clavier et la souris ne répondaient plus, j'ai donc dû l'arrêter via le bouton d'arrêt. (Ce problème persistait à chaque fois que j'allais sur mon mac).


Quelques jours plus tard, encore mieux ! Je ne peut même plus me connecter à ma session ! Quand j'allume mon mac, j'ai le "Boing" et l'écran gris qui s'affiche pendant 2 ou 3 secondes jusqu'ici rien d'anormal. Mais après j'ai la pomme qui s'affiche avec comme un damier à l'intérieur de la pomme, puis la je tombe sur un écran bleu avec le pointeur de ma souris qui reste bloqué en haut à gauche de l'écran pendant un temps indéfini. Je peut juste bouger ma souris, je vois mon curseur se déplacer, mais j'ai un autre curseur qui reste bloqué en haut à gauche de l'écran, et l'écran reste bleu.



J'ai donc effectué les manip que le support apple propose, mais rien n'y fait. J'avais également réinstaller mac os depuis son CD, ce qui m'avais permis de pouvoir me reconnecter de nouveau à ma session, mais le problème a aussitôt recommencer au bout d'une vingtaine de minutes.

Puis aujourd'hui, je ne peut même plus démarrer mon mac depuis un CD, quand j'appuis sur la touche C au démarrage ou ALT ça ignore mon CD et ça reste sur l'écran bleu après le chargement de la pomme.

Je suis donc obligé d'utilisé mon mac sous le mode "sans extension" qui fonctionne très bien, pas de bug...


Je ne sais pas si ce problème viens du matériel ou pas...ou un simple bug du os...


Voila mon problème, j'accepte toutes vos aides


Merci d'avance
 

Arlequin

Membre masqué
Club MacG
4 Août 2004
12 229
989
DTC
hello

quel mac as tu ?

toujours le disque dur d'origine ?

J'ai vue que ce forum à l'air d'être un forum sérieux, c'est pour cela que je poste mon problème ici.

doucement avec le cirage stp :D


ps: pense mettre ton profil à jour (actuellement pc/seven) ;)
 

kreator

Membre junior
5 Août 2013
19
0
29
hello

quel mac as tu ?

toujours le disque dur d'origine ?



doucement avec le cirage stp :D


ps: pense mettre ton profil à jour (actuellement pc/seven) ;)


Salut,

c'est un imac os 10.5.8 léopard 20 pouce, oui le disque dur toujours d'origine, mais lors de la réparation du disque dur via l'utilitaire je n'est pas eu de message pour dire qu'il était endommagé.
 

Breizh44

Membre émérite
13 Octobre 2011
805
29
28
Nantes
Carte mere ou dd.
Je pencherai pour la carte.
 

kreator

Membre junior
5 Août 2013
19
0
29
Re bonjour,


Je viens tout juste de faire une vidéo du problème de mon mac, pour que vous puissiez bien voir ce qu'il a.


[YOUTUBE]Ecran bleu démarrage mac - YouTube[/YOUTUBE]


Si la vidéo n'est pas visible sur le forum, voici le lien: Ecran bleu démarrage mac - YouTube


Comme vous pouvez le voir sur la vidéo, lors de l'allumage du mac après le chargement de la pomme, le mac reste bloqué sur un écran bleu avec 1 pointeur de souris figer en haut à gauche et le pointeur de ma souris en rosace multicolore.

Et ce freeze dur pendant un temps infini...
 
Dernière édition:

Mac*Gyver

Membre d’élite
Club MacG
28 Novembre 2008
1 541
55
bon ben j'ai eu la meme chose exactement hier sur mon mini.

J'ai fait un demarrage sans extensions (demarre en tenant la touche shift enfoncée) et ca s'est arrangé tout seul par la suite.
Tu peux essayer.

Perso j'ai pas encore trouvé la source du probleme (hard ou soft) mais au moins il tourne.
(merci a Arlequin en passant qui m'a bien aidé)
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
85 347
25 733
Forêt de Fontainebleau
Salut kreator.

«E pur si muove!» (et pourtant elle tourne - la roulette...) :D

<Je m'aperçois que Mac*Gyver - que je salue :coucou: - vient de publier un message pendant que je m'échinais sur mon brouillon. Essaye sa méthode de démarrage sans extensions pour voir si tu parviens à lancer ta session. Je poste quand même le produit de mes élucubrations vespérales...>


&#9758; D'après la vidéo, le lancement paraît se dérouler correctement (sans signaux d'échec) pendant les 3 premières séquences :​


  1. POST (Power-On Self-Test) : le check-up hardware effectué par la ROM de démarrage (dite : EFI) qui signale son succès par le retentissement du Carillon (dit 'Chime'). Sur ton iMac, le 'Chime' retentit haut et clair.

  2. Boot_Loader : l'exécution par l'EFI du fichier 'starter' de l'OS (le boot.efi des 'CoreServices') dont la tâche principale consiste à charger le noyau ('kernel') et les extensions du noyau ('kexts'). Le travail du Boot_Loader se signale à l'écran par le logo 'Pomme' solitaire. Apparemment tout est normal : le changement d'affichage d'écran (=> passage à la roue crantée giratoire sans signal de détresse) exprime que le kernel et les kexts se sont chargés normalement.

  3. Kernel : le noyau a pris la main et charge les infrastructures logicielles de l'OS : le BSD_UNIX ou sous-bassement Unix de OSX. Cette tâche se signale à l'écran par une roue crantée giratoire affichée sous le logo 'Pomme'. Le fait que l'écran ne reste pas figé sur cet affichage, mais change au bout d'un temps réglementaire d'environ 11" (que cela allait vite sous «Léopard» si on compare à «Mavericks»! - incroyable...) pour céder la place à un écran bleu - signale que le kernel n'a pas rencontré de difficultés dans la complétion de cette tâche. L'OS doit être en place dans ses fondations à ce moment-là.


    &#10058;​

    &#9758; Par contre, le lancement paraît planter dans sa 4è séquence :​

  4. Launchd : il s'agit du processus 'parent' (le 1er_né des processus extra-kernel qui, en cette qualité, est le 'père' de tous les autres processus qui sont ses 'fils' - càd. leur 'kreator' si tu préfères :D). Sa tâche est de charger les 'super-structures' logicielles d'OSX jusqu'à ce que le processus de la LoginWindow charge l'écran d'ouverture de session (lequel précède l'affichage de l'espace graphique d'utilisateur).

    Apparemment, le launchd exécute sa mission sans entraves jusqu'au moment de l'affichage graphique du pointeur (lequel précède normalement - sous «Léopard» - du temps d'un 'battement de cil' l'affichage de la LoginWindow). C'est là manifestement qu'il y a plantage : le processus 'Login Window' ne démarre pas, car antérieurement le responsable de l'affichage graphique du pointeur se fait des n&#339;uds.


    &#10051;

C'est donc ton 'homonyme' (le processus 'kreator') qui connaît un coup de mou dans le final de sa tâche 'procréatrice' de ses nombreux fils (je ne devrais pas mais c'est plus fort que moi :D).


Je pense à partir de là que tu es renvoyé à des procédures de dépannage classiques :

  • démarrage en 'single user' mode, ce qui te permet de passer la commande : fsck -fy pour réparer ton logiciel => regarde &#9758;ici&#9756; (clique sur le 'ici' bleu), en déroulant la page de OSX facile jusqu'à la rubrique voulue qui t'indique comment procéder => tenter de re-démarrer ensuite.

  • démarrage sur ton DVD d'install (gris) de «Léopard 10.5» sur lequel l'outil : «Utilitaire de Disque» t'offre l'option de 'réparer le disque' (si c'est possible) à côté de 'réparer les autorisations' => tenter de re-démarrer ensuite.

  • ré-installation de OSX, en démarrant sur le même DVD d'install et en choisissant l'option : en mise-à-niveau (conservatrice des données) et pas en clean-install (effaceuse du disque).

    &#10048;
 
Dernière édition:

kreator

Membre junior
5 Août 2013
19
0
29
Salut kreator.

«E pur si muove!» (et pourtant elle tourne - la roulette...) :D

<Je m'aperçois que Mac*Gyver - que je salue :coucou: - vient de publier un message pendant que je m'échinais sur mon brouillon. Essaye sa méthode de démarrage sans extensions pour voir si tu parviens à lancer ta session. Je poste quand même le produit de mes élucubrations vespérales...>


&#9758; D'après la vidéo, le lancement paraît se dérouler correctement (sans signaux d'échec) pendant les 3 premières séquences :​


  1. POST (Power-On Self-Test) : le check-up hardware effectué par la ROM de démarrage (dite : EFI) qui signale son succès par le retentissement du Carillon (dit 'Chime'). Sur ton iMac, le 'Chime' retentit haut et clair.

  2. Boot_Loader : l'exécution par l'EFI du fichier 'starter' de l'OS (le boot.efi des 'CoreServices') dont la tâche principale consiste à charger le noyau ('kernel') et les extensions du noyau ('kexts'). Le travail du Boot_Loader se signale à l'écran par le logo 'Pomme' solitaire. Apparemment tout est normal : le changement d'affichage d'écran (=> passage à la roue crantée giratoire sans signal de détresse) exprime que le kernel et les kexts se sont chargés normalement.

  3. Kernel : le noyau a pris la main et charge les infrastructures logicielles de l'OS : le BSD_UNIX ou sous-bassement Unix de OSX. Cette tâche se signale à l'écran par une roue crantée giratoire affichée sous le logo 'Pomme'. Le fait que l'écran ne reste pas figé sur cet affichage, mais change au bout d'un temps réglementaire d'environ 11" (que cela allait vite sous «Léopard» si on compare à «Mavericks»! - incroyable...) pour céder la place à un écran bleu - signale que le kernel n'a pas rencontré de difficultés dans la complétion de cette tâche. L'OS doit être en place dans ses fondations à ce moment-là.


    &#10058;​

    &#9758; Par contre, le lancement paraît planter dans sa 4è séquence :​

  4. Launchd : il s'agit du processus 'parent' (le 1er_né des processus extra-kernel qui, en cette qualité, est le 'père' de tous les autres processus qui sont ses 'fils' - càd. leur 'kreator' si tu préfères :D). Sa tâche est de charger les 'super-structures' logicielles d'OSX jusqu'à ce que le processus de la LoginWindow charge l'écran d'ouverture de session (lequel précède l'affichage de l'espace graphique d'utilisateur).

    Apparemment, le launchd exécute sa mission sans entraves jusqu'au moment de l'affichage graphique du pointeur (lequel précède normalement - sous «Léopard» - du temps d'un 'battement de cil' l'affichage de la LoginWindow). C'est là manifestement qu'il y a plantage : le processus 'Login Window' ne démarre pas, car antérieurement le responsable de l'affichage graphique du pointeur se fait des n&#339;uds.


    &#10051;

C'est donc ton 'homonyme' (le processus 'kreator') qui connaît un coup de mou dans le final de sa tâche 'procréatrice' de ses nombreux fils (je ne devrais pas mais c'est plus fort que moi :D).


Je pense à partir de là que tu es renvoyé à des procédures de dépannage classiques :

  • démarrage en 'single user' mode, ce qui te permet de passer la commande : fsck -fy pour réparer ton logiciel => regarde &#9758;ici&#9756; (clique sur le 'ici' bleu), en déroulant la page de OSX facile jusqu'à la rubrique voulue qui t'indique comment procéder => tenter de re-démarrer ensuite.

  • démarrage sur ton DVD d'install (gris) de «Léopard 10.5» sur lequel l'outil : «Utilitaire de Disque» t'offre l'option de 'réparer le disque' (si c'est possible) à côté de 'réparer les autorisations' => tenter de re-démarrer ensuite.

  • ré-installation de OSX, en démarrant sur le même DVD d'install et en choisissant l'option : en mise-à-niveau (conservatrice des données) et pas en clean-install (effaceuse du disque).

    &#10048;



Salut :)

Merci beaucoup pour vos réponses :D

Je vais essayer de faire la manip que tu m'as dit de faire, cependant le démarrage sans extension je l'ai déjà faite d'ailleurs c'est ma roue de secours pour pouvoir utilisé mon mac :siffle: Mais ça ne marche pour autant...

En ce qui concerne le mode single user avec la commande suivante "fsck -fy" je l'avais fait aussi, mais sans succès :( pareil pour la réparation du disque via le CD mac os, mais maintenant mon mac ne veut plus démarrer via CD :confused: (il ignore mon CD et passe à l'étape de l'écran bleu figer...même avec ALT ou bien C)


M'enfin, je vais quand même retenter les manip dans l'ordre que tu m'as donné, sa me donne envie :D

Je vous tiendrais au courant.

Si vous avez d'autre moyen de résoudre ce problème n'hésiter pas :)
 
Dernière édition:

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
J'irais faire un tour dans Macintosh HD > Bibliothèque,
et après avoir quitté toutes les applications en action,
je déplacerais le contenu des sous-dossiers LaunchAgents, LaunchDaemons et StartupItems.

Si le Mac redémarre ensuite normalement, ne restera qu'à trouver l'extension corrompue ou incompatible (= ou en replaçant les éléments les uns après les autres, ou en désinstallant et réinstallant toutes les applications concernées).

Si la connexion se fait automatiquement sur ta session (= sans passer par la fenêtre de connexion),
il te faudra ajouter les mêmes dossiers dans la Bibliothèque de ton compte,
et aller fouiner aussi dans les Préférences Système > Comptes > ton compte > Ouverture.

Avant de redémarrer, il vaut mieux éliminer de Préférences Système > Comptes > ton compte > Ouverture tout ce qui est concerné par les extensions que tu auras déplacées.



Une autre piste, qui était parfois utile en 10.5, est de mettre à la Corbeille le com.apple.loginwindow.plist qu'on trouve dans les Préférences de la Bibliothèque de Macintosh HD (et du compte en cas de connexion automatique) et de redémarrer aussitôt.
Si rien en s'améliore, on remet alors le fichier à sa place.
 

kreator

Membre junior
5 Août 2013
19
0
29
Bon bah j'ai tout fait ce que vous m'avez dit de faire mais malheureusement ça n'a pas résolu le problème :(


- J'ai démarrer en mode single mode j'ai entré la commande fsck -fy une fois que j'ai eu le message "appears to be OK" j'ai mis la commande "reboot"

- J'ai ensuite essayé de redémarrer le mac depuis le CD 1 de Mac os mais comme d'habitude il refuse de booter sur le CD peut importe si j'appuis sur C ou ALT il ignore le CD et reste bloqué à l'écran bleu...(pourtant le CD est en bonne état puisqu'au mode sans extension il lit mon CD).

Ce qui fait que je n'ai pas pu réparer le disque mais j'ai quand même vérifier le disque et d'après ce qu'il dit "tout est ok"

- J'ai ensuite déplacer les éléments des fichiers Lauch et du startupitems, j'ai aussi ajouter ces dossiers dans Bibliothèque --> Mon compte. J'ai aussi mis "com.apple.loginwindow.plist" à la corbeille sans la vider et pareil dans Mon compte.

Mais malheureusement toujours cet écran bleu...


Sinon j'ai 2 questions:

La 1ère: Es-ce normal que dans le dossier "LaunchDaemons" qui ce trouve dans "Macintosh HD > Bibliothèque" sois vide ?


La 2ème: Es-ce normal qu'à l'intérieur de la pomme de chargement du démarrage normal du mac, il y'a des traits vert verticaux à l'intérieur, comme sur la photo ci-dessous ? Car à vrai dire je n'est jamais fait attention, mais ça me parait louche :nailbiting:




Sinon es-ce possible aussi que ce sois un problème du matériel ? Mais pourtant en mode sans extension il fonctionne bien.

Merci d'avance :)
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
Il n'y a que quelques logiciels tiers qui écrivent dans le dossier LaunchDaemons.
Et les traits verts ne m'interpellent pas trop = Limited graphics performance in OS X recovery or safe mode


Pour faire un Apple Hardware Test, il faut pouvoir démarrer sur les DVD d'install (le n°1 pour les Mac vendus en 10.5.4 et avant, le n°2 à partir de 10.5.5).

Les modes alternatifs Alt et C peuvent revenir après un reset de PRAM ou de SMC, un changement de clavier, ou après avoir débranché tous les câbles et toutes les cartes.
Sauf si la carte-mère est de guingois.

Démarrer en mode Alt permettrait de tester le démarrage sur un autre disque (clone) : on distingue ainsi les ennuis de disque interne de ceux de carte-mère.


Parfois le démarrage en mode Verbose (Cmd+V) bloque sur le fichier qui coince le démarrage.


Je ne sais toujours pas si tu es en connexion automatique à ton compte.
 

kreator

Membre junior
5 Août 2013
19
0
29
Il n'y a que quelques logiciels tiers qui écrivent dans le dossier LaunchDaemons.
Et les traits verts ne m'interpellent pas trop = Limited graphics performance in OS X recovery or safe mode


Pour faire un Apple Hardware Test, il faut pouvoir démarrer sur les DVD d'install (le n°1 pour les Mac vendus en 10.5.4 et avant, le n°2 à partir de 10.5.5).

Les modes alternatifs Alt et C peuvent revenir après un reset de PRAM ou de SMC, un changement de clavier, ou après avoir débranché tous les câbles et toutes les cartes.
Sauf si la carte-mère est de guingois.

Démarrer en mode Alt permettrait de tester le démarrage sur un autre disque (clone) : on distingue ainsi les ennuis de disque interne de ceux de carte-mère.


Parfois le démarrage en mode Verbose (Cmd+V) bloque sur le fichier qui coince le démarrage.


Je ne sais toujours pas si tu es en connexion automatique à ton compte.


Désolé j'avais oublié de te le dire, oui je suis en connexion automatique à mon compte sans passé par la page D'ID
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
Désactiver l'option permettrait de vérifier que le problème est bien dans le système ou le hardware, et pas dans ta seule session, avant d'aller plus loin.
 

kreator

Membre junior
5 Août 2013
19
0
29
Là où tu l'as activée il y a des années ! :D


(= dans Préférences Systèmes > Comptes > Options)


chez moi dans préférences système comptes options j'ai:

- Ouverture de session automatiquement (Nom d'utilisateur)
- Afficher les boutons suspendre, redémarrer, éteindre
- Afficher le menu saisie dans la fenêtre d'ouverture
- Afficher les indices de mot de passe
- Utiliser VoiceOver dans la fenêtre d'ouverture de session
- Activer la permutation rapide d'utilisation

J'ai aussi redémarrer le mac sous mode verbose, mais il m'a rien trouver d'anormal.

J'ai réinitialiser la PRAM 4 fois d'affiler, j'ai débrancher le mac pendant 15 secondes et rebrancher au bout de 5 secondes.

Mais mon mac ne veut toujours pas lire mon CD 1 au démarrage :( de même si je lance mon CD en mode sans extension et que je double clique sur l'icone installation mac os x "redémarrer maintenant".
(Mon CD 2 n'est pas bootable)

Je craint que mon mac a du choper le cancer :D Si seulement je pourrais lancer le CD 1 d'installation du mac je pourrais restaurer le mac etc et peut être corriger ce gros problème.


J'ai vue aussi que je pouvais faire une restauration via TimeMachine mais le problème c'est qu'il va me formaté mon disque dur externe :D
 
Dernière édition:

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
chez moi dans préférences système comptes options j'ai:

- Ouverture de session automatiquement (Nom d'utilisateur)
C'est le bon menu.


Si seulement je pourrais lancer le CD 1 d'installation du mac je pourrais restaurer le mac etc et peut être corriger ce gros problème.
En montant en Target ton Mac sur un Mac aussi vieux que lui, tu y parviendrais peut-être.
S'il accepte le mode T, ce qui n'est pas gagné non plus.


En gros, en l'absence de recours au SAV, il ne reste à peu près que le démontage de ton Mac pour en extraire le disque interne et brancher celui-ci avec un adaptateur (ou un dock) sur un nouveau Mac
= ça dirait si le souci est dans le disque ou la carte-mère,
et si ça vient de la carte-mère, tu pourrais récupérer facilement tes données.


La restauration d'une sauvegarde Time Machine se fait en 10.5 en redémarrant sur le DVD d'install n°1&#8230;
 

kreator

Membre junior
5 Août 2013
19
0
29
Je viens d'avoir une idée, si j'achète mac os x 10.6 snow léopard et que j'upgrade mon mac 10.5.8 en 10.6 ça peut fonctionner ? Vue que le mac os 10.6 coûte que 19 € ça restera toujours moins cher que le SAV :D
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
Si c'est un problème matériel, tu n'arriveras pas à installer SL.

Si c'est un problème logiciel, le succès d'une simple mise à niveau n'est pas garanti du tout, ce qui t'obligera à reformater ton disque interne et donc à perdre toutes tes données.

Bref, je récupèrerais d'abord toutes mes données avant de me lancer.
 

kreator

Membre junior
5 Août 2013
19
0
29
Si c'est un problème matériel, tu n'arriveras pas à installer SL.

Si c'est un problème logiciel, le succès d'une simple mise à niveau n'est pas garanti du tout, ce qui t'obligera à reformater ton disque interne et donc à perdre toutes tes données.

Bref, je récupèrerais d'abord toutes mes données avant de me lancer.

Oui, hier j'ai récupéré toutes mes donnés sur mon disque dur externe, alors comme ça :D, puis s'il veut pas s'installé ça voudrais dire que ça vient du matos, et ça...c'est une autre histoire :rolleyes: