Ce forum est en partie financé par l’affichage de publicités. Merci de désactiver votre bloqueur de publicités pour nous permettre de continuer à fournir ce service.

écran bleu HELPPPPPPPPPPPPPPPPP !!!!!!!!!!!!

Discussion dans 'macOS' créé par richard, 29 Mai 2002.

Modérateurs: Aliboron, bompi, daffyb
  1. richard

    richard Membre confirmé

    Inscrit:
    16 Avril 2001
    Messages:
    134
    J'aime reçus:
    3
    bonjour,

    j'ai modifié mes autorisations d'accès et MacOs X ne s'ouvre plus : à la rubrique "tous" (utilisateurs) j'ai coché "aucune" (autorisation). QuickTime SS est installé (bien que je ne l'utilise pas).
    J'ai essayé dans le mode single user la ligne de commande trouvée sur les forums macgen :

    HOW TO FIX IT:
    You can fix this by booting into Single User mode (Cmd-S) and typing the commands below, but I do not recommend this as it opens up every file to all users! Obviously this is a security problem.
    /bin/fsck -y; /bin/mount -vw /; chmod a+rwx /;

    mais cela ne fonctionne pas ( je ne sais d'ailleurs pas s'il faut inscrire la ligne en entier ou 3 morceaux.
    Merci de me sortir de mon pétrin ; je voudrais surtout éviter une réinstal. qui me ferait perdre toutes mes configurations et réglages.
     
  2. sfj

    sfj Membre confirmé

    Inscrit:
    20 Avril 2002
    Messages:
    163
    J'aime reçus:
    0
    Chaque commande doit etre effectuée l'une parèes l'autre.
    Pour rétablir les autorisations ça me semble etre la dernière, MAIS JE NE CONNAIS PAS SON EFFET donc prudence et attend de voir si quelqu'un connait mieux que moi.

    [29 mai 2002 : message édité par sfj]
     
  3. Gwenhiver

    Gwenhiver Membre d’élite
    Club MacG

    Inscrit:
    8 Décembre 2000
    Messages:
    3 351
    J'aime reçus:
    2
    chmod a+rwx /

    Tu mets les droits en lecture, écriture et exécution à l'utilisateur, au groupe, et au world. A tout le monde quoi...
     
  4. macintroll

    macintroll Membre d’élite
    Club MacG

    Inscrit:
    9 Septembre 2001
    Messages:
    1 327
    J'aime reçus:
    75
    <BLOCKQUOTE><font size="1" face="Verdana, Geneva">quote:</font><HR>Posté à l'origine par richardleon:
    bonjour,
    ...
    /bin/fsck -y; /bin/mount -vw /; chmod a+rwx /;

    <HR></BLOCKQUOTE>

    1) faut les faire un après l'autre...

    2) sinon le chmod a+rwx signifie :
    Modifier les autorisations sur tous les fichiers [​IMG]
    donc tous les droits sur l'ensemble des fichiers du disque.

    a = all
    rwx = read - write - execute


    voila : [​IMG] [​IMG]
     
  5. macintroll

    macintroll Membre d’élite
    Club MacG

    Inscrit:
    9 Septembre 2001
    Messages:
    1 327
    J'aime reçus:
    75
    Arf t'es trop rapide pour moi Gwen... [​IMG] [​IMG] [​IMG]
     
  6. richard

    richard Membre confirmé

    Inscrit:
    16 Avril 2001
    Messages:
    134
    J'aime reçus:
    3
    il me répond
    chmod: /: Read only file system

    helpppppppppppppp
     
  7. macintroll

    macintroll Membre d’élite
    Club MacG

    Inscrit:
    9 Septembre 2001
    Messages:
    1 327
    J'aime reçus:
    75
    Voici comment proceder :

    tu demarre en mode "single user" (s au demarrage)

    la tu tapes :
    /bin/fsck -y [et la touche entrée pour valider]

    ensuite a l'invite de commande tu tapes :
    /bin/mount -vw / [et la touche entrée]

    enfin :

    chmod a+rwx / [et la touche entrée]

    voila... si tu tape juste Chmod sans les arguments (a+rwx) ca marchera pas [​IMG]

    chaque commande au terminal est constitué de cette manière : Commande (chmod) plus arguments (a+rw)

    courage [​IMG]
     
  8. macintroll

    macintroll Membre d’élite
    Club MacG

    Inscrit:
    9 Septembre 2001
    Messages:
    1 327
    J'aime reçus:
    75
    <BLOCKQUOTE><font size="1" face="Verdana, Geneva">quote:</font><HR>Posté à l'origine par richardleon:
    helpppppppppppppppppp
    ça ne fonctionne pas :
    à la 1ère commande il me répond :
    zsh: no such file or directory: /bin/fsck
    je n'ai pas tenté les 2 autres
    merci de me dire ce quqe je dois faire
    Richard
    <HR></BLOCKQUOTE>

    Ouaip après une petite vérif rapide tu peu essayer ca tout simplement :
    démmarre en mode single user (tu connais maintenant no ?)

    a l'invite de commande tape simplement
    fsck -y et valide avec la touche enter

    Apparement il n'y a pas besoin de spécifier le chemin d'accès (/bin/)

    et refait cette commande tant que t'as des erreurs...

    ensuite tu peu essayer la suite [​IMG]
    (fait gaffe a toutes tes commandes car ton clavier passe en QWERTY et non plus en AZERTY !)

    de meme je pense que le /bin/ n'est pas utile, tout devrait mieux se passer sans [​IMG]

    tiens nous au parfum ok !?
     
  9. mtra

    mtra Membre d’élite
    Club MacG

    Inscrit:
    17 Juillet 2001
    Messages:
    2 292
    J'aime reçus:
    13
    <BLOCKQUOTE><font size="1" face="Verdana, Geneva">quote:</font><HR>Posté à l'origine par richardleon:

    mais cela ne fonctionne pas ( je ne sais d'ailleurs pas s'il faut inscrire la ligne en entier ou 3 morceaux.
    Merci de me sortir de mon pétrin ; je voudrais surtout éviter une réinstal. qui me ferait perdre toutes mes configurations et réglages.
    <HR></BLOCKQUOTE>

    voila le probleme ! Si ca marche! et c'est fait pour ca la reinstalle. quand tu reinstalles il ne faut pas cocher la case qui ecrase les données et le systeme vas reparer uniquement les fichier endomagés et manquant ca prend a peine 20min. a la place de taper des ligne de commande que tu ne comprend pas je t'invite a reinstaller depuis ton CD rapide et efficace et SANS PERTE DE PREFERENCE.
     
  10. richard

    richard Membre confirmé

    Inscrit:
    16 Avril 2001
    Messages:
    134
    J'aime reçus:
    3
    je n'y arrive tjrs pas. voilà ce que j'obtiens après avoir essayé les 2 propositions :
    -en mode single user :
    root device is mounted read only
    if you want to make modifications to files run
    '/sbin/fsck -y' first then '/sbin/mount uw /'
    ce n'est donc plus sur le "bin" des conseil antérieurs que doivent porter les modif, mais sur le "sbin". qu'est-ce que je dois faire ??????
    -en essayant de réinstaller, la partition sur laquelle est installé MacOsX ne peut pas être sélectionné car elle est grisée et quand je passe le pointeur dessus apparaît "ce qisque est estompé car le CD de MacOsX installe plusieurs langues" (mais il faut plutôt croire comme c'est dit en 1 que cette partition est en lecture seulement)
    au secoursssssssssssssssssssssssssssss
    excusez-moi mais je vous arrose sur vos mails perso
    merci pour vos conseils et réponses rapides
     
  11. richard

    richard Membre confirmé

    Inscrit:
    16 Avril 2001
    Messages:
    134
    J'aime reçus:
    3
    eh ! ne me laissez pas tomber, j'ai besoin de vous moi!
    une autre indication : une des ligne en mode single user indique après fsck -y : '/dev/rdisk1s9' est-ce que ça dit quelque chose ?
    je compte vraiment sur vous ...
     
  12. richard

    richard Membre confirmé

    Inscrit:
    16 Avril 2001
    Messages:
    134
    J'aime reçus:
    3
    encore une précision : quand je fais 'chmod a+rwx/' il me répond 'chmod: /:Read-Only file System'
    ça sert à quelqu'un ?
    Bon alors quoi, c'est tellement désespéré que personne ne veut me le dire :-((
    allez, dites-moi qu'il y a un petit espoir...
    merci

    une question subsidiaire : les touches du pavé numérique sont-elles prises en compte en mode single user ?
     
  13. simon

    simon Membre d’élite
    Club MacG

    Inscrit:
    18 Juin 2000
    Messages:
    3 669
    J'aime reçus:
    16
    C'est bizzare parce que s'il te met

    <BLOCKQUOTE><font size="1" face="Verdana, Geneva">quote:</font><HR> zsh: no such file or directory: /bin/fsck <HR></BLOCKQUOTE>

    cela sous entend qu'il a change de shell, c'est pour ça qu'il arrive pas à trouver les commandes [​IMG] quoique je sais pas qu'elle le shell par défaut sur le mode single user [​IMG]

    Maintenant les commandes sont effectivements /sbin/fsck -y et /sbin/mount -uw / tu peux essayer avec ça.

    Maintenant le /dev/rdisk1s9 c'est en fait le nom de ton disque dur sous UNIX (en tout cas celui de ta partition de démarrage). Maintenant s'il te dit qu'il est seulement Read-Only cela sous entend qu'il y a des problèmes d'autorisation [​IMG]

    [29 mai 2002 : message édité par Simon]
     
  14. richard

    richard Membre confirmé

    Inscrit:
    16 Avril 2001
    Messages:
    134
    J'aime reçus:
    3
    Maintenant les commandes sont effectivements /sbin/fsck -y et /sbin/mount -uw / tu peux essayer avec ça.

    j'ai déja essayé mais sans succés ;-(

    Maintenant s'il te dit qu'il est seulement Read-Only cela sous entend qu'il y a des problèmes d'autorisation

    justement, alors qu'est-ce que je dois faire pour rétablir les autorisations a+rwx ???

    est-ce qu'il ya encore un espoir ?????
     
  15. simon

    simon Membre d’élite
    Club MacG

    Inscrit:
    18 Juin 2000
    Messages:
    3 669
    J'aime reçus:
    16
    <BLOCKQUOTE><font size="1" face="Verdana, Geneva">quote:</font><HR>Posté à l'origine par richardleon:

    justement, alors qu'est-ce que je dois faire pour rétablir les autorisations a+rwx ???

    est-ce qu'il ya encore un espoir ?????
    <HR></BLOCKQUOTE>

    Ouais effectivement c'est la question posé par bcp de monde mais à première vu il faudra attendre Jaguar pour avoir ds Disk Utility un joli bouton qui te permet de faire un reset des autorisations [​IMG]

    Mais en attendant un peu de lecture pourra peut-être régler ton problème [​IMG]
    http://docs.info.apple.com/article.html?artnum=106464
     
  16. Gwenhiver

    Gwenhiver Membre d’élite
    Club MacG

    Inscrit:
    8 Décembre 2000
    Messages:
    3 351
    J'aime reçus:
    2
    [Message du "Modérateur"]
    richardleon,

    Je comprends ta déception face à ta machine qui ne veut plus démarrer. Néanmoins, il est considéré comme fort impoli d'"arroser les boîtes" des gens qui te proposent leur aide. Nous t'avons tous ici suggéré des solutions variées à ton problème. Étant apparemment un novice de la ligne de commande, je pense que celle de mtra est la plus appropriée à ton cas. Si nous avions autre chose à te proposer, nous l'aurions fait sur ce forum, qui est précisément l'endroit approprié. Ça ne sert à rien d'envoyer (au moins) trois mails à chacun d'entre nous, qui reprennent en plus texto le contenu de tes posts sur ce forum.

    Merci.
    [/Message du "Modérateur"]

    Sans rancune… [​IMG]
     
  17. macintroll

    macintroll Membre d’élite
    Club MacG

    Inscrit:
    9 Septembre 2001
    Messages:
    1 327
    J'aime reçus:
    75
    <BLOCKQUOTE><font size="1" face="Verdana, Geneva">quote:</font><HR>Posté à l'origine par Gwenhiver:
    [Message du "Modérateur"]
    richardleon,

    etc...

    Merci.
    [/Message du "Modérateur"]

    Sans rancune… [​IMG]
    <HR></BLOCKQUOTE>

    Pas de problème de mon coté richardleon, en fait mon soucis c'est que je n'ai pas solution "miracle" a ta question... [​IMG]
    apparement Simon a trouvé un truc très interressant pour te sortir d'affaire... a voir.

    Par contre concernant la réinstall de Mac OS 10.1 par dessus la 10.1.4 je crois avoir lu sur ces forums qu'il y avait une combine pour ca ...(j'ai déja rencontré le message "ce disque est estompé car le CD de MacOsX installe plusieurs langues" ce n'est pas lié aux droits apparement...

    par contre je retrouve plus le topic ou on en parlait !!! [​IMG]


    enfin dernière chose... peu tu utiliser mac os9 ?(ca te permettrait de tout backuper)
    (si tu as partitionné ton disque appuye sur la touche alt (option) au démarrage et tu pourra choisir ton disque.


    courage [​IMG]
     
  18. richard

    richard Membre confirmé

    Inscrit:
    16 Avril 2001
    Messages:
    134
    J'aime reçus:
    3
    je comprends la remarque du modérateur et je prie mes correspondants de bien vouloir m'excuser de les avoir innondé de 3 mails désespérés et plein d'attente.
    J'ai pensé naivement que la mise à disposition de l'adresse perso pouvait être un encouragement à multiplier les chances de contacts rapides dans des cas particulièrement urgents ou graves.
    Gwenhiver ne manque jamais une occasion de rappeler la règle. Qu'il en soit remercié.
     
  19. richard

    richard Membre confirmé

    Inscrit:
    16 Avril 2001
    Messages:
    134
    J'aime reçus:
    3
    Voilà ce que l'on m'a proposé par ailleurs :

    Il faut faire "/sbin/fsck -y" et pas "/bin/fsck -y"
    ensuite fais "/sbin/mount -uw /" puis "/bin/chmod -R 751 /", "/bin/chmod -R 777 Volumes", "/bin/chmod -R 751 Library" et "/bin/chmod -R 751 Applications"

    J'ai essayé ; mais à chaque commande j'ai : 'chmod illegal option --7' qu'en pensez-vous ?
     
  20. myckmack

    myckmack Membre d’élite
    Club MacG

    Inscrit:
    6 Octobre 2001
    Messages:
    2 748
    J'aime reçus:
    17
    Au lieu de te casser la tête à essayer des manips stériles (qui peuvent ne régler que partiellement ton problème et peut-être t'en créer d'autres qui apparaîtront plus tard), sauvegarde tes configurations et réglages et réinstalle ton système.
     
Modérateurs: Aliboron, bompi, daffyb
Chargement...