Ecran noir & kernel panic sur un iMac 21,5" de 2017

sdick

Membre confirmé
1 Avril 2003
50
4
Bonjour
Mon iMac 21.5 2017 (3,4 GHz intel Core 15 4 coeurs, 16Go RAM, 500Go SSD, Radeon Pro 560 4Go) avec MacOS Monterey 12.3, acheté fin 2018, est depuis peu sujet à des écrans noirs réguliers, en cours d'utilisation ou lors du démarrage. J'ai réussi à faire une clean install (qui s'est terminée avec un écran noir, mais qui a visiblement réussi car l'OS était correctement installé au redémarrage) mais ça ne change rien, que ce soit en cours d'utilisation, en "pause" (allumé mais non utilisé) ou au démarrage, l'écran redevient régulièrement noir et le seul moyen d'éteindre la machine est de maintenir le bouton d'allumage enfoncé pendant plusieurs secondes.
J'ai essayé un écran externe pour voir si c'est un pb d'écran, mais ce n'est pas ça.
J'ai déconnecté le disque de backup et l'imprimante pour voir si c'est un pb de périphérique USB, mais ce n'est pas ça.
J'ai même testé un autre clavier et une autre souris, mais ce n'est pas ça.
Pendant qq minutes où ça marchait suite à une clean install j'ai installé l'utilitaire Etrecheck qui me signale des "kernel panic" :

Événements du diagnostic (7-30 dernier jours):
2022-03-26 15:50:11 Panique du noyau
Détails:
panic(cpu 0 caller 0xffffff7f925b9ff5): "virtual bool AMD9500Controlle
r::detectPowerDown(): GPU is not found. PCI config access fails!!!
Panicked task 0xffffff8b72789d10: 5 threads: pid 77: WindowServer

Est-ce que quelqu'un sait si le fait de ne pas avoir trouvé le GPU impose forcément un pb de carte graphique, et si c'est le cas avez-vous une idée du cout de cette réparation ?

Autre question en prévision d'un plan B : a combien puis-je espérer revendre cette machine avec ce pb connu, donc pour pièces ou pour un réparateur averti, sachant que tout le reste est en excellent état ?

PS : l'utilitaire disque n'a trouvé aucun pb sur le SSD mais je vais tout de même encore tenter une clean install sur un disque externe pour être 100% sûr que ce n'est pas lié au SSD

D'avance merci pour vos feedbacks & suggestions pour identifier le pb avec certitude
 

sdick

Membre confirmé
1 Avril 2003
50
4
Info complémentaire : autre problème avant la clean install détecté par EtreCheck ...

Screenshot 2022-03-27 à 13.44.46.jpg
 
Dernière édition par un modérateur:

sdick

Membre confirmé
1 Avril 2003
50
4
PS : l'utilitaire disque n'a trouvé aucun pb sur le SSD mais je vais tout de même encore tenter une clean install sur un disque externe pour être 100% sûr que ce n'est pas lié au SSD
Résultat du test : c'est lent parce que je n'ai qu'un disque dur externe traditionnel, mais ça fait depuis hier soir que l'iMac tourne comme une horloge, sans plantage ni écran noir ; j'ai pu réinstaller les grosses applications et télécharger en local qq dizaines de Go de données diverses depuis iCloud (documents, photos, ...). Je vais encore le laisser tourner qq jours, pour confirmer le diagnostic ...
 

Lucas09Ldt

Membre confirmé
9 Février 2022
18
0
22
Bonjour,

Je pense que le problème est surtout lié à la mauvaise installation du système d'exploitation.
Tu peux essayer de réinstaller l'OS via le centre de récupération (enfoncer les touches CMD et R au démarrage et en sélectionnant "Réinstaller macOS ---")
Et veille à ce que l'ordinateur soit bien branché et que le SSD n'ai pas de problème (dans le centre de récupération, sélectionne "Utilitaire de disque" puis exécute "SOS" sur ton disque dur) pour éviter que l'installation ne se termine en écran noir.

 

sdick

Membre confirmé
1 Avril 2003
50
4
Tu peux essayer de réinstaller l'OS via le centre de récupération (enfoncer les touches CMD et R au démarrage et en sélectionnant "Réinstaller macOS ---")
Et veille à ce que l'ordinateur soit bien branché et que le SSD n'ai pas de problème (dans le centre de récupération, sélectionne "Utilitaire de disque" puis exécute "SOS" sur ton disque dur) pour éviter que l'installation ne se termine en écran noir.
Merci pour ta réponse. J'avais bien fait tout ça, le SOS sur le SSD m'avait dit que tout allait bien, le reformatage du SSD s'était bien passé, mais ça s'était tout de même terminé avec un écran noir alors que sur le disque externe ça a marché. Comme ça fonctionne maintenant (mais lentement) depuis le DD externe, je vais cette fois ci virer complètement la partition du SSD, la recréer, et refaire à nouveau une clean-install de la dernière chance ; si elle ne marche pas je remplacerai le SSD
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
54 574
10 432
Nancy___
Comme ça fonctionne maintenant (mais lentement) depuis le DD externe, je vais cette fois ci virer complètement la partition du SSD, la recréer,
Il faut formater ton disque interne : dans Utilitaire de disque, dans l'item "Présentation", fais "afficher tous les appareils".
Là tu sélectionnes l'icône la plus haute de ton SSD et tu formates.

Par contre, pourquoi parles tu de "partitions" ?
 

sdick

Membre confirmé
1 Avril 2003
50
4
"Effacer et reformater la table de partition du volume" est ce que j'ai fait la 1ère fois, sans succès puisque mon pb d'écran noir persistait. Ce que je viens de faire et qui semble marcher est "supprimer le volume APFS" (ce n'est pas le menu partitionner en effet, qui ne me permettait pas de virer la partition existante), ce qui réinitialise complètement le SSD et permet ensuite de réinstaller MacOS avec CMD-R. La réinstallation s'est bien passée et le Mac a l'air de fonctionner correctement... à valider les jours qui viennent
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
40 984
6 429
Ce que je viens de faire et qui semble marcher est "supprimer le volume APFS" (ce n'est pas le menu partitionner en effet, qui ne me permettait pas de virer la partition existante), ce qui réinitialise complètement le SSD et permet ensuite de réinstaller MacOS avec CMD-R.
Tssst, tssst, tssst, fais-tu réellement un formatage en suivant à la lettre ceci...

Formatage09.jpg

0) un clic sur Présentation et tu sélectionnes Afficher tous les appareils
1) tu sélectionnes la racine du disque dur et pas ce qui est en-dessous
2) un clic sur Effacer affichera les informations suivantes
3) tu donnes un nom explicite comme Macintosh HD
4) tu sélectionnes le format APFS
5) tu sélectionnes impérativement Table de partition GUID
6) un clic sur Effacer, ça ne prendra pas trop de temps

Tu quittes Utilitaire de disque, dans la fenêtre avec les 4 outils, tu sélectionnes Réinstaller macOS, la suite ne te posera pas de problème.
 

daffyb

-Duck Warrior-
Modérateur
Club MacG
18 Octobre 2001
14 161
1 822
Angoulême
Bonjour, j'ai un problème similaire (mais peut-être pas identique).
macOS Monterey
iMac Retina 4K, 21.5-inch, 2017
3,4GHz Intel Core i5 4 cœurs
16Go de RAM
Radeon Pro 560 4 Go
SSD 500 Go


Description du problème et son contournement
Mon Mac démarre correctement jusqu'à 50% de la barre de progression, mais lorsqu'il active la puce graphique, soit écran noir (mais le Mac continue son boot), soit kernel panic (très rare), soit écran coupé en 2 dans sa hauteur.
La solution est déteindre en pressant le bouton de démarrage.
Le Mac démarre correctement lorsque les extensions sont désactivées
Mon analyse (après de nombreux test) est qu'il y a un problème hardware lors de l'initialisation de la puce graphique.

Ma solution :
Je n'eteinds plus mon Mac.
Je ne suspends plus l'activité (sinon KP)
Quand je le redémarre (parce que parfois c'est nécessaire) très rarement il redémarre correctement.
Mais quand il ne démarre pas, je le laisse se reposer 1 heure (pas moins, et j'ai testé max 2 heures) et là il démarre.

Il ne démarre pas à froid non plus. Dans ce cas, il faut le "chauffer" en le démarrant extensions désactivées (une 20taine de minutes).
C'est pourri, c'est chiant, c'est stressant à chaque reboot, mais pour l'instant ça fonctionne comme ça.

Précision : le problème est survenu sous BigSur et j'ai fait la mise à jour Monterey avec un faible espoir qu'un éventuel changement dans la séquence de boot règle le problème… mais non…
 

geooooooooffrey

Membre confirmé
27 Août 2017
15
2
28
@daffyb décrit très exactement le même problème et la même "solution" que j'ai trouvée, seul détail qui change c'est la capacité du SSD (256 Go)
Ce problème a commencé à se manifester chez moi début octobre. Aucun mise à jour depuis n'a rien corrigé. Pas mieux avec une clean install.

Les Kernel Panic que je me prends sont souvent celui-ci :
panic(cpu 3 caller 0xffffff7fa440adeb): "virtual bool IOAccelLegacyDisplayMachine::display_mode_did_change(uint32_t): AMDRadeonAccelerator driver returns false"@/System/Volumes/Data/SWE/macOS/BuildRoots/38cf1d983f/Library/Caches/com.apple.xbs/Sources/IOAcceleratorFamily_kexts/IOAcceleratorFamily-442.9/Kext2/IOAccelLegacyDisplayMachine.cpp:267

J'ai un peu farfouillé le web, et j'ai l'impression de voir régulièrement les iMac (21" et 27") de 2017 impliqués dans des problèmes de KP de ce genre...
 
  • J’aime
Réactions: daffyb

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
40 984
6 429
Mon analyse (après de nombreux test) est qu'il y a un problème hardware lors de l'initialisation de la puce graphique.
Ce serait plutôt l'inverse au lu de ton problème, la puce graphique interne fonctionne correctement, mais ce serait la carte graphique de 4 Go le problème.

Juste comme ça, je n'ai pas d'iMac classique, est-ce que tu as cette option dans Préférences système/Economiseur d'énergie... https://fr.ihowto.tips/apple/enable-disable-graphic-video-card-in-macbook-pro-15-inch-2016-2017.html ... ? Si oui, ça permettrait de désactiver la carte graphique dédiée et de vérifier que c'est elle le problème. A priori cela concernerait les MBP. Par le passé il y avait bien gfxCardStatus, mais il ne fonctionne plus depuis pas mal de temps. Par curiosité, essaye gSwitch... https://codyschrank.github.io/gSwitch/ ...sans aucune garantie, je ne peux pas tester avec mon iMac 24" M1.

Jouant les curieux, je suis tombé sur cet article de MacG... https://www.macg.co/mac/2016/12/la-...ise-autonomie-des-macbook-pro-15-pouces-96672 ...et tout en bas, mais vraiment en bas tu as un lien qui renvoie ici... https://github.com/steveschow/gfxCardStatus/releases ...et tu as un lien de téléchargement... gfxCardStatus.app.zip ...là encore, sans garantie, je ne peux pas vérifier.