MacBook Pro Ecran noir

Sulfuristik

Membre junior
12 Mars 2017
96
5
32
Hello la communauté,

Depuis que j'ai acheté mon macbook pro 15pouces, j'ai remarqué qu'en allant sur certains sites, j'ai un bref écran noir d'une fraction de seconde. Je l'ai déjà emmené chez Apple où on m'a dit que c'était dû au fait qu'il y avait deux cartes graphiques et qu'en gros d'après ce que j'ai compris selon le besoin de ressource le mac switchait entre les 2 cartes graphiques. Et un collègue au genius bar du réparateur lui a dit qu'il avait le même mac que moi à savoir un macbook pro 15 pouces mi-2105 et que ça lui faisait aussi. Il aurait "patché" son mac pour qu'il n'utilise qu'une seule carte graphique. Ca me laisse perplexe.
Vous en pensez quoi ?
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
40 871
5 707
Nancy___
Bonjour,

Tu peux le vérifier en installant gfxCardStatus et en ne fonctionnant qu'avec le chipset intégré.

Si tu n'as plus ce "bref écran noir d'une fraction de seconde" qu'en tu utilises uniquement le chipset graphique, alors que tu as ce "bref écran noir d'une fraction de seconde" quand tu passes du chipset à la carte graphique, alors tu auras vérifié les dires de l personne de chez Apple.
 

Sulfuristik

Membre junior
12 Mars 2017
96
5
32
Voilà je viens de l'installer mais je n'arrive pas à sélectionner le mode intégré uniquement. Je peux choisir visiblement le mode dédié ou basculement auto...

Edit : Ah si c'est bon en fait quand j'appuie maintenant sur l'un des deux mode il me propose l iris pro ou la radeon.

Je vous tiens au jus
 
Dernière édition:

Sulfuristik

Membre junior
12 Mars 2017
96
5
32
Salut,
Je viens aux nouvelles. A priori quand je lance gfxCardStatus, je n'ai plus ce fameux écran noir, une fois la carte Intel iris pro ou amd choisi. Il n'y a donc plus ce basculement automatique. Donc c'est pas un problème de carte graphique c'est déjà ça. En revanche impossible de lancer gfxCardStatus dès le démarrage du mac, même après avoir été dans les préférences et cocher lancer gfxCardStatus au démarrage. Quelqu'un a déjà réussi ?

Merci
 
D

Deleted member 1099514

Invité
Salut

Qu'as-tu fait exactement?
Il faut aller dans Préférences systèmes/Utilisateurs et groupes/choisir ton utilisateur puis "ouverture" et là tu ajoutes l'appli.
Mais il ne faut pas cocher la case "Masquer".
 
  • J’aime
Réactions: Sulfuristik

Sulfuristik

Membre junior
12 Mars 2017
96
5
32
Salut,

Alors quand j'allume mon mac, je vais dans le dossier téléchargement, puis je clique sur gfxCardStatus. Ensuite je choisis manuellement la carte sur laquelle je veux être ce qui n'a pas de grande importance pour moi tant que j'évite le basculement auto. Je vais essayé ce que tu m'as dit. Sais-tu si par hasard on peut choisir directement sur quelle carte démarrer par hasard ? J'en demande peut-être trop...
En tout cas merci du tuyau je vais essayer ça
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
40 871
5 707
Nancy___
Est ce que l'application gfxCardStatus est bien installée sur ta machine (c'est qu'elle n'est pas dans une image disque) ?
 
D

Deleted member 1099514

Invité
Déjà il faut copier gfxCardStatus dans /Applications/Utilitaires et ensuite aller sélectionner ce programme depuis "Ouverture" dans les préférences systèmes de ton utilisateur.
 

Sulfuristik

Membre junior
12 Mars 2017
96
5
32
Déjà il faut copier gfxCardStatus dans /Applications/Utilitaires et ensuite aller sélectionner ce programme depuis "Ouverture" dans les préférences systèmes de ton utilisateur.
D'accord. C'est ce que je fais tout le temps quand l'installation d'un programme le demande. Alors que là ça me l'a jamais fait. Donc à voir.
 

Sulfuristik

Membre junior
12 Mars 2017
96
5
32
Salut,

Alors voilà j'ai réussi à tout faire ça fonctionne seulement ça choisit le mode basculement auto et du coup toutes les secondes ça bascule entre chaque graphique c'est un peu chiant. On est obligé de choisir manuellement sa carte au début. Dommage qu'on ne peut pas enfin j'espère que si choisir sa carte une bonne fois pour toute. Et ne pas avoir à retourner dans la barre du haut à chaque démarrage.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
71 637
21 495
Forêt de Fontainebleau
Salut Sulfuristik

Les anciennes versions de gfxCardStatus offraient la possibilité de fixer a priori le processeur graphique par défaut - ce jusqu'à la version gfxCardStatus-2.1 comprise. Dans les versions ultérieures > le développeur a abandonné cette option. Je ne sais pas pour quelle raison précisément.

La version gfxCardStatus-2.1 est théoriquement introuvable > mais en pratique je te l'offre en téléchargement depuis le dossier public de ma DropDox : ☞gfxCardStatus-2.1.app.zip☜. En examinant bien ses options > tu trouveras.
 
  • J’aime
Réactions: Tox

Sulfuristik

Membre junior
12 Mars 2017
96
5
32
Bonjour,
Voici mon retour avec gfxCardStatus-2.1. Alors comme je suis sur Sierra 10.12.6 j'ai ce message au début :

Capture d’écran 2017-08-26 à 14.51.06.png


Ensuite quand je clique sur Oh, I See ça fonctionne. J'ai choisi dans le mode préférences, de démarrer gfxCardStatus-2.1 au démarrage mais ça ne fonctionne pas. Le mode choisit dans les réglages me fait basculer automatiquement d'un GPU à un autre. Et ce quelque soit le mode choisit. De plus impossible de trouver ce logiciel dans ouverture. Du coup je le supprime.
 

Sulfuristik

Membre junior
12 Mars 2017
96
5
32
Bonsoir,

J'ai trouvé une solution. En allant dans Préférences Système > économiseur d'énergie > décocher Permutation automatique du graphisme. Ensuite appuyer sur le bouton < en haut à gauche et le tour est joué.