Ecrire en japonais sous mac OS X

_bushido_

Membre confirmé
10 Novembre 2011
12
0
Salut!
Je suis nouveau sur le forum, donc je vais me présenter brièvement :)
Je suis étudiant en école de commerce, j'ai 18 ans et je commence le japonais en LV3 cette année. Grâce aux cours que je suis, j'ai un correspondant japonais.
Mais le problème c'est que je dois passer par google traduction ou un plug-in de chrome +copier coller à chaque fois pour pouvoir écrire... en japonais.

Pourquoi? Parce que dès que je bascule en Kotoeri (le clavier japonais qui rassemble Hiraganas, Katakanas, et caetera dans prefs systeme), mon mac plante! La jolie roue multicolore tourne indéfiniment et chaque fois que je clique, l'action liée se produit 30 secondes après!
Impossible d'écrire dans ces conditions. Suivant l'avis du forum mac de jeuxvidéos.com, j'ai créé une autre session pour savoir si c'était un problème généralisé, et tout marche sur celle ci!
Lorsque je vais dans moniteur d'activité, rien d'anormal, sauf le "contenu safari": lorsque tout plante, il arrive que ça monopolise 73% du proc° par exemple!

Quelques infos:
- Je suis sur Mac OS X 10.6.8 Snow Leopard
- J'ai un macbook pro 13" 2010
- le principe du clavier japonais kotoeri: rentrer "fu" pour obtenir le caractère (la syllabe) ふ

Si je peux apporter d'autres précisions, n'hésitez pas à me les demander... :zen:
Merci d'avance!
 

butchan

Membre confirmé
27 Octobre 2006
21
2
52
Ce la fait des années que j'écris en japonais via mac sans souci (c'est une des forces du mac vs. Windows : être un vrai OS multilingue).
Pour faire court, va dans "Préférences/Méthodes de saisie" coche bien "Kotoeri".Dans l'onglet "Langues" insère le japonais en langue 2 juste après le français. Ensuite, quand tu ouvres n'importe quelle app (Word, Safari, etc.), tu écris en japonais en ayant préalablement sélectionné la langue japonaise dans la barre en haut à droit de ton écran.

Si tu as déjà fait tout ça et que ça plante à nouveau, fais une réinstallation propre de ton OS (sans effacer tous tes autres data).

J'ai 5 ordis à la maison avec Lion, Leopard, Snow Leopard et le japonais fonctionne parfaitement sur toutes mes machines.

がんばて!
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
Si le problème ne survient que dans un Compte,
ça peut valoir la peine de faire un peu de maintenance (vidage de Caches, etc), avec Onyx (ou autre),

et, sinon, de regarder ce qu'il peut y avoir comme Polices dans le compte > Bibliothèque > Fonts,
et de valider ces polices dans le Livre des Polices.
 

_bushido_

Membre confirmé
10 Novembre 2011
12
0
J'ai essayé la première solution (vider les caches), ça ne change rien.
J'ai regardé dans le dossier Fonts... Il n'y a absolument rien dedans :confused:
Comment faire un clean install sans effacer toutes mes données?
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
Tu as relativement peu de chances de t'en sortir en réinstallant tout,
car tu vas vraisemblablement réinstaller ce qui coince dans ta session.

Puisque ça se passe sur internet, je chercherais plutôt du côté d'un plugin-module-add on à Safari/Chrome : les Internet Plug-ins de la Bibliothèque de ton compte, par exemple.

Si tu veux réinstaller 10.6, tu insères le DVD, tu cliques sur Installer Mac OS X, et tu fais la mise à jour du menu  quand c'est réinstallé.

Tu t'es servi d'Onyx pour nettoyer tes Caches d'utilisateur ?
 

_bushido_

Membre confirmé
10 Novembre 2011
12
0
je me suis bien servi d'Onyx pour vider les caches.
Ça ne se passe pas uniquement sur Internet, et j'avais le sentiment que sur l'autre session, que ce soit sur Internet ou non, ça fonctionnait à la perfection!
Apparemment, les problèmes arrivent toujours "au bout d'un certain temps (moins d'une minute)
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
Les caches des Polices se nettoyant aussi avec un démarrage en mode sans échec (touche Maj enfoncée).

Existent aussi d'autre polices, stockées ailleurs que dans Fonts : Microsoft Office (dans tes Préférences).

Il y a peut-être un tour à faire dans l'utilitaire Livre des Polices, pour valider les fontes et éliminer les doublons.
Et, sinon, dans l'utilitaire Console, pour trouver un message d'erreur.
 

_bushido_

Membre confirmé
10 Novembre 2011
12
0
Ce la fait des années que j'écris en japonais via mac sans souci (c'est une des forces du mac vs. Windows : être un vrai OS multilingue).
Pour faire court, va dans "Préférences/Méthodes de saisie" coche bien "Kotoeri".Dans l'onglet "Langues" insère le japonais en langue 2 juste après le français. Ensuite, quand tu ouvres n'importe quelle app (Word, Safari, etc.), tu écris en japonais en ayant préalablement sélectionné la langue japonaise dans la barre en haut à droit de ton écran.

Si tu as déjà fait tout ça et que ça plante à nouveau, fais une réinstallation propre de ton OS (sans effacer tous tes autres data).

J'ai 5 ordis à la maison avec Lion, Leopard, Snow Leopard et le japonais fonctionne parfaitement sur toutes mes machines.

がんばて!

Au fait, je pense que "がんばて!" doit s'écrire en Kanji, parce que là, ça veut dire "l'épuisement du cancer" ^^(je dis ça, je ne connais que les hiragana pour le moment)
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
Regarde dans ta Maison > Bibliothèque > Préférences si tu y trouves un fichier com.apple.main-thread
(éventuellement en faisant un tour dans le sous-dossier ByHost).

Si tu le trouves, tu le mets à la Corbeille (sans la vider),
et tu relances ta session (tu la quittes puis tu t'y reconnectes).
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
Une autre piste :
j'ai créé une autre session pour savoir si c'était un problème généralisé, et tout marche sur celle ci!
Lorsque je vais dans moniteur d'activité, rien d'anormal, sauf le "contenu safari": lorsque tout plante, il arrive que ça monopolise 73% du proc° par exemple!
1/ Quitte Safari, et va dans ta Maison > Bibliothèque > Caches > com.apple.safari,
et mets le Cache.db à la Corbeille avant de relancer Safari.

2/ Va dans Safari > Préférences > Extensions, et désactive-les : si le japonais remonte dans ta session, mets à jour ou désinstalle tes extensions une par une, jusqu'à trouver la coupable.
 

_bushido_

Membre confirmé
10 Novembre 2011
12
0
すごい!
Je crois que ça marche enfin!
Mais je ne sais toujours pas d'où ça vient... En tout cas j'ai désactive toutes mes extensions sauf adblock... et surtout j'ai supprimé le fichier cache.db comme tu as dit!
どもありがとう!

Edit: au moment où j'ai cliqué sur "envoyer le message", ça a recommencé à planter ! Mais moins brutalement qu'avant...
 

_bushido_

Membre confirmé
10 Novembre 2011
12
0
Je reviens sur ce sujet, car j'ai appris un 2ème syllabaire (katakana) et je vais bientôt passer aux kanji.
Pour l(instant j'utilise un module de google chrome pour saisir du texte en hiragana (premier syllabaire), et il ne peut rien faire d'autre. La seule solution est de passer par le clavier kotoeri du mac, mais comment faire, si cela freeze tout le temps?
 

_bushido_

Membre confirmé
10 Novembre 2011
12
0
Le problème est que ça fonctionne sur n'importe quelle autre session, mais je ne peux pas supprimer celle-ci, sinon je risque de tout perdre, non?