10.11 El Capitan Empêcher le disque interne de monter au démarrage

fbike

Membre junior
1 Novembre 2015
53
2
Bonjour

Je suis sous el-capitan.

Ma question est la suivante:
Peut-on empêcher de monter un volume au démarrage, s’agissant du disque interne qui n’est plus utilisé. (le système est sur un disque connecté en thunderbolt)

Les options du finder ne permettent pas cela.

Pour ce qui est de mettre une entrée dans la fstab ou dans la fstab.hd un affichage de fstab.hd indique

Bloc de code:
christian@imac:[/private/etc]:more fstab.hd
IGNORE THIS FILE.
This file does nothing, contains no useful data, and might go away in
future releases.  Do not depend on this file or its contents.
Le disque à ne pas monter au démarrage est celui ci:

Bloc de code:
diskutil list -all
.....
Volume Name:              VIDE

   Mounted:                  Yes
   Mount Point:              /Volumes/VIDE

   File System Personality:  Journaled HFS+
   Type (Bundle):            hfs
   Name (User Visible):      Mac OS Extended (Journaled)
   Journal:                  Journal size 81920 KB at offset 0x298000000
   Owners:                   Enabled

   Partition Type:           Apple_HFS
   OS Can Be Installed:      Yes
   Media Type:               Generic
   Protocol:                 SATA
   SMART Status:             Verified
   Volume UUID:              0479C532-B154-344A-BEF5-ADF5980C6968
   Disk / Partition UUID:    97D47B65-FE00-4598-9C63-84BEC493695B


Pour résoudre mon problème, est ce que configurer à la main le fichier auto-master serait la solution ?
Je vous remercie par avance pour vos lumières.

Bloc de code:
christian@imac:[/private/etc]:more auto_master
#
# Automounter master map
#
+auto_master            # Use directory service
/net                    -hosts          -nobrowse,hidefromfinder,nosuid
/home                   auto_home       -nobrowse,hidefromfinder
/Network/Servers        -fstab
/-                      -static
 
D

Deleted member 1099514

Invité
Peux-tu essayer de mettre dans le fichier /etc/fstab la ligne suivante :

UUID=0479C532-B154-344A-BEF5-ADF5980C6968 none hfs rw,noauto

Pour éditer le fichier il faudra faire un :
sudo nano /etc/fstab
 

fbike

Membre junior
1 Novembre 2015
53
2
Peux-tu essayer de mettre dans le fichier /etc/fstab la ligne suivante :

UUID=0479C532-B154-344A-BEF5-ADF5980C6968 none hfs rw,noauto

Pour éditer le fichier il faudra faire un :
sudo nano /etc/fstab


Merci beaucoup, cela fonctionne très bien. J'ai été induit en erreur à cause de la non présence du fichier /etc/fstab et de la présence du fichier /etc/fstab.hd avec son avertissement.

Du coup ... sudo cp /etc/fstab.hd /etc/fstab, édition du contenu et reboot... TOUT EST OK...

MERCI