Emulation via SheepShaver

comgil

Membre actif
13 Septembre 2000
194
0
Visiter le site
Quelqu'un a-t-il réussi à faire fonctionner ce logiciel ? La dernière version est toujours récalcitrante pour moi (version mars 2005). J'ai la bonne ROM (MAC OS ROM 3.8), les bons paramètres, mais dans la console le message "Impossible d'ouvrir la ROM" après que le logiciel se lance.

Des idées ?
J'ai mis mon fichier de réglages à la racine du disque (via PathFinder, très bien au demeurant), dans mon dossier "Maison" (home), dans le dossier de SheepShaver, mais rien n'y fait.

C'est énervant, car ce logiciel d'émulation semble bien plus intéressant que Basilisk II (en performance du moins).

Merci
 

Napoléon

Membre actif
28 Juin 2001
395
18
Paris
Il faut configurer le fichier de démarrage :

Dans le terminal :

sudo mv /chemin/de/ton/sheepshaver_prefs.sample /Users/tonnomdutilisteur/.sheepshaver_prefs
Ca c'est pour placer le fichier de config et le renommer

pico /Users/tonnomdutilisateur/.sheepshaver_prefs
Pour éditer ton fichier de config...

Il faut que tu changes les champs : chemin de la ROM, chemin de l'image disque, chemin du fichier keycodes.sdl, etc...
 

comgil

Membre actif
13 Septembre 2000
194
0
Visiter le site
Le message Console :
"SheepShaver V2.2 by Christian Bauer and Mar"c" Hellwig
Paranoia checks...
...passed
ERROR: Cannot open ROM file."

Mes paramètres dans le Terminal
"rom /Users/gillescombe/Desktop/Pour\ e?mulation/Mac\ Rom\ Images\ Folder/MAC\ OS\ ROM\ 8.6
disk /Users/gillescombe/Desktop/Pour\ e?mulation/Disque\ 750.image
extfs /Users/gillescombe/Desktop
windowmodes 3
screenmodes 63
seriala /dev/cu.modem
seriala /dev/cu.Bluetooth-Modem
serialb /dev/null
bootdrive 0
bootdriver 0
ramsize 16777216
frameskip 8
gfxaccel true
nocdrom false
nonet false
nosound false
nogui false
noclipconversion false
ignoresegv true
jit false
jit68k false
keyboardtype 5
keycodes false
mousewheelmode 1
mousewheellines 3
dsp /dev/dsp
mixer /dev/mixer
ignoresegv true
idlewait true
keycodefile /Users/gillescombe/Desktop/Pour\ e?mulation/SheepShaver.macosx/keycodes.sdl"

Help !!!
 

Napoléon

Membre actif
28 Juin 2001
395
18
Paris
1) es tu sûr de ta ROM ?
2) es-tu sûr de ton image disque ?
3) evite les espaces et les accents dans tes chemins d'accès
 

comgil

Membre actif
13 Septembre 2000
194
0
Visiter le site
Oui normalement les ROM sont bonnes (extraites de fichiers Apple de mise à jour).
De plus mon image fonctionne dans Basilisk II.
Enfin, j'ai modifier les chemins pour éviter accents et espaces, j'ai le même problème.
NB : si j'avais vos fichiers des paramètres et leur localisation, je pourrais peut-être voir ce qui cloche?
Merci
 

Napoléon

Membre actif
28 Juin 2001
395
18
Paris
Mon fichier de config :

sheep.jpg



L'image disque en .HFV a été créée avec HFVExplorer (sur PC) et j'ai installé dessus le 7.5.3 "universel" avec Basilik II (sur VirtualPC puisque BAsilik refuse de tourner sur mon mac). J'ai récupéré cette image (après avoir viré une extension qui bloqué sheepshaver) et là ça marche... Mais sheepshaver reste très capricieux sur OS X, il plante souvent chez moi... M'enfin ;)
 

comgil

Membre actif
13 Septembre 2000
194
0
Visiter le site
Il y a du progrès : il semble que des espces se soient insérés dans le nom de fichier (ça c'est du macintosh?)
La ROM de la mise à jour 8.6 semble fonctionner, mais je reste bloqué au démarrage pour l'instant.
Mais ça démarre, c'est mieux.
Merci pour les conseils
PS : basilisk sur Mac OS X fonctionne désormais (prendre la version simple) (v16)
 

comgil

Membre actif
13 Septembre 2000
194
0
Visiter le site
La dernière version du 16 mars 2005 bloque toujours. J'arrive à avoir le message "Bienvenue sur Macintosh" (la ROM est bonne et le début du système). Ensuite quand j'obtiens la 'roue qui tue", et en regardant dans Console il semblerait que toute une matrice se crée infiniment (remplie de 0).

Pour l'instant j'utilise un système 7.5.5 que j'ai patiemment créé avec les installateurs Apple (7.5.3 et mise à jour) sur une image disque créé par Basilisk Mac.

Je vais essayer sur un vieux système 8.0 pour voir, mais peut-être il y a-t-il un réglage que je n'ai pas correctement fait ? Une idée ?

Merci
 

Napoléon

Membre actif
28 Juin 2001
395
18
Paris
comgil a dit:
La dernière version du 16 mars 2005 bloque toujours. J'arrive à avoir le message "Bienvenue sur Macintosh" (la ROM est bonne et le début du système). Ensuite quand j'obtiens la 'roue qui tue", et en regardant dans Console il semblerait que toute une matrice se crée infiniment (remplie de 0).

Pour l'instant j'utilise un système 7.5.5 que j'ai patiemment créé avec les installateurs Apple (7.5.3 et mise à jour) sur une image disque créé par Basilisk Mac.

Je vais essayer sur un vieux système 8.0 pour voir, mais peut-être il y a-t-il un réglage que je n'ai pas correctement fait ? Une idée ?

Merci

Mhh, ça me l'a fait une fois, impossible de booter, il faisait la roue... Et malheureusement, je ne peux pas te dire ce qui a fait que maintenant ça marche... La seule différence sur mon système : avant il y avait Application Enhancer et plus maintenant.

Bon courage ;)
 

Napoléon

Membre actif
28 Juin 2001
395
18
Paris
Si Basilik te convient, je te conseille d'en rester à ce dernier en attendant que sheepshaver murisse un brin... ;)
 

comgil

Membre actif
13 Septembre 2000
194
0
Visiter le site
(après avoir viré une extension qui bloqué sheepshaver) et là ça marche... Mais sheepshaver reste très capricieux sur OS X, il plante souvent chez moi... M'enfin ;

PS mon sheepshaver bloque juste après le démarrage, quel que soit le système 7.0, 7.55, 8.0.
Une solution ? :)
 

Napoléon

Membre actif
28 Juin 2001
395
18
Paris
Démarre sans les extensions peut-être (touche majuscule au démarrage de sheepshaver)

Mais je te confirme, il est plantogène et comme basilik fonctionne très bien, pourquoi s'embêter ?
 

Napoléon

Membre actif
28 Juin 2001
395
18
Paris
Si ça peut te consoler (mais j'en doute ;) ), sheepshaver pose de nouveau problème chez moi, pareil que toi, roue au démarrage et matrice de 0 dans la console...
 

comgil

Membre actif
13 Septembre 2000
194
0
Visiter le site
Ok je laisse tomber pour l'instant. Dommage !
J'ai également essayé de faire un disque OS8 sous Basilisk, ça a marché, mais au second démarrage, il m'a fait une erreur système qui revient systématiquement.

Une corruption de quelque chose je suppose.
Heureusement que tout ça fonctionne en émulation sous OSX, car lui ne plante pas du tout. C'est vraiment rassurant. En tout cas moins frustrant que si c'était vraiment une machine qui ne voulait pas être mise à jour.

Ah vivement Tiger, ma commande doit arriver vers la fin du mois. C'est vraiment une autre génération de système.

@+

:up:
 

menuisier3

Membre enregistré
3 Janvier 2006
8
0
Bonjour,
La dernière version de SheepShaver fonctionne correctement mais je n'arrive pas à monter les CD multisession que j'avais créé à l'époque sur mon performa 475.
Problème aussi avec QuickTime qui veux se connecter à l'ouverture sur internet alors que la config de SheepShaver ne le permet pas !
Si quelqu'un peux m'aider, je l'en remercie par avance, @ bientôt
 

iota

Membre expert
Club MacG
19 Août 2004
5 454
824
39
Paris
Salut.

Concernant SheepShaver, vous trouverez ici, une version expérimentale compilée pour les Mac-Intel.
Il devrait être possible, à plus ou moins long terme, de faire fonctionner les applications OS9 sur les Mac-Intel (qui sont dépourvus de Classic).

@+
iota
 

gemini

Membre enregistré
11 Juin 2005
3
0
41
iota a dit:
Salut.

Concernant SheepShaver, vous trouverez ici, une version expérimentale compilée pour les Mac-Intel.
Il devrait être possible, à plus ou moins long terme, de faire fonctionner les applications OS9 sur les Mac-Intel (qui sont dépourvus de Classic).

@+
iota


salut,

je suis de près l'émulation mac classic et j'ai reussi sous linux et windows xp à émuler un OS 8.6 :
screenshot : http://tacticalopsppl.canalblog.com/archives/2006/02/04/1321351.html
j'attends que l'on me prete un cd OS 9.0 et une rom :S.
 

Thierry6

Membre actif
29 Avril 2003
878
30
Ailleurs
Bonjour,

même question ici
j'ai bien vu ça :
http://www.gibix.net/dokuwiki/en:projects:sheepshaver:help:faq
(which ROM to use with my system)
(pour Didier, ça répond peut être à ta question.)

j'ai essayé de copier le Mac Os ROM de mon dossier système 9.2, de mon CD 9.0.4 et de charger
http://docs.info.apple.com/article.html?artnum=60408
mais je n'y arrive pas, il ne veut pas faire d'update, ce qui est logique. (this update will only run on machines that require the MAC OS ROM)
donc comment trouver cette ROM 3.8 quand on a que des disques de OS9, pas de 8.6 sous la main ?