erreur de commande "AppleDisplayScaleFactor" = Mac bloqué !

ploufside

Membre confirmé
1 Septembre 2010
10
0
Angers
plus.google.com
Bien le bonjour à toute la communauté mac !


Alors voilà je vous explique mon problème :

Possesseur d'un imac intel allu, j'ai récemment eut recours à la commande defaults write NSGlobalDomain AppleDisplayScaleFactor ce qui pour me permet de minimiser la taille de certaines application dans certaines conditions, bref :)

Pour ceux qui connaissent cette commande, on se rend compte très rapidement qu'elle modifie le zoom général de la totalité du mac et donc qu'il faut l'activer et la désactiver en fonction des situations.

J'ai donc tenté de repasser mon mac en zoom normal en tapant la commande defaults write NSGlobalDomain AppleDisplayScaleFactor 100% mais celà a été une énorme erreur !

Je me retrouve maintenant avec un mac qui zoom à 100% de la taille normal des applications / fenêtres etc... Pour exemple la taille d'un icone de mon bureau ne passe pas sur mes 2 écrans (j'ai un switch...)

Je me suis donc tourné vers la seule solution que j'ai trouvée : single user mode !
Je démarre donc mon imac en pressant les touches cmd+s ou cmd+v et j'ai un espoir de pouvoir retaper cette maudite commande dans l'autre sens !

j'essaie donc de taper après root#
defaults write NSGlobalDomain AppleDisplayScaleFactor 1
Commande qui devrais tous remettre en ordre !

Malheureusement terminal me répond "Could not write on domain Apple Global Domain"

Je n'ai donc aucune idée de la façon de remettre mon mac en ordre, et ceci sans passer par la remise à zéro des réglages usine que je préfère mettre de côté : /


Si quelqu'un s'est déjà retrouvé dans un cas similaire et peu m'aider à résoudre le problème ce sera avec un trèèèèèès grand plaisir :)

Cordialement
 

DarKOrange

Modulo
18 Novembre 2004
4 315
349
Paris
Bonjour. Quel rapport avec le thème de ce forum ? Ici on parle matériel. On bouge.
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
J'ai donc tenté de repasser mon mac en zoom normal en tapant la commande defaults write NSGlobalDomain AppleDisplayScaleFactor 100% mais celà a été une énorme erreur !
Bonjour, et bienvenue sur MacGé,


Google est notre ami = http://hints.macworld.com/article.php?story=20060119152725322
et la Recherche sur MacGé aussi = http://forums.macg.co/reagissez/rumeurs-sur-leopard-191149-15.html

Il te suffit donc de repasser par le Terminal pour y taper
Bloc de code:
 defaults write NSGlobalDomain AppleDisplayScaleFactor 1.0
ou d'utiliser les DevTools. :)
 

ploufside

Membre confirmé
1 Septembre 2010
10
0
Angers
plus.google.com
Rebonjour et merci pour ta réponse,

le problème est que mon écran est tellement zoomé après login de l'utilisateur que je ne peut pas acceder au terminal !

je dois donc passer par le self user mode mais je ne peut pas réécrire AppleDislayScaleFactor car il ne s'exécute qu'après le login de l'utilisateur !

Je dois donc trouver une solution à partir du self user mode : /
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 963
3 170
En l'occurrence, ce serait le mode mono-utilisateur.

Pour que ce soit plus simple, le mieux serait d'aller dans la console UNIX au lieu de te logger. Dans la fenêtre de login du tapes ">Console" (ou ">console", je ne me souviens plus) et tu arrives sur un écran en mode texte.
Là tu te logges normalement (il est fort probable cependant que le clavier soit en QWERTY).

Une fois loggé tu vas dans le répertoires des préférences :
Bloc de code:
cd ~/Library/Preferences

Après, tu modifies le fichier .GlobalPreferences.plist.

Pour cela, il faut le convertir en mode XML :
Bloc de code:
plutil -convert xml1 .GlobalPreferences.plist
Puis tu l'édites avec l'éditeur nano (ou vi ou emacs si tu les connais et les apprécies). Les lignes à virer ressembleront à ça :
Bloc de code:
<key>AppleDisplayScaleFactor</key>
<string>0.8</string>
Tu enregistres puis tu quittes.
Tu quittes le shell en tapant par exemple exit (ouCTRL-D).

Tu reviens au login et tu tentes le coup ...
 

ploufside

Membre confirmé
1 Septembre 2010
10
0
Angers
plus.google.com
Merci beaucoup pour vos réponses elle m'on permis d'orienter mes recherches et de voir les choses sous un autre angle.
J'ai finalement trouvé une solution vraiment trop simple, à m'en dégouter >.<

Loggué vous avec un autre compte ou créez-en un en vous loggan en tant qu'admin.
Le Scale n'y est pas modifié !
Vous pouvez donc très simplement ouvrir le terminal, vous loggé sur la session plantée, et lancer les commandes adéquates :)

pour rappel dans la situation actuelle :

defaults write NSGlobalDomain AppleDisplayScaleFactor 1
Encore merci et à bientôt ;)
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
Solution très simple ! :up:

Mais qui me laisse deux questions en suspens. :hein:

créez-en un en vous loggan en tant qu'admin.

Vous pouvez donc très simplement ouvrir le terminal, vous logguer sur la session plantée, et lancer les commandes adéquates :)
Comment créer un compte quand le zoom est à 100 sur la session plantée ?
Ou alors, il faut se logguer en root avec le DVD d'install (Réinitialisation du mot de passe > root).

Ou encore, si c'est possible (mais ça doit l'être), accéder à la session plantée à partir de l'écran Single User,
et y taper la commande qui modifiera le plist dans la session.
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 963
3 170
C'est pour ça que je ne me suis pas orienté vers cette solution : je me suis dit que sans compte tiers, ce n'était pas vraiment possible en l'état ;)
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
Un commentaire de cet article nous rappelle comment créer un nouveau Compte admin en Single User = en effaçant le .AppleSetUpDone. ;)


Mais, dis-moi, est-ce que "su - nom_abrégé" permet en Single User de se placer dans la "session" d'un Compte, comme on le fait dans le Terminal ?
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 963
3 170
Bonne question : à mon prochain démarrage, il faudra que je pense à le tester.

Néanmoins, à mon avis, ce n'est pas possible car les services d'annuaires ne sont pas démarrés donc l'utilisateur ne sera pas connu du système.

Mais ce n'est pas si gênant : on peut se déplacer sur les répertoires du user et les modifier.
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 963
3 170
Le "pas si gênant" faisait allusion au fait de pouvoir, ou non, exécuter un "su" ;)

Je t'accorde bien volontiers que passer des commandes en mode texte avec un clavier considéré comme QWERTY peut être un peu stressant...

Ça ne me stresse pas car :
- j'ai des sauvegardes
- j'ai un clavier QWERTY
- je connais un peu le mode texte

De ces trois points, c'est le premier le plus important :zen:
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
"man defaults" raconte qu'on peut lancer une commande "defaults read ~/Library/Preferences/com.apple.TextEdit" dans le Terminal

= dans le Terminal, on doit donc pouvoir arriver à "defaults write /Users/un_compte/Library/Preferences/com.apple.TextEdit" pour pouvoir modifier un plist dans une autre session,

et donc aussi arriver à le faire aussi en Single User, simplement après avoir monté le Disque Interne. :)


Guillaume Gete (dans "Snow Leopard efficace") écrit, lui, un espace entre le chemin du dossier de Préférences et le nom du plist, au lieu de les accoler avec un slash.
C'est peut-être une alternative, plutôt qu'une coquille ? :confused: