Ce forum est en partie financé par l’affichage de publicités. Merci de désactiver votre bloqueur de publicités pour nous permettre de continuer à fournir ce service.

Erreur gnome-python/gramps

Discussion dans 'Unix, Linux et open source' créé par Yanqing, 15 Juin 2003.

Modérateurs: bompi, daffyb
  1. Yanqing

    Yanqing Membre junior

    Inscrit:
    26 Janvier 2003
    Messages:
    39
    J'aime reçus:
    0
    Bonjour,

    je viens d'installer X11 et j'ai pu télécharger Gimp, Gramps et Gnumeric via FinkCommander, mais en voulant faire d'autres tlg j'ai ce message d'erreur:

    ---
    Setting up gnome-python (1.4.2-1) ...
    /sw/var/lib/dpkg/info/gnome-python.postinst: glibtool: command not found
    dpkg: error processing gnome-python (--configure):
    subprocess post-installation script returned error exit status 127
    Setting up reportlab (1.15-1) ...
    Setting up pil (1.1.2-14) ...
    dpkg: dependency problems prevent configuration of gramps:
    gramps depends on gnome-python (>= 1.4.2-1); however:
    Package gnome-python is not configured yet.
    dpkg: error processing gramps (--configure):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    gnome-python
    gramps
    E: Sub-process /sw/bin/dpkg returned an error code (1)
    ---

    Gimp, Gramps et Gnumeric fctn correctement même si le Terminal de X11 signale :
    Gdk-WARNING **: locale not supported by C library

    Qlq'un peut m'aider? Merci! [​IMG]
     
  2. maousse

    maousse Vétéran
    Club MacG

    Inscrit:
    20 Avril 2002
    Messages:
    7 224
    J'aime reçus:
    445
    C'est un message qui ne porte pas à conséquence. Il y a moyen de s'en débarasser en modifiant la variable LANG dans ton fichier de config, mais tu perdras la version française des applis que tu utilises. Donc, à moins d'un sens de l'esthétique vraiment aigu, ça ne pose pas de problème [​IMG]

    Pour ton installation qui bloque, tu as installé les outils développeurs apple ?
     
  3. Bobbus

    Bobbus Membre confirmé

    Inscrit:
    5 Décembre 2001
    Messages:
    146
    J'aime reçus:
    1
    Visiblement la configuration de gnome-python merde, parce qu'il ne trouve pas glibtool (c'est la ligne
    /sw/var/lib/dpkg/info/gnome-python.postinst: glibtool: command not found )
    Et après, du coup, il ne peut pas non plus configurer gramps.

    Je ne sais pas trop pourquoi il fait ça, tu peux essayer de chercher dans les archives des mailing-lists de fink (sur fink.sourceforge.net) et si la réponse n'y est pas, poser la question.

    Mais si ça marche comme tu le veux, tu peux aussi ignorer tout ça...

    Bob
     
  4. Yanqing

    Yanqing Membre junior

    Inscrit:
    26 Janvier 2003
    Messages:
    39
    J'aime reçus:
    0
  5. maousse

    maousse Vétéran
    Club MacG

    Inscrit:
    20 Avril 2002
    Messages:
    7 224
    J'aime reçus:
    445
    ben, d'après les réponses, glibtool est installé avec les outils developpeur, ou sinon, est installé avec le package gnucash. voilà un résumé des réponses. Les outils développeurs ne sont pas indispensables, mais peuvent se révéler utiles pour bien des raisons. A moins d'un espace réduit sur ton disque, ça ne te gênera pas [​IMG]
     
  6. Bobbus

    Bobbus Membre confirmé

    Inscrit:
    5 Décembre 2001
    Messages:
    146
    J'aime reçus:
    1
    Effectivement, sans outils développeurs, c'est plus difficile...

    Je ne savais même pas qu'on pouvait installer fink sans outils développeurs...
    A installer d'urgence [​IMG]

    Bob
     
  7. Yanqing

    Yanqing Membre junior

    Inscrit:
    26 Janvier 2003
    Messages:
    39
    J'aime reçus:
    0
    Moi non plus... [​IMG]
    J'ai tenté 2 x de les tlg ce week-end en vain (timed out vers 70%). Est-ce qu'ils ne sont pas installés par défaut au moment de l'install de MacOS 10.2? Comment savoir si je les ai ou pas (c'est une appli avec une icône?) ?
     
  8. Bobbus

    Bobbus Membre confirmé

    Inscrit:
    5 Décembre 2001
    Messages:
    146
    J'aime reçus:
    1
    Ils sont sur un des CD livrés avec Jaguar, mais ce n'est pas la dernière version (qui date de décembre).
    Pour savoir si ils sont installés, il suffit de regarder si il y a un répertoire Developer à la racine du disque.

    Bob
     
Modérateurs: bompi, daffyb
Chargement...