Espace fantômes sur voyelles accentuées avec police windows réencodées mac latin

ccciolll

Vétéran
Club MacG
Bonjour,

il m'a fallu réencoder (via X11-fontforge) en mac latin et générer une font truetype Ressource avec la Verdana car celle ci comportait des graisses cachées que Xpress ne savait pas gérer.

Il a fallu pas mal truquer les choses d'ailleurs puisque j'ai dû donner un nom bien différent à chaque typo générées sinon Xpress ne faisait toujours pas la différence entre les graisses.

Sauf que maintenant elle me fait un autre problème.
Dès que je saisie une voyelle accentuée dans le texte, il rajoute un espace fantôme et le texte, s'il est ferré à droite, se décale à l'écran d'autant d'espaces fantômes que de voyelles accentuées sur la ligne et laisse un espace blanc à la fin de la ligne

voir exemple image testecr


Plus curieux encore, à l'impression, ce n'est pas un espace blanc le résultat. La première lettre reste bien là où elle apparait à l'écran mais le reste du texte subit une approche de groupe pour que la dernière lettre soit calée sur le ferrage normal.

voir exemple image testimp



Comment faire pour avoir toutes les graisses de la Verdana dans Xpress sans pour autant qu'elle pète les plombs comme ça ?
 

ccciolll

Vétéran
Club MacG
Bon, il semblerait que j'aie trouvé une solution à ce problème. Toujours en partant de la verdana de base, sans réencoder cette fois ci, je change le nom bien sûr, et ensuite je génère un font True Type tout court (.ttf) et cette fois ci pas d'espaces fantômes, enfin je crois, j'ai pas fini tous les tests.
Le seul problème c'est que mon collègue en os9 ne gère pas les ttf. Mais il a un logiciel (TTconverter) qui apparemment sait changer les TTF et ça semble aussi aller bien chez lui.

Si qqun a compris quoi que ce soit à cett emésaventure qui m'â coûté près de 3 heures, qu'il nous explique.