Filevault2 & Utilitaire de disque. Partitions verrouillées?

xabikoma

Nouveau membre
6 Décembre 2010
3
0
45
Bonjour à tous,

C'est un demi-problème, et peut-être pas un problème du tout, mais je n'ai pas trouvé de doc précise là dessus.

Hier, je me suis décidé à activer Filevault sur mon MBP 15" mid-2010 sous Lion 10.7.2...
Jusque là, tout va bien, Disque dur chiffré, pas de ralentissement, tout marche à merveille, 6h pour chiffrer un HD de 750Go.
J'ai aussi un 2ème HD de 750Go installé à la place de mon lecteur DVD, que je n'utilisais plus. J'ai donc décidé de le chiffrer également via la procédure trouvée ici:
http://www.red-sweater.com/blog/1935/lions-whole-disk-encryption
, ce qui a marché à merveille aussi.

En fait, tout va bien, tout fonctionne parfaitement... Sauf un détail qui m'intrigue...

Si j'ouvre l'utilitaire de disque, je n'ai plus accès à aucune option sur mes partitions chiffrées, comme vérifier ou réparer le disque/les autorisations, démonter le disque, elles apparaissent grisées et sont indiquées comme "non montées"
A priori, je peux quand même reformater, restaurer, mais même pas éjecter les disques. En tout cas, pas via l'interface graphique, mais je le peux via le terminal.

Je suis admin de ma machine, j'ai bien ma clé (pas de soucis de ce côté là), et donc accès à mes disques et tout et tout.
J'ai essayé en root, et là, mes partitions ne sont plus grisées dans l'utilitaire de disque, je peux démonter la partition, vérifier, réparer, mais bon, c'est du root quoi...

Ma question, en résumé: est-ce que c'est normal, dû au chiffrement de mes disques? ou bien est-ce j'ai quelque chose qui ne tourne pas rond? En gros, est-ce que je me prend la tête pour rien? :siffle:

j'ai rebooté plusieurs fois, réparé les autorisations via terminal, etc... Pas de changement.

Une petite capture de mon utilitaire de disque:

Si quelqu'un pouvait m'éclairer, je suis prêt à lui payer un godet!

Merci!
 

xabikoma

Nouveau membre
6 Décembre 2010
3
0
45
Et bien, oui, je ne l'ai pas activé que pour m'amuser, dans la mesure où je passe plus de 6 mois par an en déplacement à l'étranger, et mes données sont sauvegardées régulièrement et stockées chez moi.
Merci de t'inquiéter pour moi, ça fait toujours chaud au coeur :up:
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
Ma question, en résumé: est-ce que c'est normal, dû au chiffrement de mes disques?
Je dirais : c'est dû au nouveau chiffrage de tes disques.

FileVault 2 chiffre le Disque : il englobe tout le disque dans un cocon imperméable.
C'est sa façon de faire.

L'ancien FileVault, alias Legacy FileVault, ne chiffrait que la partition OS X.

Alors, ça me semble logique qu'Utilitaire de Disque ne puisse réparer que les Disques, et pas les partitions, dans ta capture d'écran.


Remarque aussi que le démarrage sur ton Mac chiffré se fait plus vite que sans chiffrage
= avec FV2, tu démarres sur la partition EFI : ce n'est qu'après avoir fourni le mot de passe que tu accèdes à ta partition OS X.
 

xabikoma

Nouveau membre
6 Décembre 2010
3
0
45
Merci, c'est ce que je me suis dit aussi, mais je n'ai trouvé de précision là-dessus nulle part...
Je ne trouve pas ça très logique, dans la mesure où j'ai entré mon mot de passe, je ne comprends pas le sens de cette limitation, d'autant plus que onyx ou le terminal me permettent de réparer les autorisations.
Pas très "user-friendly"...
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)